BIOS update gone wrong

Good day,

I was updating my BIOS… I created a ISO to boot the latest BIOS for my thinkpad E14 gen2 (I have never updated the Bios) Then booted it and everything worked fine! The installation went well!
I was quite proud of myself I’m not going to lie… Unfortunately after rebooting the all system I can see the Endeavour booting choices LTS or Lastest but after that Black screen! I’m not able to do anything else than pressing the power button…
So my first question is do I need to THIS?
Is it a grub issue?
Thank you!

Can you boot from EndeavourOS ISO image? If so, you can chroot to your installed system and regenerate grub config, remove the USB drive and try to boot.

Yes so I run a Chroot and then did:


But still this haven’t work…

What exactly did you do? Did you mount your drives in the correct order? First the root filesystem, then the EFI partition…

Also, rebuilding the grub config is done with:

grub-mkconfig -o /boot/grub/grub.cfg

Yes I mount everything properly as I can update my system etc… with the terminal I enter the command grub-install
grub-mkconfig -o /boot/grub/grub.cfg

This did not work unfortunately

While in the chroot, try to reinstall the kernel:

pacman -Syu linux linux-headers

Since the ISO image is booting properly, the problem must be with your installed system.

I don’t know if this helps but that about where I’m stuck!


Try to boot with the mainline kernel (the one you’ve just reinstalled), not lts. You should have the option to choose the kernel in the grub menu.

1 Like

Unfortunately this did not work :frowning: now I just got a black screen… On the positive side tho my Bios is definitely updated!

PS: really appreciate your help!

1 Like

Did you check the graphics drivers? Is it a NoVidea GPU?

Can you boot to a TTY? Do do so (make sure the USB with the ISO image is removed), you press the E key during the grub menu and add 3 to the end of the kernel parameters (the line which begins with linux)…

1 Like

I do not think this has anything to do with that everything was working without a problem before the BIOS update… Just seem like I can’t boot to the system… Otherwise everything is working while I’m in Chroot

If you can boot to a TTY on the installed system, then it’s almost certainly the graphics drivers. If you can’t even boot to a TTY, then I’m really out of ideas… The fact ISO image boots properly means that there is nothing wrong with the bios and that the fault is somewhere in the installed system.

I’m very confused too I just run a BIOS update via USB iso then the update went well as I checked the version I got now 1.20 but now nothing works :frowning: Arghhhhhhh almost a year without bloody reinstalling the all system!!!

No, don’t reinstall, this can be fixed, just need to figure out how…

Did you manage to boot to TTY?

Yes I can just don’t know which one I need to log in I’m not at all familiar to TTY I try TTY 2

Any TTY is okay, just login with your user account.

This means your computer boots just fine, the problem is with the graphical session starting. So for this, I would investigate the drivers.

At least you now have access to your system without having to chroot. That’s something…

1 Like

To confirm that it’s on Chroot right?

No, no, no… Chroot means boot with another system (the live ISO image) and change the root (chroot) to the installed system.

You’re not chrooting now, you don’t use the ISO image. You are booting your installed operating system to the TTY (a text mode console interface).

When you boot to the TTY your OS is working normally, it just doesn’t start the graphical session.

1 Like

Okay so that did not work… Black screen nothing is happening looks like the OS does not want to boot that all…

Maybe when you updated your bios, it loads default and prior settings could have reverted, if you can enter in your bios to check if secure boot is disabled, you’re operate on AHCI mode, you’re hard drive first in the boot order, disable fast boot and enable CSM (compatibility support module) and if you’ve got a option “windows or other OS”.