Bios does not recognize Endeavour partition

Ok, I F’ed up again. I tried to do a portable install on a usb drive from my laptop, which worked, but now my computer will not boot into my old Endeavour install.

I have an old HP 15-F014WM that worked just fine (as far a boot) until I tried the install. I have 4 systems on it: Windows 10, Kali, Android x86, and Endeavour. Now all my bios sees is all the others, but no Endeavour. I can only get it to boot if I manually select the EFI file from the Bios at boot.

I am not sure if it changed, but now it is showing the boot info on partition 6, with the others on partition 1. When I select partition 6 I find Endeavour and partition 1 has the others. This is not serious as I can just reinstall, but I would like to know how to fix it. I thought that maybe just updating grub would work (sudo grub-mkconfig -o /boot/grub/grub.config) but no such luck.

Thanks.

I think you will have to boot on a live usb and arch-chroot and reinstall grub and then update grub on the installed EndeavourOS. I usually disable all other os from being able to detect other installed OS so it only updates what you are booted into and doesn’t take over the boot loader. You want only EndeavourOS grub to control the boot so it should be the only one finding other os. I’m not familiar with how Android x86 works so i can’t comment on that.

I also do the same on the install on the usb stick so that you only boot from it by using the F keys on boot and when updating it doesn’t also find any other os and take over. So normally then when you boot it would boot from the settings that are in Bios. The only way you boot on the installed usb is from an F key to select the boot order.

Maybe someone else does it differently or has another solution. :man_shrugging:

Edit: If the installed EndeavourOS is controlling the boot it will also find a usb stick and add it to the boot too. I personally don’t want that so i would not have the stick in the computer if i was updating.

Ok, I’ll pull my manual back out for chroot and reinstall grub (Endeavour is making me lazy!). I remember having a problem when I tried this before, but I assumed the problem came from detecting other OS’s in the grub config and that was disabled in the new version. I thought it would work fine this time. I was obviously wrong.

One of the issue’s too is that other OS don’t always play nice with arch so they may not work well if they are controlling the boot.

That is the crazy part though. The other OS’s coexisted just fine. What broke the system is when I installed a second Endeavour OS onto a thumb drive for a portable setup. (Boot from USB then full install on second USB). That is what broke my system. I can still boot into it, I just have to select the EFI file from the bios boot menu when I press F9. It is not listed when I actually go into the Bios under the boot menu.

Sorry, kinda confusing. But if I can boot into my system using the EFI file method, could I just reinstall grub like you said without having to chroot into it?

I am starting to think this is a Bios issue. It is a secure boot W8 computer.

I know what your saying. So your system is UEFI not Bios. It gets confusing because everyone refers to it as Bios but it’s not the same. It’s obviously switched efi boot on you. You can check the boot with this command to see which is booting first.

efibootmgr 
Timeout: 0 seconds
BootOrder: 0004,000F,0008,0000,0010,0013,0014,9998,0001,0003,0006,0002,0007
Boot0000* Windows Boot Manager  HD(1,GPT,ffbb8e97-0e51-48b5-b05a-717475b86dad,0x800,0x32000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)57494e444f5753000100000088000000780000004200430044004f0042004a004500430054003d007b00390064006500610038003600320063002d0035006300640064002d0034006500370030002d0061006300630031002d006600330032006200330034003400640034003700390035007d00000049000100000010000000040000007fff0400
Boot0001  ubuntu        HD(6,GPT,e5b4b3c2-2109-b14f-a9fb-da8f7a376347,0x6e9a4800,0xfa000)/File(\EFI\ubuntu\shimx64.efi)
Boot0002  Manjaro       HD(7,GPT,e66899a2-c7b5-da48-ad12-3778768a5b30,0x13400000,0xfa000)/File(\EFI\Manjaro\grubx64.efi)
Boot0003  grub_uefi     HD(10,GPT,77cd76b6-03eb-0c41-a8df-569e0458d5ed,0xc34f800,0xfa000)/File(\EFI\grub_uefi\grubx64.efi)
Boot0004* endeavouros   HD(1,GPT,674dcf53-5993-8b4e-b0a4-d19cf9dd5416,0x1000,0x96000)/File(\EFI\endeavouros\grubx64.efi)
Boot0006  debian        HD(1,GPT,827e0a6c-9dcd-4e12-844e-aa6ec5d6ee8e,0x800,0x32000)/File(\EFI\debian\shimx64.efi)
Boot0007  Arch  HD(4,GPT,35fb22cf-e76e-40fe-ad81-925090b09a01,0xc701800,0xfa000)/File(\EFI\Arch\grubx64.efi)
Boot0008* Android-x86 8.1-r6    HD(1,GPT,ffbb8e97-0e51-48b5-b05a-717475b86dad,0x800,0x32000)/File(\efi\Android\BOOTx64.EFI)
Boot000F* kali  HD(1,GPT,ffbb8e97-0e51-48b5-b05a-717475b86dad,0x800,0x32000)/File(\EFI\kali\grubx64.efi)
Boot0010* Internal Hard Disk    PciRoot(0x0)/Pci(0x11,0x0)/Sata(0,65535,0)/HD(1,GPT,ffbb8e97-0e51-48b5-b05a-717475b86dad,0x800,0x32000)0000424f
Boot0013* Internal Hard Disk    PciRoot(0x0)/Pci(0x11,0x0)/Sata(0,65535,0)/HD(6,GPT,ee45143d-b271-1449-94b8-198c16875941,0x12c00000,0xc8000)0000424f
Boot0014* USB Drive (UEFI) -  USB       PciRoot(0x0)/Pci(0x10,0x0)/USB(3,0)/HD(2,MBR,0x67d633f,0x3528000,0x10000)0000424f
Boot9998* Internal CD/DVD ROM Drive(UEFI)       PciRoot(0x0)/Pci(0x1d,0x0)/USB(16,0)00000000424f

Interisting. It is listing Debian, Manjaro, and Ubuntu which have never been on this device, unless it was installed prior. I did buy this computer from the pawn shop.

Can you add code tags before and after what you posted to make it easier to read?

Next time you could just edit the previous post. You didn’t have to re-post it.

If you want to clean up some of those entries and delete them i can tell you how.

sudo efibootmgr -b <bootnum> -B

Just add the number as listed inplace of (bootnum) in order to remove the entry.

example:

sudo efibootmgr -b 0001 -B

Then run efibootmgr and you’ll see the new entries.

1 Like

Go it. Used to an old truck forum that was unable to do that. I also didn’t notice till now that the page is live and the posts automatically update. Cool.

You should be able to get it working again fairly easily.

OK, and how do I set the default one? It looks like the right one is set, but it would be nice to know when I play with it later.

Oh, and what do the asterisks mean?

To set the boot order just arrange them in the order you want like this.

sudo efibootmgr -o 0004,0000,0003 
1 Like

The astericks means active. So the others are inactive.

Edit: Even though it has EndeavourOS as first boot it may have changed because of your installs on the usb and the EndeavourOS it refers to may be the one on the usb. You most likely are going to have to arch-chroot and reinstall grub on the installed EndeavourOS and update grub.

Edit2: I understand this may be a bit of a pain but what it does is get you familiar with having to arch-chroot and be able to fix your system if it doesn’t boot. arch-chroot is fairly easy. You just have to mount the / of the installed system then mount the /efi or boot partition and then arch-chroot into the /mnt. Then you reinstall grub and update grub. Then you exit or unmount and reboot. Of course you have to use the right commands and have the correct partitions to mount.

Edit3:

https://discovery.endeavouros.com/system-rescue/arch-chroot-for-efi-uefi-systems/2021/03/

https://discovery.endeavouros.com/system-rescue/repair-a-non-booting-grub/2021/03/

1 Like

I’ll try the chroot, I just have to look up how to do it with my btrfs setup. I only used ext4 in the past which was simple, but I guess it is time to learn how on btrfs since it seems to be the future. Snapper is 100x better in my opinion than using Timeshift and ext4. I have only used it once, but that one time was way easier than Timeshift.

Yes it’s a little different with btrfs. It’s listed in the links i posted.

Edit: I also have btrfs with snapper so i have done it a couple of times too.

It worked. Thanks for the help. Not only did I learn more about chroot I also learned I can change the boot order right from efibootmgr.

This is why I love Linux: it breaks and you learn how to fix it. When Windoze breaks, you learn why you should hate it more!

1 Like

Glad you got it resolved. I use btrfs and i’m running btrfs assistant, snapper and snap-pac. I don’t have it set up to boot into snapshots. It’s been very reliable for me.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.