Battery Icon Issues

I have been looking for my problem and it seems to be common among people who use kde, the battery icon shows that it is charging even if it is not connected.


I have used the upower command for more information on this in case it helps to solve the problem:

[pikaloid@FlowX16EndeavourOS ~]$ upower -i /org/freedesktop/UPower/devices/battery_BAT0
  native-path:          BAT0
  vendor:               ASUSTeK
  model:                ASUS Battery
  power supply:         yes
  updated:              lun 12 jun 2023 23:10:39 (2 seconds ago)
  has history:          yes
  has statistics:       yes
    present:             yes
    rechargeable:        yes
    state:               discharging
    warning-level:       none
    energy:              54,911 Wh
    energy-empty:        0 Wh
    energy-full:         80,233 Wh
    energy-full-design:  90,001 Wh
    energy-rate:         13,188 W
    voltage:             15,986 V
    charge-cycles:       N/A
    time to empty:       4,2 hours
    percentage:          68%
    capacity:            89,1468%
    technology:          lithium-ion
    icon-name:          'battery-full-symbolic'
  History (charge):
    1686604149  68,000  discharging
  History (rate):
    1686604239  13,188  discharging
    1686604209  14,531  discharging
    1686604179  16,785  discharging
    1686604149  28,870  discharging

I can’t think of what to do from here, any help will be appreciated! :smile:

PS: I have tried installing upower-git from the AUR but nothing changed after reboot.

My Kde doesn’t even show the battery icon? :thinking: I don’t pay much attention until now.

It’s probably hidden in the icon box.

Yes i see here where it is on my desktop so I’ll check later on the laptop.

No issue here, how is yours set up to display it, mine is set to display when relevant


As a side note I did have some weird issues due to settings in my bios a while ago

I’m on a desktop and haven’t checked my laptop yet.

Edit: On the laptop

I’ve tried “when relevant” and “always” but same result, from what I have read it may be a problem due to the fact that my computer also supports usb-c charging but I am not sure if it is the problem completely, I will try to fully discharge the battery in case it is a battery info error.

Have you checked youre bios/uefi settings also as I have also mentioned? Otherwise I have no idea what else to suggest. But it may help others to help troubleshoot this issue.