Bash shell not changing

So, I loved the Manjaro shell look. After some asking, I came upon this lad’s tutorial:

With this, I managed to create a .zshrc, I set up oh-my-zsh with the plugs shown in the video…
But once I left the shell, that was it. All gone. When I run which $SHELL it shows /bin/bash. I’ve tried several different ways of chsh -s /usr/bin/zsh user and I either get shell changed without any of my .zshrc configuration, or it says it doesn’t change. How do I set zsh to be my default and not bash?
OS: EndeavourOS Linux x86_64
Kernel: 5.17.5-arch1-1
Shell: bash 5.1.16
DE: Plasma 5.24.5
Terminal: konsole
CPU: Intel i7-4790K (8) @ 4.400GHz
GPU: NVIDIA GeForce GTX 1070 Ti
GPU: Intel HD Graphics

Is your .zshrc file still the same as it was before or did it change?
The command

chsh -s /bin/zsh

should change your shell after you logout and login (this is important). Don’t forget to enter the password when it asks you after the chsh command.

Ah, I’m sorry, I think rebooting my PC did the trick. Thanks for the help though!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.