Barracuda vpn Bufferoverflow


I tried to install barracudavpn via AUR and also via a deb file and both instances produce a bufferoverflow when executed.

*** buffer overflow detected ***: barracudavpn terminated
======= Backtrace: =========
======= Memory map: ========
00400000-0090a000 r-xp 00000000 103:02 23660903                          /usr/bin/barracudavpn
00b0a000-00b47000 rw-p 0050a000 103:02 23660903                          /usr/bin/barracudavpn
00b47000-00b61000 rw-p 00000000 00:00 0 
00fe8000-01051000 rw-p 00000000 00:00 0                                  [heap]
7f8611519000-7f861151b000 rw-p 00000000 00:00 0 
7ffe29bae000-7ffe29bcf000 rw-p 00000000 00:00 0                          [stack]
7ffe29bf7000-7ffe29bfb000 r--p 00000000 00:00 0                          [vvar]
7ffe29bfb000-7ffe29bfd000 r-xp 00000000 00:00 0                          [vdso]
ffffffffff600000-ffffffffff601000 --xp 00000000 00:00 0                  [vsyscall]
[1]    70951 IOT instruction  sudo barracudavpn

Is there any fix for this? I am pretty new to EndavourOS and love it. :slight_smile:

That looks like something you should report to the software developers - does Barracuda VPN have some support routes?

I have no idea how tbh. I tried to chat with them but they didnt respond. sooo :person_shrugging: Very unfortunate because i need it for work. I tried setting it up via a proxy vm but without success :frowning: