Baloo our good ol' "friend": No search results while file indexing is enabled

Plasma DE here.

Whenever I try to search for example, videos ending with .mp4 extensions (I have a lot of these kind of files), I got no results while the file indexer (balooctl6) is enabled.

The file indexer is set to only index my /home folder, and nothing else, hidden files are excluded and its set to only index file names but not its contents.

So, these example video files are on my external drives. Now - when I type .mp4 in the search field, I get no results. And here’s the twist: when I disable the file indexing, then I get results. But my problem however is that keeping the file indexer disabled, screws up the search results when I search within my actual indexed /home folder, because it gives back results from system files too, so it’s like a never ending circle of doom.

I already purged the database via balooctl6 purge. I’ve read that balooctl is insanely unstable, now I see what people mean by that.

Is there a proper solution to keep the indexing on, but still be able to search on external drives without indexing them?

I also tried to exclude my external drives (even though as I mentioned earlier that I explicitly set that to only index my /home), just to see if its a bug or not, but nope, I get no search results from my external drive. :confused:

Actually most of the issues with baloo have been resolved in plasma 6.

How are you searching?

1 Like

I open dolphin, go to the folder where I want to search within, then I press CTRL+F to open up the search box up the top of the Dolphin’s address bar. Then I just type in for example .mp4 or .jpg and hit Enter.
Get no results. Turned off file indexing, typed in the same exact words, I get results. I thought it must have been something with my regex keywording, but then I tried to look for file names also, like mypicture.jpg and only typed in mypicture - same symptoms, no results. Turned off baloo, mypicture.jpg showed up.

I use Dolphin and I prefer the filter bar. Way faster. And I don’t use KDE, so no baloo.



This method gives immediate results/feedback.

1 Like

How does that filter bar work?

EDIT: Got it. Search Filter :wink:

1 Like

Hmm…I just did a test on my end and I can’t duplicate this.

I can search both internal and external drives with baloo enabled even if they are outside what I am indexing.

I believe it filters the results. So if you are looking in a single directory, it will filter the results it is showing but not search.

2 Likes

Thanks mate, but the problem is that it doesn’t go into subfolder, only searches within the actual current folder. I’m a datahoarder, see my situation as having 3TB of files, while having huge directory trees. I can’t go within each of them one by one :smiley: But thanks for the reply though

1 Like

It’s not even really a search. It just filters for whatever you type.

1 Like

My system is completely in German. I have to rethink such specific things

EDIT: You talk about the search symbol in Dolphin?

Out of curiosity, can you send me back what this gives you back, just to isolate:
systemctl --user status kde-baloo and systemctl --user status plasma-baloorunner.service

I see. 3TB… Lord…

While you work on finding a fix, I’ll offer an alternate tool — XnViewMP. It’s meant for media, but you can turn off thumbnails, playback, etc. and use it like a regular file manager.

I recommend it because it has a feature which allows you to view all the contents in all subdirectories of a folder, which you can then filter in the same way I described for dolphin above.

1 Like

No. It’s a bar you can enable.

1 Like

I know right, its a lot xD Thanks pal, defo gonna give it a shoot :smiley:

1 Like

Yes thank you. I can show or hide the bar using the search icon or simply strg + f. We are talking about the same

We aren’t, actually. See below:



But for some reason, I can’t find the setting to turn it on/off. :confused:

1 Like

Now i got it. Seacrh is strg +f and filter is strg +i

you can turn off by clicking the x :wink:

1 Like

Yes, was just about to type that. CTRL + I for English keyboards.

That I knew, but didn’t want to click it and not be able to find it again. :laughing:

1 Like

Same on german keyboards :wink:

Lol. You typed:

:sweat_smile:

1 Like