Autostart ->Program at KDE/Plasma launch

Hi
I have looked up various pages online looking for the answer, Ive done this before and can not remember how. I wish to run a command at start up/Login “streamdeck -n”

I can do this at the prompt but it grabs output and closes when prompt closes,
I therefore if doing manualy from the prompt have to enter “nohup streamdeck -n &”.

I have created a small bash script to be run at startup, however this does not seem to function,
the only thing I can think of is IAm running ZSH rather than Bash.

Manual input from prompt
Prompt
Script
Contents
Autostart
autostart
Autostart Properties
AutostartPropertise

What changes / What have I done wrong?


Data

1 Like

Go to Settings - Startup and Shutdown - Autostart
and add your script there

Hi
That was my first choice. But it still does not launch at boot/launch/login
It’s missing something!!


Data

Try this:
move the script out of ~./config/autostart/
Add the script again from the new location in
Settings - Startup and Shutdown - Autostart

I don’t know about ZSH, but the duckduckgo says:
To use zsh explicitly, add the shebang as:
#!/usr/bin/zsh

Hi
Thanks for the info-Shebang.zsh
I made a new directory in home as suggested,
NewFolder

Altered shebang
Reapplied chmod a+x streamdeck1.ls


I tried adding it as a normal autostart
I also tried adding it as a logon script

No Joy.


Bamboozled Data

The script does work if you db-click on it?

If streamdeck is an application, you should add it as that and not as script

Hi thanks for continued efforts :slight_smile:

When I start/attempt the program/script in dolphin I get!!!
DolphinStartAuto
when I execute the script from the prompt It works.
FromTerminator

To answer you : This is an python scripted program, as such it has no “application” I can confirm
that the script streamdeck(not confuse with my script) is on the command path.


Data

Try

python streamdeck -n

or

python3 streamdeck -n

in a terminal. If this works, put it into the script and see if it works.

Hi
Sorry it looks for a file or program… Phython does.
Python


Data

1 Like

How about (just guessing :wink:):

python /path/to/streamdeck

?

Grand Solved. Thanks @pebcak

#!/usr/bin/zsh

python ~/.local/bin/streamdeck -n

EDITED
“Solution highlighted as requested below”

@ricklinux lock pls thanks for your patience.

1 Like

Great! Glad you got it sorted out!

If you are content with the outcome, please consider to mark the appropriate post as the solution. In this way the forum software will also recognize it as such and others searching in solved threads looking for a solution to similar problem would find it more easily.

:enos_flag:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.