Automatically switch to bluetooth speaker once connected

My bluetooth headphones do connect automatically once I turn them on, however I always need to manually switch the speaker to the headphones through the audio plugin in the panel.

Is there a way to prevent this so that the speakers are automatically switched to my headphones once they are connected? Thanks

Sound server: Pipewire with wireplumber
Bluetooth Headphones: Samsung Galaxy Buds

eos-sendlog just in case

  1. Get bluetooth support (pipewire is default, generally speaking pipewire is preferred):

Please read this for full details:

For pipewire: sudo pacman -S --needed bluez bluez-utils

sudo systemctl enable --now bluetooth

^you must run this command for Gnome (will work for other DE’s too) to even turn Bluetooth ON^

Reboot and test before trying Step 2 please.

  1. IF you’ve already done the above steps before, the next option is to adjust the AutoEnable Policy:

Fix bluetooth issues on reboot for Gnome 42: Auto power-on after boot/resume:

Please read this for full details:

sudo nano /etc/bluetooth/main.conf and look for AutoEnable and uncomment it (remove the # in front of it, so that it becomes enabled) so that it looks like this:



Then make sure your save the file and exit nano.

Reboot and test before trying Step 3 please.

  1. This is taking it one step even further, but in my opinion you generally shouldn’t need to go this far, but it’s easy to try:

If the device should always be visible and directly connectable:

sudo nano /etc/bluetooth/main.conf and look for this line and remove the # to enable DiscoverableTimeout so it looks like this:


DiscoverableTimeout = 0

I would try each step one at a time, reboot, see if it fixes your problem, if not, then go on to the next step. For most users Steps 1 and 2 should be all you need to really do to get bluetooth to automatically turn on and connect to your device during login, but some hardware (aka very old or very new bluetooth protocols) can be a bit hard to troubleshoot, so you’re experience may vary. Good Luck and hope this was helpful!

1 Like

No, there is no way. It is a known issue between wireplumber and pavuctrl. You may try switching to pipewire-media-session, but the issue is likely to persist, I would guess.

Installing easy-effects (former pulse-effects) only makes it much worse, as then there are many more audio-sinks to be set manually.

Keeping the last settings of pulse-audio doesn’t seem to be implemented in pipewire, at all yet, as I have followed some discussions on the web, so far. It seems to be a matter of incompatibility between pipewire and pulse-related sessions, and both are blaming a “potential issue” on each other.

YMMV, so please correct me, should I be wrong, people, as I’ve been seeking for a solution to this for months now myself.

Thanks for the info. It’s not a huge problem, just slightly inconvenient.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.