AUR Update Check - wirft Fragen auf

hallo und guten Tag liebe Community,

der AUR Update Check - wirft Fragen auf


: Paketänderungen werden verarbeitet …
(1/5) Aktualisiert wird blas                                 [--------------------------------] 100%
(2/5) Aktualisiert wird lapack                               [--------------------------------] 100%
(3/5) Aktualisiert wird nmap                                 [--------------------------------] 100%
(4/5) Aktualisiert wird unrar                                [--------------------------------] 100%
(5/5) Aktualisiert wird xfce4-settings                       [--------------------------------] 100%
:: Post-transaction-Hooks werden gestartet …
(1/4) Arming ConditionNeedsUpdate...
(2/4) Updating icon theme caches...
(3/4) Checking which packages need to be rebuilt
(4/4) Updating the desktop file MIME type cache...

AUR Update-Check:
:: Durchsuche AUR nach Updates...
 -> Fehlende AUR Pakete:  grub-tools  grub2-theme-endeavouros  ipw2100-fw  ipw2200-fw
 -> Verwaiste AUR-Pakete:  gn-m87
:: 3 Pakete zu aktualisieren.
3  aur/celt                    0.11.3-4 -> 0.11.3-5
2  aur/python2                 2.7.18-7 -> 2.7.18-8
1  aur/visual-studio-code-bin  1.73.0-1 -> 1.73.1-1
==> Pakete zum Ausschließen: (z.B. "1 2 3", "1-3", "^4" oder Repo-Name)
==>

ich bin nicht sicher - hab aber doch diese Fragen des öfteren.
Kann ich denn hier ein für alle Mal diese Fragen los werden.

btw. VSCOde ist wichtig - das ist mir wichtig und das brauche ich.

vielen Dank u. euch allen einen schönen Sonntag.

Was ist konkret deine Frage jetzt?

Pakete zum Ausschließen: (z.B. "1 2 3", "1-3", "^4" oder Repo-Name) fragt dich, ob du irgendwelche von diesen 3 genannten Pakete nicht aktualisieren möchtest.
Wenn du Einfach Enter drückst (also nichts eingibst), werden alle 3 Pakete aktualisiert.
Wenn du z.B. 1 eingegeben hättest, würde sich visual-studio-code-bin nicht aktualisieren.

Fehlende AUR Pakete: grub-tools grub2-theme-endeavouros ipw2100-fw ipw2200-fw sagt dir, dass diese Pakete in der AUR nicht mehr zu finden sind. Wieso sie von dort gelöscht wurden, wird seine Gründe haben, aber du kannst eigentlich jetzt nichts dafür machen.
Diese Pakete sollten gelöscht werden.

Verwaiste AUR-Pakete: gn-m87 habe ich keine Ahnung was das bedeuten soll. Hatte es nie.

Wenn ich Mist erzählt hatte, jemand wird mich korrigieren.

Hallo Smokus
vielen dank für deine schnelle Antwort. Also zu den fehlenden AUR Paketen:
ggf bin ich da (mit meinem Laptop) verantwortlich. Hab ab und zu Abstürze - wenn nämlich das Lappy ein asus L54 mit 4 gb auf I3 CPU und mit ggf. zu vielen Vivaldi Tabs - dann oft friert alles ein u. ich schalt das Notebook einfach aus.
Mir wurde neulich gesagt - dass solche Dinge ggf. durchschlagen auf die Software - usw. usf.

zu den Paketen - ich hab die FRAGE der AUSWAHL immer wieder. Python 2 ist für mich kaum relevant, VSCode hingegen schon.

Vielen vielen 'Dank für deine Antwort u. die vielen Tipps die du gegeben hast.
ggf muss ich Vivaldi im alltägl. Betrieb einfach abspecken.

viele viele Grüße

Das wirst du auch immer haben. Wenn du yay Befehl im Terminal benutzst, um nach neuen Updates zu suchen (das durchsucht sowohl official repos Pakete als auch AUR Pakete), dann werden dir immer zuerst alle Pakete aufgelistet, für die ein Update gefunden wurde.
Du wirst dann immer bestätigen müssen, ob du wirklich das Update ausführen möchtest.
Das ist normal.

Python2 kannst du wahrscheinlich löschen, falls es nicht verwendet wird.

When the maintainer(s) of an AUR package abandon the maintenance of the package, it will become “orphan”. It is then up for adoption if someone else would step in and take responsibility for its maintenance.

2 Likes

Oh yeah, that was bad on my part. I read the word Verwaiste wrongly. That’s actually an orphaned package as you said. You described it nicely then.

1 Like

Ganz unten stehen 3 AUR Pakete, für die es ein Update gibt, im Normalfall drückst du einfach auf enter und spielst die Aktualisierungen ein. VSCode würde ich aktualisieren, den Rest nicht, also wäre die Vorgehensweise das du die anderen Pakete vom Update ausschließt indem du 2-3 eintippst und enter drückst.

Die verweisten Pakete, celt und Python 2 würde ich prüfen ob die benötigt werden, wenn nicht, dann würde ich sie entfernen.

Wenn ipw2100 oder ipw2200 nicht von deinem System benötigt werden, kannst du sie entfernen.

Führe mal folgenden Befehl aus

inxi -Na

Sind unter Network unter Driver weder ipw2100 noch ipw2200, kannst du sie löschen.

Edit:

Celt kannst du löschen und python2 kannst du überprüfen ob es gebraucht wird mit:

pactree -r python2

Wenn der Befehl nichts zurück gibt, kannst du es entfernen

Die Pakete waren nicht im AUR, die müssten in extra oder community gewesen sein und wurden entfernt (vermutlich weil obsolet).

Aufpassen beim grub2-theme-endeavouros - wenn man das entfernt gibts ne häßliche Fehlermeldung in Grub (sofern das Theme dort noch eingetragen ist). Da sollte man vorher die Grub-Config anpassen.

2 Likes

Hallo pycrk, hallo Smokus, hi apollo und peback :slightly_smiling_face:

vorweg: vielen Dank für Eure Tipps, Ideen und Anregungen.

[quote=“apollo, post:9, topic:33849”] Die Pakete waren nicht im AUR, die müssten in extra oder community gewesen sein und wurden entfernt (vermutlich weil obsolet).

Aufpassen beim grub2-theme-endeavouros - wenn man das entfernt gibts ne häßliche Fehlermeldung in Grub (sofern das Theme dort noch eingetragen ist). Da sollte man vorher die Grub-Config anpassen. [/quote]

also ich werde den:
a. Update machen wie empfohlen
b. die orphaned packages nacheinander enfernen
c. bei grub2-theme-endeavouros - wie apollo geraten hat - auf alle Fälle aufpassen. Das werde ich am besten nicht antasten.

und hier noch was ganz generelles: ich setze schon ziemlich lange Linux ein - und hab bei Suse ‘(opensuse’) angefangen, dann Ubuntu, Mint, Manjaro und MX eingesetzt.
Also - die Community-Erfahrung - die Hilfsbereitschaft, der tolle Spirit hier in diesem Forum - bei EOS ist wirklich bemerkenswert. Vielen vielen Dank euch allen. Das ist wirklich ganz besonders klasse hier -…

PS. Ich hab zwei Notebooks an denen ich in einer Wochenfrequenz arbeite. M.a.W. ich komme an die dann abwechselnd ran. Und da (her) kommts dann dazu dass ich immer wieder in gewisse …

-Update
-Konfigurations
-Installations - Themen komme.