AUR program installs infinitely for hours

Hi friends, I have several questions.

When I install a program like Steam, it gets installed from the EXTRA repository, which I think is the ARCH repository, and other lesser-known programs like JDownloader gets downloaded from the AUR repository, which is the secondary ARCH/EOS repository, I think.

So, when I install from EXTRA, the program installs quickly, and I just have to put Y/N, but when I have installed Librewolf from AUR, it asks me several questions, and my english is very bad, and I don’t know what it means, so I click ENTER. (I think the question was something about “Diff?”)

Unfortunately, I can’t paste that part from the console, because, that’s the second problem.

After pressing ENTER, it asked me if I wanted to remove the dependencies after installing Librewolf [y/N], since the N was capitalized I thought it was important and pressed ENTER (NO), even though I was told if the letter is uppercase it is because it is the most “correct” option.

So, Librewolf started to install, but it’s been almost 2 hours now, and it’s still installing, I’m a little scared.

The only line that does not move is the one at the bottom of the terminal:

TIER: configure pre-export export compile misc libs tools

Is this normal with AUR programs? With the EXTRA programs it has been installed in a few seconds.

Could it be a virus or something? I went to the official Librewolf page, and the command was the same sudo pacman -S librewolf or yay -S librewolf:

I don’t understand, this is a Mozilla Firefox but fortified, it shouldn’t weigh much. What I get from the terminal are many lines, for example these are the last ones that are being created right now:

80:47.69 1 warning generated.
80:54.32 toolkit/components/satchel
80:56.73 toolkit/components/sessionstore
81:08.85 toolkit/components/startup
81:12.16 toolkit/components/statusfilter
81:13.71 toolkit/components/telemetry/
81:14.27 toolkit/components/terminator
81:14.37 toolkit/components/typeaheadfind
81:15.16 toolkit/components/uniffi-js
81:18.05 toolkit/components/url-classifier
81:25.13 toolkit/components/viaduct
81:26.35 toolkit/components/windowwatcher
81:29.11 toolkit/crashreporter
81:30.66 toolkit/library/buildid.cpp.stub
81:30.86 toolkit/mozapps/extensions
81:33.64 toolkit/profile
81:38.25 toolkit/system/gnome
81:41.38 toolkit/system/unixproxy
81:44.08 toolkit/xre
81:46.62 tools/performance
81:50.11 tools/profiler
82:03.76 uriloader/base
82:10.13 uriloader/exthandler
82:19.06 uriloader/prefetch
82:27.08 uriloader/preload
82:29.67 view
82:35.66 widget/gtk/mozgtk
82:36.12 widget/gtk/mozwayland
82:36.98 widget/gtk
82:46.25 widget/gtk/wayland
TIER: configure pre-export export compile misc libs tools

I just want to know if this is normal, or if I did something wrong.

Thanks in advance.


What should I do if it continues like this for more hours? Should I close the terminal or something, or let it install overnight?

All browsers take forever to compile, install the precompiled bin version:

10 aur/librewolf-bin 115.0.2-2 [+277 ~16.61]

Yeah, compiling a browser is no small task. :slight_smile:


read the AUR wiki, especially the part in “Getting Started”:


Thanks for answering friends.

I just quit Windows 10 and I’m installing here all the programs that I had in Windows 10, so I don’t understand much about it, sorry.

Compile, is that something like creating a Windows .exe file?

And this only happens with AUR, but not with EXTRA, which doesn’t need compilation, right?

I’m glad to know that everything is correct, for a moment I thought it was a virus or something strange.

About the uncompiled version, Is it better to compile the programs, or download them already compiled?

And how do I get the Librewolf you showed me, if I need it in the future? This:

10 aur/librewolf-bin 115.0.2-2 [+277 ~16.61]

With yay -Ss librewolf, and should it appear there?

And does the word bin mean it’s compiled, or is there a method to tell them apart?

One more question, how do I know when a program has finished installing, does this have to appear? => [my-name@my-pc]

Sorry to ask so many questions, but this will help me to download the other programs that I had in Windows 10.

Thanks again for all your effort!

Thanks friend, I’m going to read it while this ends, although the PC is a bit slow and I don’t know if it’s a good idea to leave the Terminal minimized.

Thanks again!

Can I cancel the compilation, and uninstall it, or will it break and I won’t be able to uninstall what’s installed so far?

I’m reading on reddit that only crazy people compile instead of downloading the binary version. :fearful:

Until 5 minutes ago I didn’t even know that these 2 modalities existed. :joy:


I think it’s going to take more than 2 hours with my potato pc from 15 years ago, I have canceled it, I hope I have not broken anything!

Can someone tell me how I delete everything compiled so far please? xD

Nope, all is fine

I dont use yay myself, but from documentation this should do the job;
meaning -S = Sync, -c = Clean

yay -Sc

:sweat_smile: I’m just compiling my own kernel here.
There are some benefits for compiling yourself, like some applying patches or some theoretical optimizations. But compiling yourself especially large packages like browsers are something normal user usually should avoid and just go for the binary version (-bin). Compiling takes time and it will do it again every time the software updates.

In short: Check if AUR has -bin version and use it. And if possible use official repos if possible instead of AUR. Pacman command normally only searches the official ones. yay also searches the AUR.


Hi Nicknick, if you need to stop a job in the terminal, press Ctrl + Z. It will cancel anything its doing.
You should learn about cleaning things as well just in case.

I’m quite the noob myself and I learnt today as well about the binaries (started early configuring the system). My advice to you is that try to learn what anything means first, and in the meantime, stick to “pacman -Ss”. If it’s something that you can’t find there, check the AUR. In the AUR, try to see which one has the highest amount of votes and the latest date that the package was updated.

If it’s a program that has “many versions” in the AUR, before installing try to do a bit of research. I don’t know why they do this but it happens. For example, I tried to install Joplin, and there were like 5 different entries from AUR, 2 of them were very similar. “joplin-desktop” (joplin is a note taking app built on electron) and the other one was “joplin-electron” which made me very confused. But after a bit of research, it seemed “joplin-desktop” was the official one converted for Arch packaging.
Regardless, I installed the flatpak in the end.

These practices will keep your system secure and stable for the most part. EOS is very forgiving with the setup. I installed printer support just in case, and even bluetooth worked flawlessly after starting the service.

Last but not least, I also learnt today that compiling yourself could have the advantage of security, if you know how to do that and if you cared for that, because pre compiled packages “could” have something malicious in them. But unless you start installing a lot of different unknown packages from the AUR, nothing bad should happen.


:point_up: This.

It’s always good to practice due diligence and check what the commands you run actually do instead of just copy&pasting them from web.

Also this. Following the one with highest votes and popularity is usually good practice if you have to use AUR packages

It’s also good practice to check comments on AUR, and preferably Pkgbuild file. Checking Pkgfiles tho takes some know-how.

AUR packages are often labeled for different variations, like -electron or bin. Electron being cross-platform build with javascript - Essentially running the app in embedded chromium. Takes a bit of resources, but has some advantages.

Linux is all about choice and freedom. Its your system, your rules. If you want to tinker things and build your own software go for it, or not and just take the binary packages. One advice I like to give is never let elitists, elitism, or anyone else shame you for choosing specific way to use your system, or distro you are using.


I remember I used to build ungoogled-chromium it took like 12 hours. It was great, by the time I finished, it was ready to update again. It kept my office warm that winter for sure.


Thats why I ran gentoo last winter. -35c / -31F :cold_face: :rofl: Just point the exhaust fans at the desktop.

1 Like

I’d move. I pay dearly to live in Los Angeles. And it’s worth it.

1 Like

You are still compiling a web browser from source, and that is by no means a small task.

To avoid this, you can install the pre-compiled binary version from the AUR, librewolf-bin

Hint: You can tell the pre-compiled AUR packages from normal ones from the package names; the pre-compiled binaries usually have names of the form somepackage-bin


Either the bin package, or you can use the flatpak for much easier building.


Thank you very much friend!

Yes, now I understand a little more, and I’m using this website:

It seems that the following official Arch repositories are located there:

Core Testing
Extra Testing
KDE Unstable

They are the ones with the green name in the Terminal, they are the official ones.

And on this other website, the AUR repositories, which I learned yesterday are made by the community, that is, by EOS/Arch users:

These are then the ones that I should look at so that they have positive votes and comments, to know that they work and that they do not have viruses, etc.

I also have to remember to have the -bin keyword so I know that I don’t have to compile them, if they are very large programs.

About pacman/yay, I was taught in this forum to use yay instead of pacman, because that way I can also install AUR packages, I use it for everything and maybe it’s a bad habit! :fearful:

I usually use yay -Ss to search for programs, and I usually install the green one (arch/multilib), for example steam, but sometimes there are only blue options like jdownloader (aur). And yellow for EOS.

Maybe the official repository also compiled steam, but the steam launcher was only 3mb, and maybe that’s why I didn’t notice it (or maybe it didn’t compile it).

Thank you very much again friend.

Thanks friend, I think I got used to just using yay to install everything. I don’t know if this could cause problems when using pacman cleanup commands, etc.

It’s a bad habit probably, but it’s easier for me to update like this and I don’t forget it with my bad memory. :sweat_smile:

I don’t really install many programs, just the ones I used on windows 10, steam, blender, gimp, jdownloader, librewolf, 7-zip, so there shouldn’t be any problems.

But yes, I’ll go through all the votes and install the -bin version if it’s available.

Thanks again!

Yes, I always try to find out what each command does, or ask here, as sometimes the guides are made for Arch and may not work for EOS.

Yes, I always use the green color packages, and if it doesn’t exist, then I choose a blue one.

I also always look on the official website if it has an install command, like Librewolf, which has sudo pacman -S librewolf and sudo pacman -S librewolf-bin, but I thought the -bin was the beta version or the developer version, or something like that.

Also now I can see the votes of each program from the ARCH and AUR website, that will help me a lot.

I don’t know what Pkgbuild is, but tonight I’ll look for info on it!

No, I won’t be ashamed, thanks for the advice. I’m really happy to have met you all, this forum is made up of really beautiful people. When they shut down the official EOS subreddit, I went to ask a question about EOS installation partitioning on the official Arch subreddit (because it’s based on Arch), I received a lot of negative feedback and they said a lot of things like “EOS? that’s not Arch!”, and quickly had to delete the thread. Luckily one of the users told me that the EOS community had moved to this website.

I don’t plan to modify/compile anything, I just want the default programs, the most free and safe, I also like that it is open source, so I can know thanks to other users that there are no bad things.

I left Windows because of the issue of the new Cortana ad window and because I had to uninstall many programs that were collecting data etc. Also because Windows locked down the speed of Mozilla Firefox to be slower, Firefox told Microsoft to investigate why it runs slower on Windows, and when they released Windows 11, Microsoft said that they had mistakenly tweaked something in Mozilla Firefox during all these years, which made Mozilla very slow, but now in 2023 they had fixed it…

I really didn’t like that at all, surely they will do the same in Windows 11 until windows 12 comes out, that should be illegal, I’m sure that will never happen in EOS. For these and more reasons I started using EOS.

(Sorry for my bad english, I’m using google translate)

Thank you very much for all your advice friends!

I’m really glad I called it off when it reached 2-3 hours. :joy:

Thanks friend, I’ll do that!

Does that mean, that steam (multilib), blender (extra-testing), etc, were compiled? They didn’t have -bin, but they installed really fast.

I spent a very short time in Ubuntu, and then in Fedora, I remember using Flatpak when I still didn’t know how to use the Terminal.

I’m still very new and I still have a lot to learn, but it’s true, I think flatpak can be installed on EOS/Arch.

But for now I prefer to keep using the ARCH and AUR repositories, although I have heard that steam and some other programs work better in flatpak, but I have not had problems with steam arch for now or with any other program, everything works the same or better than even on windows 10. (The only problem I had was the CSGO black screen, but it was solved by enabling the compatibility)

Thanks for the tip friend!

You can definitely use flatpak if you want. It works on virtually all distros.

Glad you got CSGO running. I need to look at the thread again, I’ve never managed to do that.

1 Like

You can assume that packages in official repos (arch / endeavouros) are already compiled ones.
When searching packages you can see repository in front of the package name;
repo / package

For example this would be from official arch repos

extra/cmake 3.27.1-1 [0B 71.09MiB] [Installed]

and this one is from EOS repos


and ones from AUR, which can be source packages needing compiling or can be already compiled are noted as aur/ like

aur/librewolf-bin 115.0.2-2 [+277 ~16.61] [Installed]
aur/librewolf 115.0.2-2 [+97 ~3.97]

You can find instructions to setup flatpak / flathub at
Flathub is repository for flatpak apps.

Flatpak is usable in Arch and arch based distros, but please note some people may have strong opinions about it :grin:

I do myself use flatpak for some applications because thats the official way package is distributed, or if the package is not available in repos or AUR. One example is statistics program I need for research which is orphaned in AUR and not updated anymore.

Steam had some problems while back and using flatpak version fixed it for many. There is no universally best option and as I stated before it’s all about freedom of choice.

Pkgbuilds are Arch Linux package build description file, it can be described as instructions for your system how to install or compile the AUR package.
As noted in Arch wiki about AUR;
" Warning: AUR packages are user-produced content. These PKGBUILDs are completely unofficial and have not been thoroughly vetted. Any use of the provided files is at your own risk."

If package is well known, popular and has lot of upvotes I tend to trust it. If I’m installing rarely used AUR software I usually skim through the pkgbuild file to double check what it will do to my system.

Some AUR helpes (yay is AUR helper for example) show pkgbuild before running the install.

If you want to check packages Pkgbuild you can also see it on AUR website after selecting package, on the right side of screen theres Package Actions and under it View PKGBUILD. As stated before reading them may take some learning and know-how

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.