AUR PGP Issue

I have another issue with pgp keys import while installing any package that mandates keys import while fetching them from AUR.
Tried 1.resetting keys,2.cleared cache with pacman -Sc and pacman -Scc. 3.Enabled paccache.timer
Used several key servers with hkps and https protocols.Only ports 443,853,11371 are allowed out on firewalld.
Still getting error. Not sure if ISP blocked them as with DNS over TLS local router block may be possible.
Librewolf_PGP_keys_import_denied
Help please

Another error that surfaces quite often for PGP keys import. This is nl server
librewolf_nl_server_fail

New issue = new thread.

You already hijacked this thread once.

1 Like

This may be of help for you:

https://wiki.archlinux.org/title/Pacman/Package_signing

1 Like

Please post the terminal output as text and not as screenshots.

Copy the terminal output, paste it into your post editor, highlight it and press Ctrl+E to format.

:enos_flag:

1 Like

Tried all suggestions mentioned out there. As i have already mentioned, Resetting keys with pacman-key --init and pacman-key --populate couldn’t fetch any favor.
I also have port 11371 open as suggested.
I also have tried specific key servers from netherlands with pacman keyserver hkps://pgp.mit.edu – recv-keys 1234567890
Nothing worked. error for yay package was “operation not permitted”
Error for specific server key import was “dirmngr” issue.
I was wondering is there any way i can manually install rpm package from fedora?.
I hope that would negotiate keys issue.

sudo gpg --keyserver https://pgp.surf.nl --recv-keys 14F26682D0916CDD81E37B6D61B7B526D98F0353
Output was

> **gpg: connecting dirmngr at '/root/.gnupg/S.dirmngr' failed: IPC connect call failed**
> **gpg: keyserver receive failed: No dirmngr**

yay librewolf OUTPUT as below

[Aur:1] librewolf-bin-104.0.2-1

:: (1/1) Downloaded PKGBUILD: librewolf-bin
1 librewolf-bin (Build Files Exist)
==> Diffs to show?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
==> n
:: (1/1) Parsing SRCINFO: librewolf-bin

:: PGP keys need importing:
→ 031F7104E932F7BD7416E7F6D2845E1305D6E801, required by: librewolf-bin
:: Import? [Y/n] y
:: Importing keys with gpg…

gpg: keyserver receive failed: Operation not permitted
 -> problem importing keys

Check the “start fresh” section on

1 Like

Tried all options listed.
This time around system generated an error list with following packages as missing
error: target not found: xorg-server-xvfb,autoconf2.13,rust,llvm,cbindgen,nasm,dump_syms,lld,wasi-libc,wasi-compiler-rt,wasi-libc++,wasi-libc++abi,imake,yasm
I have installed all packages.

Still getting same error when accepting import transaction of Key for librewolf package

> key server receive failed.Operation not permitted

gpg --keyserver hkp://keyserver.ubuntu.com --search-keys 031F7104E932F7BD7416E7F6D2845E1305D6E801

It is pinned to the top of the comment-list on librewolf-bin’s Arch Linux AUR package-site.

1 Like

What specifically did you run?

This normally means the package doesn’t exist, or you don’t have a synchronised package database. Hence, more information needed.

yay librewolf
Then selected librewolf package from AUR
Prompted me for key import
said yes
immediately returned the same error that was surfacing all the time
“key server receive failed.Operation not permitted”
Then asked for sudo password.
After password input
target not found error surfaced for packages mentioned above
Then manually i have installed all packages.
Tried yay librewolf again and remaining process of key import
This time there were no errors related to packages
But still key import failed with error
keyserver receive failed.Operation not permitted.
Is there any admin lock that is preventing me from import?
dirmngr?

and one forgotten hint not mentioned?
makepkg / yay and AUR builds? running as normal user? so if a key is missing for an AUR build to validate… you need to add the key to users keyring.

title at least says AUR pgp issue
gpg --recv-keys 031F7104E932F7BD7416E7F6D2845E1305D6E801

as normal user and run yay -S librewolf again.

Tried all that before.
as normal user executed the following command on bash shell
sudo gpg – recv-keys 031F7104E932F7BD7416E7F6D2845E1305D6E801
error surfaced as below

gpg: connecting dirmngr at ‘/root/.gnupg/S.dirmngr’ failed: IPC connect call failed
gpg: keyserver receive failed: No dirmngr

What could be the issue with dirmngr?.How to fix that error?

Also tried to import from a specific server
sudo gpg --keyserver https://pgp.surf.nl --recv-keys
then different error gets displayed
*

key server receive failed. operation not permitted

Working for me

sudo gpg --recv-keys 031F7104E932F7BD7416E7F6D2845E1305D6E801
gpg: key D2845E1305D6E801: 4 duplicate signatures removed
gpg: key D2845E1305D6E801: 4 signatures reordered
gpg: /root/.gnupg/trustdb.gpg: trustdb created
gpg: key D2845E1305D6E801: public key "ohfp repo key (Repository signing key for privacyshark repo) <1813007-ohfp@users.noreply.gitlab.com>" imported
gpg: Total number processed: 1
gpg:               imported: 1

It was all fine for me a while ago. I had installed several packages that mandate key import including librewolf. Now i am getting all these errors.
Do you suspect any AI based remote control or malware that has taken over control of my PC?

I’ve no idea what you’ve done to your system. Maybe sending our logs from journalctl or the like might help.
It is good to revert back the changes you’ve made in trying to fix this issue. It might’ve caused more troubled.
https://discovery.endeavouros.com/forum-log-tool-options/how-to-include-systemlogs-in-your-post/2021/03/

Here is journalctl log
https://clbin.com/bgAn8

Any ways i was just trying to fix issue with the help of forum members.
Re installation would be a better option than revert changes with timeshift like tools.
If issue can not be resolved can do re install. But the same issue again re occurs, then we will have to find root cause.
Either way i am fine.

Getting an error as usual like below

gpg: error searching keyserver: Operation not permitted
gpg: keyserver search failed: Operation not permitted