AUR paru Which package to install

Optional dependency, paru.
Found three options, which one do you recommend?

[marcelo@linux log]$ LANG=C yay -Syyu
:: Synchronizing package databases...
 core                                                                                                              133,3 KiB  1606 KiB/s 00:00 [----------------------------------------------------------------------------------------] 100%
 extra                                                                                                            1637,6 KiB  8,29 MiB/s 00:00 [----------------------------------------------------------------------------------------] 100%
 community                                                                                                           5,3 MiB  8,46 MiB/s 00:01 [----------------------------------------------------------------------------------------] 100%
 multilib                                                                                                          152,3 KiB  7,44 MiB/s 00:00 [----------------------------------------------------------------------------------------] 100%
 endeavouros                                                                                                        15,2 KiB  71,4 KiB/s 00:00 [----------------------------------------------------------------------------------------] 100%
:: Starting full system upgrade...
warning: openvpn: ignoring package upgrade (2.4.9-2 => 2.5.0-3)
resolving dependencies...
looking for conflicting packages...

Packages (1) eos-update-notifier-1.11-1

Total Installed Size:  0,04 MiB
Net Upgrade Size:      0,00 MiB

:: Proceed with installation? [Y/n] Y
(1/1) checking keys in keyring                                                                                                                 [----------------------------------------------------------------------------------------] 100%
(1/1) checking package integrity                                                                                                               [----------------------------------------------------------------------------------------] 100%
(1/1) loading package files                                                                                                                    [----------------------------------------------------------------------------------------] 100%
(1/1) checking for file conflicts                                                                                                              [----------------------------------------------------------------------------------------] 100%
:: Processing package changes...
(1/1) upgrading eos-update-notifier                                                                                                            [----------------------------------------------------------------------------------------] 100%
New optional dependencies for eos-update-notifier
    paru: another AUR helper supported by eos-update-notifier   <<<<<<<<<<<
:: Running post-transaction hooks...
(1/1) Arming ConditionNeedsUpdate...
:: Searching databases for updates...
:: Searching AUR for updates...
 -> openvpn: ignoring package upgrade (2.4.9-2 => 2.5.0-3)
 there is nothing to do

Checking to install, found three options:

marcelo@linux log]$ LANG=C yay -Ss paru
aur/paru-git 1.1.2.r0.g40a75f7-1 (+1 0.58) 
    AUR helper based on yay
aur/paru-bin 1.1.4-1 (+15 6.20) 
    AUR helper based on yay
aur/paru 1.1.4-1 (+52 23.47) 
    AUR helper based on yay

I have this one installed.

Can one of the team members move @mcury s post to a fitting category?

Thanks for your reply Trekkie00, isn’t paru an optional dependency for the eos-update-notifier?
Thought that this category is related to it…

This thread is not for general eos-update-notifier topics. It’s only for the nice GUI (thx to @manuel) that was just added today.

paru isn’t required by eos-update-notifier so it isn’t a requirement that you install it.

However, if you want to install it, paru is probably the most common option. paru-bin is a prebuilt binary and paru-git pulls the latest source code if you want to test the latest features before they are released.

1 Like

Paru is simply an alternative to yay. No requirements to install it if you have yay.
Yay is good to go.

3 Likes