AUR firefox-kde and firefox-kde-opensuse not building

I’m running EndeavourOS on a Surface Pro 8. I’ve been trying to build firefox-kde and even firefox-kde-opensuse from the AUR using yay for the last two hours. I keep getting the following errors when I run yay -S firefox-kde:

WARNING: You are using pip version 21.2.3; however, version 22.2.2 is available.
You should consider upgrading via the ‘/tmp/tmpgbt_nvk4/bin/python -m pip install --upgrade pip’ command.
psutil<=5.8.0,>=5.4.2: Installed with unexpected version “5.9.1”
Traceback (most recent call last):
File “/home/kelvin/.cache/yay/firefox-kde/src/firefox-103.0.2/./mach”, line 96, in
File “/home/kelvin/.cache/yay/firefox-kde/src/firefox-103.0.2/./mach”, line 88, in main
mach = check_and_get_mach(os.path.dirname(os.path.realpath(file)))
File “/home/kelvin/.cache/yay/firefox-kde/src/firefox-103.0.2/./mach”, line 35, in check_and_get_mach
return load_mach(dir_path, mach_path)
File “/home/kelvin/.cache/yay/firefox-kde/src/firefox-103.0.2/./mach”, line 21, in load_mach
return mach_initialize.initialize(dir_path)
File “/home/kelvin/.cache/yay/firefox-kde/src/firefox-103.0.2/build/”, line 153, in initialize
File “/home/kelvin/.cache/yay/firefox-kde/src/firefox-103.0.2/build/”, line 99, in _activate_python_environment
File “/home/kelvin/.cache/yay/firefox-kde/src/firefox-103.0.2/python/mach/mach/”, line 359, in activate
File “/home/kelvin/.cache/yay/firefox-kde/src/firefox-103.0.2/python/mach/mach/”, line 337, in ensure
result = self._up_to_date()
File “/home/kelvin/.cache/yay/firefox-kde/src/firefox-103.0.2/python/mach/mach/”, line 322, in _up_to_date
File “/home/kelvin/.cache/yay/firefox-kde/src/firefox-103.0.2/python/mach/mach/”, line 1106, in _assert_pip_check
raise Exception(
Exception: The “mach” site is not compatible with the installed system Python packages.
==> ERROR: A failure occurred in build().
→ error making: firefox-kde

I checked my pip install:

python -m pip install --upgrade pip
Defaulting to user installation because normal site-packages is not writeable
Requirement already satisfied: pip in /usr/lib/python3.10/site-packages (22.2.2)

How do I fix this?

Here is the complete output:
firefox-kde.pdf (66.9 KB)

using pip? running it as root before??

and always check the AUR page and comments:

Thanks for pointing out the firefox-kde-opensuse AUR page! I was finally able to install firefox-kde-opensuse from Thaodan’s repository.

I only tried to install firefox-kde-opensuse once from the AUR using yay. When that didn’t work, I focused all of my efforts on firefox-kde. I read the firefox-kde AUR page thoroughly, and even tried, without success, to install it with paru.

Out of curiosity, what features of these browsers are you using?

Since Firefox now can use kde file dialogs natively it seems I see fewer people using these variants.

1 Like

It’s more for curiosity. I wanted to see if firefox-kde-opensuse provided any additional KDE Plasma integration over regular Firefox. So far the answer has been no.

I think it adds two things:

  • Native file dialogs(which you now get another way)
  • Global menu/appmenu integration(Which you only need if you are using that)

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.