AUR dial tcp 95.216.144.15:443: i/o timeout

I have AUR issues for some days now.

I am not sure what the problem is, but it seems related to my ISP and/or AUR servers and their routing/dns/peering whatever. I always get timeouts:

:: Searching AUR for updates…
→ request failed: Get "https://aur.archlinux.org/rpc?arg(ALLMYAURPACKAGESLIST). : dial tcp 95.216.144.15:443: i/o timeout

and also this

error: failed retrieving file ‘endeavouros.db’ from ca.gate.endeavouros.com : Connection timeout after 10000 ms

The thing is, when I VPN through my own server that is hosted at NETCUP ( german ip location ) it is working fine somehow.

This happens with yay and paru. I did not try any other alternative to them so far.

sometimes traceroute doesn’t show anything special. But very often it shows packet-loss on the last hops to reach the AUR and AUR itself. Even with timeout set to like 10 seconds. There is lots of packetloss at hetzner.com, twelve99.net, your-cloud.host (which is hetzner afaik) and aur.archlinux.org (95.216.144.15).

I might add that I do not have any issues whatsoever with other sites or services. It is only AUR/Archlinux.org and this little error of endeavouros.db.

tldr: New thread opened on request by a mod. And to clarify, there is no issue when I connect through a VPN to AUR. There is an issue with my regular home connection to AUR. Just in case there is anybody out there not understanding this correctly.

I have cleaned up all the back and forth personal attacks in this topic. Please try to keep the conversation focused on solving the issue at hand.

2 Likes

OK. Topic cleaned up a second time.

The issue that has been removed doesn’t require further discussion or explanation.

My best guess that is some routing thing. Are those last hops (where the loss occurs) different to when you go via VPN ?

1 Like

I tested it like 5 times in a row couple of minutes ago. And they seem to be the same every time. That is what is kinda weird. I mean I could call my ISP, but my own exp tells me, those people I get on the phone there do know even less than I do. :frowning:

The packetloss doesn’t happen at my ISP hops, neither on VPN or without. Its always beginning at twelve99.net and then at hetzner (where AUR seems to be hosted on, I guess).

Is it a german provider? Then I’ll guaranty you that will be the case :joy::frowning:

You probably can’t do anything else than trying to contact the companies traffic gets routed through, I’m afraid. :man_shrugging:

Sounds like it is on their end then. Packets are most likely asymmetrically routed back taking some congested/bad route back to your ISP network

1 Like

Yes, O2/Telekom lol :=)

Yeh it is really annoying, I can not even do an Arch install like that, cant get connection to arch repos most of the time (sometimes it gets through, but not always).

I guess, I need to use my vpn to do such things then for the time being. :confused:

There are hundreds of mirrors though. One or the other should work. Since you can connect to netcup servers just fine apparently, you might want to try https://mirror.moson.org/
It has the arch repo’s as well as eos :wink:

1 Like

I tried almost every mirror that EOS has. Same problem everywhere. I can try yours too. I will test it. It is not in the “official” list in EOS, is it?

Yepp

1 Like

Screenshot from 2022-07-25 23-18-21

I can not even get to change or test mirrors with reflector because archlinux.org connection fails. Not always, but most of the time.

AFAIK the only source for AUR scripts is the AUR itself, right? I mean, even if arch repos work again, I still can’t access AUR. :frowning:

Just change the mirrorlist(s) manually…

Btw. Are you sure it’s only to hetzner with those issues. Other devices in your network have the same issue?

1 Like

I know, that is what I already did. I just wanted to showcase the issue ^^

every device, as long as they are connected through my home connection ofc. I do not have any issues at all with any other site or service, only AUR/arch.

I can connect to AUR perfectly fine with my mobile phone for example. Even simple ping on archlinux.org or aur.archlinux.org timeout after first ping.

I even tried different DNS, I used my own unbound resolver, I tested Cloudflare, DoH, no DoH etc. changed from selfhosted DHCP to router DHCP etc. etc.

Even though it for sure isn’t the issue, because everything else works fine. I still tested it.

archlinux.org ping statistics —
175 packets transmitted, 0 received, 100% packet loss, time 178181ms

through vpn:

➜ ~ ping archlinux.org
PING archlinux.org (95.217.163.246) 56(84) bytes of data.
64 bytes from archlinux.org (95.217.163.246): icmp_seq=1 ttl=54 time=41.9 ms
64 bytes from archlinux.org (95.217.163.246): icmp_seq=2 ttl=54 time=42.5 ms
64 bytes from archlinux.org (95.217.163.246): icmp_seq=3 ttl=54 time=42.3 ms
64 bytes from archlinux.org (95.217.163.246): icmp_seq=4 ttl=54 time=42.0 ms
64 bytes from archlinux.org (95.217.163.246): icmp_seq=5 ttl=54 time=42.8 ms

It is cleary an issue at my ISP and their peering or routing whatever.

Probably. Or arch just blocks you(r ISP) :laughing:

I must say, I love my ISP just for the naming of their routers :rofl:

image

1 Like

Screenshot from 2022-07-25 23-56-17

Which one do you have?

Epcan. It’s a local one.

https://www.epcan.de/ ?

never heard of before.

Yupp.
We’re getting pretty much OT here though. :joy:
But yeah I guess it’s on your ISP to ge things sorted…

I just restarted my router like 12 times now. To get a new IP every time. Now it seems to work with the current IP they gave me. Fingers crossed that this will work with upcoming IPs they give me. Otherwise I really need to call them. At least it was a confirmation that its clearly an ISP issue. Thanks for your help btw.