Audio usually disappears

I’ve had Endeavour OS installed for 3 months now, but for it was only today that the audio started having issues. When I play videos, sometimes audio just disappears (happened with both earphones and just the speakers), and I would wait a while for the audio to return or unplug and replug my earphones to get it to work again. Sometimes, it needs multiple replugs to get it to work. After it plays though, it’s smooth-sailing, and it won’t happen if I constantly have some audio playing. But as soon as I stop playing audio for a few seconds the problem reappears.

I saw some other posts about wireplumber being the issue, but I checked cat /var/log/pacman.log | grep wireplumber and the last update happened December 1, so I’m not sure why it only started today.

If you are / had you been using PulseAudio – Endeavour uses PipeWire by default – attempt no. 1 would’ve been commenting out

load-module module-suspend-on-idle

in /etc/pulse/ Not on Endeavour so I will need to leave it up to you / someone else to figure out if there’s a corresponding setting for PipeWire.

Attempt no. 2 would, assuming you’re using snd-hda-intel, be creating a file /etc/modprobe.d/snd-hda-intel.conf consisting of

options snd-hda-intel power_save=0 power_save_controller=N

and rebooting. Check with e.g. inxi -Ax if indeed the card in question uses snd-hda-intel.

Both that said; you seem to imply that sometimes sound cuts out literally in the middle of playing something so the above might also both be N/A. So FWIW…

Saw an article on arch wiki that is somewhat similar to the issue you’re experiencing, though I’m not sure if it’s relevant.

For now, your best cause of action, in my opinion, is to check all the journal entries for pipewire

Consider running journalctl --user --unit pipewire

One more thing to came to mind specifically as a result of also just now being a thread about CPU frequency scaling…

If the snd-hda-intel parameters aren’t helping try if the issue’s still there after running

sudo cpupower frequency-set -g performance

Probably not the answer, but as a FWIW…

1 Like

@Steve120 Are the audio issues present in the LTS kernel as well? What about in a live environment?

This is what I got for today:

The previous logs were all similar to this up until around Dec. 1, which looked like this:

@rene yeah I think both attempts don’t apply here unfortunately:

╰─ inxi -Ax 
  Device-1: Intel Tiger Lake-LP Smart Sound Audio vendor: Lenovo
    driver: sof-audio-pci-intel-tgl bus-ID: 0000:00:1f.3
  Sound API: ALSA v: k5.15.82-1-lts running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.61 running: yes

I’m currently running on LTS as my day-to-day, have not tried a live USB yet

It happened in all audio-related contexts? Or just a specific application? Watching youtube videos? Web-browsing? Playing music files? Playing video files?

Yah, not useful then. Could still try the CPU frequency thing.

It seems to be the case: YouTube on browser, YouTube on Discord, .mp3, .mp4 files so far all have not worked.

When did you last update your system? You can check your pacman logs at /var/log/pacman.log
The logs also contain information on what packages you updated.

If it’s a software issue, we need to identify the culprit (maybe a recently update package has caused this?). It makes no sense for this issue to occur out of the blue.

To rule out hardware issues, you can test it out in a live environment and see if the issue is there. Maybe try out different kernels? You are running LTS now; I don’t see the harm in testing things out with the stable kernel.

It seems I have last updated it last Dec. 11.

Just tried it on a live USB, and it was working fine there (only tested browser though since the installed media player couldn’t open)

Okay. So it’s a software issue. The next step is to figure out which recently updated package is causing this.

how do i do that?

If this could help, this is what pacman.log has for the entire day of Dec. 11:

[2022-12-11T15:50:30-0500] [PACMAN] Running 'pacman -S -y -u --config /etc/pacman.conf --'
[2022-12-11T15:50:30-0500] [PACMAN] synchronizing package lists
[2022-12-11T15:50:31-0500] [PACMAN] starting full system upgrade
[2022-12-11T15:50:40-0500] [ALPM] transaction started
[2022-12-11T15:50:40-0500] [ALPM] upgraded attica (5.100.0-1 -> 5.101.0-1)
[2022-12-11T15:50:40-0500] [ALPM] upgraded ki18n (5.100.0-1 -> 5.101.0-1)
[2022-12-11T15:50:40-0500] [ALPM] upgraded karchive (5.100.0-1 -> 5.101.0-1)
[2022-12-11T15:50:41-0500] [ALPM] upgraded kconfig (5.100.1-1 -> 5.101.0-1)
[2022-12-11T15:50:41-0500] [ALPM] upgraded kcoreaddons (5.100.0-1 -> 5.101.0-1)
[2022-12-11T15:50:41-0500] [ALPM] upgraded kfilemetadata (5.100.0-1 -> 5.101.0-1)
[2022-12-11T15:50:41-0500] [ALPM] upgraded kidletime (5.100.0-1 -> 5.101.0-1)
[2022-12-11T15:50:41-0500] [ALPM] upgraded solid (5.100.0-1 -> 5.101.0-1)
[2022-12-11T15:50:41-0500] [ALPM] upgraded kwidgetsaddons (5.100.0-1 -> 5.101.0-1)
[2022-12-11T15:50:41-0500] [ALPM] upgraded kjobwidgets (5.100.0-1 -> 5.101.0-1)
[2022-12-11T15:50:41-0500] [ALPM] upgraded kdbusaddons (5.100.0-1 -> 5.101.0-1)
[2022-12-11T15:50:41-0500] [ALPM] upgraded kwindowsystem (5.100.0-1 -> 5.101.0-1)
[2022-12-11T15:50:41-0500] [ALPM] upgraded kcrash (5.100.0-1 -> 5.101.0-1)
[2022-12-11T15:50:41-0500] [ALPM] upgraded kglobalaccel (5.100.0-1 -> 5.101.0-1)
[2022-12-11T15:50:41-0500] [ALPM] upgraded kauth (5.100.0-1 -> 5.101.0-1)
[2022-12-11T15:50:41-0500] [ALPM] upgraded kcodecs (5.100.0-1 -> 5.101.0-1)
[2022-12-11T15:50:41-0500] [ALPM] upgraded qt5-wayland (5.15.7+kde+r55-1 -> 5.15.7+kde+r56-1)
[2022-12-11T15:50:41-0500] [ALPM] upgraded kguiaddons (5.100.0-1 -> 5.101.0-1)
[2022-12-11T15:50:41-0500] [ALPM] upgraded kconfigwidgets (5.100.0-1 -> 5.101.0-1)
[2022-12-11T15:50:41-0500] [ALPM] upgraded kiconthemes (5.100.0-1 -> 5.101.0-1)
[2022-12-11T15:50:41-0500] [ALPM] upgraded kitemviews (5.100.0-1 -> 5.101.0-1)
[2022-12-11T15:50:41-0500] [ALPM] upgraded kxmlgui (5.100.0-1 -> 5.101.0-1)
[2022-12-11T15:50:41-0500] [ALPM] upgraded kbookmarks (5.100.0-1 -> 5.101.0-1)
[2022-12-11T15:50:41-0500] [ALPM] upgraded knotifications (5.100.0-1 -> 5.101.0-1)
[2022-12-11T15:50:41-0500] [ALPM] upgraded kservice (5.100.0-1 -> 5.101.0-1)
[2022-12-11T15:50:41-0500] [ALPM] upgraded kwallet (5.100.0-1 -> 5.101.0-1)
[2022-12-11T15:50:41-0500] [ALPM] upgraded kcompletion (5.100.0-1 -> 5.101.0-1)
[2022-12-11T15:50:41-0500] [ALPM] upgraded sonnet (5.100.0-1 -> 5.101.0-1)
[2022-12-11T15:50:41-0500] [ALPM] upgraded ktextwidgets (5.100.0-1 -> 5.101.0-1)
[2022-12-11T15:50:41-0500] [ALPM] upgraded kded (5.100.0-1 -> 5.101.0-1)
[2022-12-11T15:50:41-0500] [ALPM] upgraded kio (5.100.0-1 -> 5.101.0-1)
[2022-12-11T15:50:41-0500] [ALPM] upgraded baloo (5.100.0-1 -> 5.101.0-1)
[2022-12-11T15:50:41-0500] [ALPM] upgraded bluez-qt (5.100.0-1 -> 5.101.0-1)
[2022-12-11T15:50:42-0500] [ALPM] upgraded breeze-icons (5.100.0-1 -> 5.101.0-1)
[2022-12-11T15:50:42-0500] [ALPM] upgraded endeavouros-skel-i3wm (4.0-1 -> 4.1-1)
[2022-12-11T15:50:42-0500] [ALPM] installed net-tools (2.10-1)
[2022-12-11T15:50:42-0500] [ALPM] upgraded eos-log-tool (1.14-1 -> 1.14-4)
[2022-12-11T15:50:42-0500] [ALPM] upgraded extra-cmake-modules (5.100.0-1 -> 5.101.0-1)
[2022-12-11T15:50:42-0500] [ALPM] upgraded kpackage (5.100.0-1 -> 5.101.0-1)
[2022-12-11T15:50:42-0500] [ALPM] upgraded syndication (5.100.0-1 -> 5.101.0-1)
[2022-12-11T15:50:42-0500] [ALPM] upgraded knewstuff (5.100.0-1 -> 5.101.0-1)
[2022-12-11T15:50:42-0500] [ALPM] upgraded frameworkintegration (5.100.0-1 -> 5.101.0-1)
[2022-12-11T15:50:42-0500] [ALPM] upgraded imagemagick ( ->
[2022-12-11T15:50:42-0500] [ALPM] upgraded kactivities (5.100.0-1 -> 5.101.0-1)
[2022-12-11T15:50:42-0500] [ALPM] upgraded kactivities-stats (5.100.0-1 -> 5.101.0-1)
[2022-12-11T15:50:42-0500] [ALPM] upgraded kdeclarative (5.100.0-1 -> 5.101.0-1)
[2022-12-11T15:50:42-0500] [ALPM] upgraded kcmutils (5.100.0-1 -> 5.101.0-1)
[2022-12-11T15:50:42-0500] [ALPM] upgraded kcontacts (1:5.100.0-1 -> 1:5.101.0-1)
[2022-12-11T15:50:42-0500] [ALPM] upgraded kunitconversion (5.100.0-1 -> 5.101.0-1)
[2022-12-11T15:50:42-0500] [ALPM] upgraded kitemmodels (5.100.0-1 -> 5.101.0-1)
[2022-12-11T15:50:42-0500] [ALPM] upgraded kemoticons (5.100.0-1 -> 5.101.0-1)
[2022-12-11T15:50:42-0500] [ALPM] upgraded kparts (5.100.0-1 -> 5.101.0-1)
[2022-12-11T15:50:43-0500] [ALPM] upgraded kdelibs4support (5.100.0-1 -> 5.101.0-1)
[2022-12-11T15:50:43-0500] [ALPM] upgraded kpty (5.100.0-1 -> 5.101.0-1)
[2022-12-11T15:50:43-0500] [ALPM] upgraded kdesu (5.100.0-1 -> 5.101.0-1)
[2022-12-11T15:50:43-0500] [ALPM] upgraded kdnssd (5.100.0-1 -> 5.101.0-1)
[2022-12-11T15:50:43-0500] [ALPM] upgraded kholidays (1:5.100.0-1 -> 1:5.101.0-1)
[2022-12-11T15:50:43-0500] [ALPM] upgraded kinit (5.100.0-1 -> 5.101.0-1)
[2022-12-11T15:50:43-0500] [ALPM] upgraded kirigami2 (5.100.0-1 -> 5.101.0-1)
[2022-12-11T15:50:43-0500] [ALPM] upgraded kjs (5.100.0-1 -> 5.101.0-1)
[2022-12-11T15:50:43-0500] [ALPM] upgraded knotifyconfig (5.100.0-1 -> 5.101.0-1)
[2022-12-11T15:50:43-0500] [ALPM] upgraded kpeople (5.100.0-1 -> 5.101.0-1)
[2022-12-11T15:50:43-0500] [ALPM] upgraded kquickcharts (5.100.0-1 -> 5.101.0-1)
[2022-12-11T15:50:43-0500] [ALPM] upgraded kwayland (5.100.0-1 -> 5.101.0-1)
[2022-12-11T15:50:43-0500] [ALPM] upgraded plasma-framework (5.100.1-1 -> 5.101.0-1)
[2022-12-11T15:50:43-0500] [ALPM] upgraded threadweaver (5.100.0-1 -> 5.101.0-1)
[2022-12-11T15:50:43-0500] [ALPM] upgraded krunner (5.100.0-1 -> 5.101.0-1)
[2022-12-11T15:50:43-0500] [ALPM] upgraded syntax-highlighting (5.100.0-1 -> 5.101.0-1)
[2022-12-11T15:50:43-0500] [ALPM] upgraded ktexteditor (5.100.0-1 -> 5.101.0-1)
[2022-12-11T15:50:43-0500] [ALPM] upgraded libmpc (1.2.1-2 -> 1.3.0-1)
[2022-12-11T15:50:43-0500] [ALPM] upgraded modemmanager-qt (5.100.0-1 -> 5.101.0-1)
[2022-12-11T15:50:43-0500] [ALPM] upgraded networkmanager-qt (5.100.0-1 -> 5.101.0-1)
[2022-12-11T15:50:43-0500] [ALPM] upgraded perl-path-tiny (0.142-1 -> 0.144-1)
[2022-12-11T15:50:43-0500] [ALPM] upgraded prison (5.100.0-1 -> 5.101.0-1)
[2022-12-11T15:50:43-0500] [ALPM] upgraded purpose (5.100.0-1 -> 5.101.0-1)
[2022-12-11T15:50:43-0500] [ALPM] upgraded qqc2-desktop-style (5.100.0-1 -> 5.101.0-1)
[2022-12-11T15:50:43-0500] [ALPM] upgraded sof-firmware (2.2.2-1 -> 2.2.3-1)
[2022-12-11T15:50:43-0500] [ALPM] transaction completed
[2022-12-11T15:50:44-0500] [ALPM] running '30-systemd-udev-reload.hook'...
[2022-12-11T15:50:44-0500] [ALPM] running '30-systemd-update.hook'...
[2022-12-11T15:50:44-0500] [ALPM] running '30-update-mime-database.hook'...
[2022-12-11T15:50:44-0500] [ALPM] running 'dbus-reload.hook'...
[2022-12-11T15:50:44-0500] [ALPM] running 'detect-old-perl-modules.hook'...
[2022-12-11T15:50:44-0500] [ALPM] running 'gtk-update-icon-cache.hook'...
[2022-12-11T15:50:44-0500] [ALPM] running 'rebuild-detector.hook'...
[2022-12-11T15:50:46-0500] [ALPM] running 'texinfo-install.hook'...
[2022-12-11T15:50:46-0500] [ALPM] running 'update-desktop-database.hook'...
[2022-12-11T15:52:59-0500] [PACMAN] Running 'pacman -U --noconfirm --config /etc/pacman.conf -- /home/steven/.cache/yay/archlinux-appstream-data-pamac/archlinux-appstream-data-pamac-1:20221210-1-any.pkg.tar.zst'
[2022-12-11T15:52:59-0500] [ALPM] transaction started
[2022-12-11T15:53:00-0500] [ALPM] upgraded archlinux-appstream-data-pamac (1:20221014-1 -> 1:20221210-1)
[2022-12-11T15:53:00-0500] [ALPM] transaction completed
[2022-12-11T15:53:00-0500] [ALPM] running '30-systemd-update.hook'...
[2022-12-11T15:53:00-0500] [ALPM] running '90-update-appstream-cache.hook'...
[2022-12-11T15:53:00-0500] [ALPM-SCRIPTLET] ✔ Metadata cache was updated successfully.
[2022-12-11T15:53:00-0500] [ALPM] running 'fix-appstream-data.hook'...
[2022-12-11T15:53:01-0500] [ALPM] running 'rebuild-detector.hook'...
[2022-12-11T15:53:04-0500] [PACMAN] Running 'pacman -U --noconfirm --config /etc/pacman.conf -- /home/steven/.cache/yay/kvantum-qt5-git/kvantum-qt5-git-1.0.7.r1.gab94b200-1-x86_64.pkg.tar.zst'
[2022-12-11T15:53:04-0500] [ALPM] transaction started
[2022-12-11T15:53:04-0500] [ALPM] upgraded kvantum-qt5-git (1.0.4.r10.gcd913082-1 -> 1.0.7.r1.gab94b200-1)
[2022-12-11T15:53:04-0500] [ALPM] transaction completed
[2022-12-11T15:53:04-0500] [ALPM] running '30-systemd-update.hook'...
[2022-12-11T15:53:04-0500] [ALPM] running 'gtk-update-icon-cache.hook'...
[2022-12-11T15:53:04-0500] [ALPM] running 'rebuild-detector.hook'...
[2022-12-11T15:53:05-0500] [ALPM] running 'update-desktop-database.hook'...
[2022-12-11T15:53:43-0500] [PACMAN] Running 'pacman -U --noconfirm --config /etc/pacman.conf -- /home/steven/.cache/yay/snapd/snapd-2.58-1-x86_64.pkg.tar.zst'
[2022-12-11T15:53:43-0500] [ALPM] transaction started
[2022-12-11T15:53:44-0500] [ALPM] upgraded snapd (2.57.6-1 -> 2.58-1)
[2022-12-11T15:53:44-0500] [ALPM] transaction completed
[2022-12-11T15:53:44-0500] [ALPM] running '30-systemd-daemon-reload.hook'...
[2022-12-11T15:53:44-0500] [ALPM] running '30-systemd-tmpfiles.hook'...
[2022-12-11T15:53:44-0500] [ALPM] running '30-systemd-update.hook'...
[2022-12-11T15:53:44-0500] [ALPM] running 'dbus-reload.hook'...
[2022-12-11T15:53:44-0500] [ALPM] running 'rebuild-detector.hook'...
[2022-12-11T15:53:45-0500] [ALPM] running 'update-desktop-database.hook'...
[2022-12-11T15:54:00-0500] [PACMAN] Running 'pacman -U --noconfirm --config /etc/pacman.conf -- /home/steven/.cache/yay/visual-studio-code-bin/visual-studio-code-bin-1.74.0-1-x86_64.pkg.tar.zst'
[2022-12-11T15:54:00-0500] [ALPM] transaction started
[2022-12-11T15:54:01-0500] [ALPM] upgraded visual-studio-code-bin (1.73.1-2 -> 1.74.0-1)
[2022-12-11T15:54:01-0500] [ALPM-SCRIPTLET] ==> NOTE: Custom flags should be put directly in: ~/.config/code-flags.conf
[2022-12-11T15:54:01-0500] [ALPM] transaction completed
[2022-12-11T15:54:01-0500] [ALPM] running '30-systemd-update.hook'...
[2022-12-11T15:54:01-0500] [ALPM] running '30-update-mime-database.hook'...
[2022-12-11T15:54:01-0500] [ALPM] running 'rebuild-detector.hook'...
[2022-12-11T15:54:02-0500] [ALPM] running 'update-desktop-database.hook'...
[2022-12-11T16:13:13-0500] [PACMAN] Running 'pacman -Syu'
[2022-12-11T16:13:13-0500] [PACMAN] synchronizing package lists
[2022-12-11T16:13:18-0500] [PACMAN] starting full system upgrade
[2022-12-11T16:13:43-0500] [PACMAN] Running 'pacman -S pipewire-media-session'
[2022-12-11T16:13:47-0500] [ALPM] transaction started
[2022-12-11T16:13:47-0500] [ALPM-SCRIPTLET] Removed "/etc/systemd/user/pipewire-session-manager.service".
[2022-12-11T16:13:47-0500] [ALPM-SCRIPTLET] Removed "/etc/systemd/user/pipewire.service.wants/wireplumber.service".
[2022-12-11T16:13:47-0500] [ALPM] removed wireplumber (0.4.12-2)
[2022-12-11T16:13:47-0500] [ALPM] installed pipewire-media-session (1:0.4.1-2)
[2022-12-11T16:13:47-0500] [ALPM-SCRIPTLET] Created symlink /etc/systemd/user/pipewire-session-manager.service → /usr/lib/systemd/user/pipewire-media-session.service.
[2022-12-11T16:13:47-0500] [ALPM-SCRIPTLET] Created symlink /etc/systemd/user/pipewire.service.wants/pipewire-media-session.service → /usr/lib/systemd/user/pipewire-media-session.service.
[2022-12-11T16:13:47-0500] [ALPM] transaction completed
[2022-12-11T16:13:47-0500] [ALPM] running '30-systemd-update.hook'...

You said the audio only starts to give problems when you stop playing audio for a while but not when the audio is playing continuously?

I’m beginning to suspect that this might have to do with Wireplumber’s “suspend on idle” setting.

Can you cd into /usr/share/wireplumber/main.lua.d/ and open a file called 50-alsa-config.lua? Scroll down to the bottom to the apply_properties section. You should see a bunch of commented out lines like this:

Uncomment this line:

--["session.suspend-timeout-seconds"] = 5, 

And change the timeout-seconds to 0 to disable suspend. After that, reboot and see if the problem still occurs

Could it be related to that? => After update, pipewire needs to be restarted often

I had problems where my audio suddenly stopped working and Discord was the cause of this. Audio usually worked fine but when I had Discord running and didn’t play audio for a while all audio was broken.

I fixed it by setting ["api.alsa.headroom"] = 512 (Here is a guide on how/where to set this property =>

If it does I hereby announce that I shall then be unable to not mention that that was the very first thing I said in reply #1