Audio stuttering when combining PipeWire and Viper4Linux


I’ve been having a couple audio issues. Initially whenever I ran an emulator and had audio from another application running, the pitch would be altered for all sound and remain until I restarted the computer. This problem was solved after replacing Pulse with PipeWire, however, under PipeWire I’ve been having trouble running Viper4Linux.

When Viper is on audio will ‘hack/lag’ and repeat itself, i.e. it sounds like it took 0.2 seconds of previous audio and reinserted it later in the track every ~10 seconds - this will continue for a brief period after a song has stopped.

I would like to keep using PipeWire (and Viper) unless someone has better alternatives, so does anyone have any insight on what’s causing this and could perhaps offer a solution?

There’s a known issue which sounds similar and is currently a “won’t fix”:

As an alternative, you might have a look at EasyEffects as that integrates directly with Pipewire.

1 Like

I don’t use Bluetooth but it does seem similar. I’ll look into EasyEffects. Thanks!

1 Like

You might also consider removing Pipewire to what was PulseAudio-legacy, but I think is now just PulseAudio in the repos. From what I know about Viper4Linux (which is finicky itself re the Git page) it is meant to work with Pulseaudio.

An easier solution though is what @jonathon suggested, use EasyEffects with Pipewire instead.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.