Audio streamed simultaneously on multiple outputs

hello, Im using laptop thats pinned to dock station. when I connect external speakers/headphones to the dock station, audio continues to play through both the attached device and the internal laptop speaker.

i figured out that either ‘speaker’ or ‘line out’ option in ‘auto-mute’ of alsamixer can fix it, however this option keeps changing to ‘disabled’ anytime I plug in a device, which I do frequently. I tried using ‘sudo alsactl’ to save the alsamixer settings, but it keeps changing to ‘disabled’ on plugging.
any ideas?

my config

System:
  Kernel: 5.17.6-arch1-1 arch: x86_64 bits: 64 Desktop: KDE Plasma v: 5.24.5
    Distro: EndeavourOS
Machine:
  Type: Laptop System: Dell product: Latitude E6420 v: 01
    serial: <superuser required>
  Mobo: Dell model: 0K0DNP v: A01 serial: <superuser required> BIOS: Dell
    v: A26 date: 09/14/2018
Battery:
  ID-1: BAT0 charge: 54.4 Wh (100.0%) condition: 54.4/48.8 Wh (111.4%)
CPU:
  Info: dual core model: Intel Core i5-2540M bits: 64 type: MT MCP cache:
    L2: 512 KiB
  Speed (MHz): avg: 906 min/max: 800/3300 cores: 1: 797 2: 832 3: 798
    4: 1199
Graphics:
  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics
    driver: i915 v: kernel
  Device-2: Sunplus Innovation Laptop_Integrated_Webcam_FHD type: USB
    driver: uvcvideo
  Display: x11 server: X.Org v: 21.1.3 driver: X: loaded: intel
    unloaded: modesetting gpu: i915 resolution: 1: N/A 2: 1920x1080~60Hz
  OpenGL: renderer: Mesa Intel HD Graphics 3000 (SNB GT2)
    v: 3.3 Mesa 22.0.3
Audio:
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio
    driver: snd_hda_intel
  Sound Server-1: ALSA v: k5.17.6-arch1-1 running: yes
  Sound Server-2: PipeWire v: 0.3.51 running: yes
Network:
  Device-1: Intel 82579LM Gigabit Network driver: e1000e
  IF: eno1 state: down mac: 5c:26:0a:60:86:2f
  Device-2: Intel Centrino Advanced-N 6205 [Taylor Peak] driver: iwlwifi
  IF: wlan0 state: down mac: 0a:83:f9:97:fa:c3
  IF-ID-1: enp0s29u1u2 state: unknown speed: -1 duplex: half
    mac: 36:cd:d8:d9:4c:bf
  IF-ID-2: wwp0s29u1u6i6 state: down mac: 02:80:37:ec:02:00
Bluetooth:
  Device-1: Xiaomi Mi/Redmi series (RNDIS + ADB) type: USB driver: rndis_host
  Report: This feature requires one of these tools: hciconfig/bt-adapter
RAID:
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci
Drives:
  Local Storage: total: 133.68 GiB used: 6.72 GiB (5.0%)
  ID-1: /dev/sda vendor: A-Data model: SU900 size: 119.24 GiB
  ID-2: /dev/sdb type: USB model: USB DISK 2.0 size: 14.44 GiB
Partition:
  ID-1: / size: 108.15 GiB used: 6.72 GiB (6.2%) fs: ext4 dev: /dev/sda1
Swap:
  ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%)
    dev: /dev/sda2
Sensors:
  System Temperatures: cpu: 57.0 C mobo: 31.0 C sodimm: SODIMM C
  Fan Speeds (RPM): cpu: 0
Info:
  Processes: 180 Uptime: 1h 17m Memory: 7.65 GiB used: 2.16 GiB (28.3%)
  Shell: fish inxi: 3.3.15

Go into Audio settings and mute output to the internal speakers. One-click stopping. :wink:

1 Like

even though I mute internal speaker in audio settings it keeps using ‘line out’ audio level and still plays.
in alsamixer ive got combined ‘speaker+lo’ item. is it normal?

What do KDE’s own Settings>Audio show?

This needs to be its own topic instead of O.T.

there aint much options - I can choose port and adjust voice level

but as I said - changing internal speaker settings doesnt work as its using line out options for some reason

problem fixed by commenting lines of code included in this topic

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.