Audio Stopped Working After Recent Update

The audio on my EndeavourOS KDE system has stopped working after the recent update.

I have tried to debug the issue for long hours without reaching any resolution. I noticed though that switching the audio profile away from (Analog Sterio Duplex) and back to it fixes allows me to run the audio test successfully from the settings, but then it crashes again after a while. I have tried it on other browsers as well, but I was also getting the same problem.

Here are the commands that I have tried so far:

Install PulseAudio:

yay -S pulseaudio --needed
Sync Dependency (1): pulseaudio-16.1-6
warning: pulseaudio-16.1-6 is up to date -- skipping
there is nothing to do

Check running profiles:

ps aux | grep -iE 'pulseaudio|alsa|jack|esd|arts'`
rc          1137  0.1  0.3 2414632 26668 ?       S<sl 10:13   0:01 /usr/bin/pulseaudio --daemonize=no --log-target=journal
rc         11134  0.0  0.0   6588  2528 pts/0    S+   10:36   0:00 grep -iE pulseaudio|alsa|jack|esd|arts

Check Status:

sudo systemctl status pulseaudio
Unit pulseaudio.service could not be found.

Check Audio Output Device:

pacmd list-sinks
2 sink(s) available.
  * index: 1
        name: <alsa_output.pci-0000_03_00.6.analog-stereo>
        driver: <module-alsa-card.c>
        flags: HARDWARE HW_MUTE_CTRL HW_VOLUME_CTRL DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
        state: SUSPENDED
        suspend cause: APPLICATION|IDLE
        priority: 9039
        volume: front-left: 45340 /  69% / -9.60 dB,   front-right: 45340 /  69% / -9.60 dB
                balance 0.00
        base volume: 65536 / 100% / 0.00 dB
        volume steps: 65537
        muted: no
        current latency: 0.00 ms
        max request: 0 KiB
        max rewind: 0 KiB
        monitor source: 1
        sample spec: s16le 2ch 44100Hz
        channel map: front-left,front-right
                     Stereo
        used by: 0
        linked by: 0
        configured latency: 0.00 ms; range is 0.50 .. 1999.82 ms
        card: 1 <alsa_card.pci-0000_03_00.6>
        module: 7
        properties:
                alsa.resolution_bits = "16"
                device.api = "alsa"
                device.class = "sound"
                alsa.class = "generic"
                alsa.subclass = "generic-mix"
                alsa.name = "ALC256 Analog"
                alsa.id = "ALC256 Analog"
                alsa.subdevice = "0"
                alsa.subdevice_name = "subdevice #0"
                alsa.device = "0"
                alsa.card = "1"
                alsa.card_name = "HD-Audio Generic"
                alsa.long_card_name = "HD-Audio Generic at 0xc04c0000 irq 79"
                alsa.driver_name = "snd_hda_intel"
                device.bus_path = "pci-0000:03:00.6"
                sysfs.path = "/devices/pci0000:00/0000:00:08.1/0000:03:00.6/sound/card1"
                device.bus = "pci"
                device.vendor.id = "1022"
                device.vendor.name = "Advanced Micro Devices, Inc. [AMD]"
                device.product.id = "15e3"
                device.product.name = "Family 17h/19h HD Audio Controller"
                device.string = "front:1"
                device.buffering.buffer_size = "352768"
                device.buffering.fragment_size = "176384"
                device.access_mode = "mmap+timer"
                device.profile.name = "analog-stereo"
                device.profile.description = "Analog Stereo"
                device.description = "Family 17h/19h HD Audio Controller Analog Stereo"
                module-udev-detect.discovered = "1"
                device.icon_name = "audio-card-pci"
        ports:
                analog-output-speaker: Speakers (priority 10000, latency offset 0 usec, available: unknown)
                        properties:
                                device.icon_name = "audio-speakers"
                analog-output-headphones: Headphones (priority 9900, latency offset 0 usec, available: no)
                        properties:
                                device.icon_name = "audio-headphones"
        active port: <analog-output-speaker>
    index: 2
        name: <alsa_output.pci-0000_03_00.1.hdmi-stereo-extra1>
        driver: <module-alsa-card.c>
        flags: HARDWARE DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
        state: SUSPENDED
        suspend cause: APPLICATION|IDLE
        priority: 9030
        volume: front-left: 65536 / 100% / 0.00 dB,   front-right: 65536 / 100% / 0.00 dB
                balance 0.00
        base volume: 65536 / 100% / 0.00 dB
        volume steps: 65537
        muted: no
        current latency: 0.00 ms
        max request: 0 KiB
        max rewind: 0 KiB
        monitor source: 5
        sample spec: s16le 2ch 44100Hz
        channel map: front-left,front-right
                     Stereo
        used by: 0
        linked by: 0
        configured latency: 0.00 ms; range is 0.50 .. 1837.33 ms
        card: 0 <alsa_card.pci-0000_03_00.1>
        module: 6
        properties:
                alsa.resolution_bits = "16"
                device.api = "alsa"
                device.class = "sound"
                alsa.class = "generic"
                alsa.subclass = "generic-mix"
                alsa.name = "C27F390"
                alsa.id = "HDMI 1"
                alsa.subdevice = "0"
                alsa.subdevice_name = "subdevice #0"
                alsa.device = "7"
                alsa.card = "0"
                alsa.card_name = "HD-Audio Generic"
                alsa.long_card_name = "HD-Audio Generic at 0xc04c8000 irq 78"
                alsa.driver_name = "snd_hda_intel"
                device.bus_path = "pci-0000:03:00.1"
                sysfs.path = "/devices/pci0000:00/0000:00:08.1/0000:03:00.1/sound/card0"
                device.bus = "pci"
                device.vendor.id = "1002"
                device.vendor.name = "Advanced Micro Devices, Inc. [AMD/ATI]"
                device.product.id = "1640"
                device.product.name = "Rembrandt Radeon High Definition Audio Controller"
                device.string = "hdmi:0,1"
                device.buffering.buffer_size = "352768"
                device.buffering.fragment_size = "176384"
                device.access_mode = "mmap+timer"
                device.profile.name = "hdmi-stereo-extra1"
                device.profile.description = "Digital Stereo (HDMI 2)"
                device.description = "Rembrandt Radeon High Definition Audio Controller Digital Stereo (HDMI 2)"
                module-udev-detect.discovered = "1"
                device.icon_name = "audio-card-pci"
        ports:
                hdmi-output-1: HDMI / DisplayPort 2 (priority 5800, latency offset 0 usec, available: yes)
                        properties:
                                device.icon_name = "video-display"
                                device.product.name = "C27F390"
        active port: <hdmi-output-1>

Audio Information:

Audio:
  Device-1: AMD Rembrandt Radeon High Definition Audio
    vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel
    bus-ID: 03:00.1
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor
    vendor: Acer Incorporated ALI driver: snd_pci_acp6x v: kernel
    bus-ID: 03:00.5
  Device-3: AMD Family 17h/19h HD Audio vendor: Acer Incorporated ALI
    driver: snd_hda_intel v: kernel bus-ID: 03:00.6
  API: ALSA v: k6.4.7-arch1-2 status: kernel-api
  Server-1: PipeWire v: 0.3.76 status: active
  Server-2: PulseAudio v: 16.1 status: active

System Information:

Operating System: EndeavourOS 
KDE Plasma Version: 5.27.7
KDE Frameworks Version: 5.108.0
Qt Version: 5.15.10
Kernel Version: 6.4.7-arch1-2 (64-bit)
Graphics Platform: X11
Processors: 8 × AMD Ryzen 5 7520U with Radeon Graphics
Memory: 7.0 GiB of RAM
Graphics Processor: AMD Radeon Graphics
Manufacturer: Acer
Product Name: Aspire A315-24P
System Version: V1.03

Your help will be much appreciated.

I’m not sure what the problem is and I don’t currently use pulseaudio, but I believe if memory serves that pulse audio runs as a user session by default, so the command you should use would be systemctl --user pulseaudio.service to check its status. Hope that little bit helps.

Thank you for your reply. Your suggested command above is giving the following:

Unknown command verb pulseaudio.service.

I forgot to add the status part. systemctl --user status pulseaudio

Thank you! The above command that you have shared is producing the following:

[rc@rc-acer-laptop ~]$ systemctl --user status pulseaudio
● pulseaudio.service - Sound Service
     Loaded: loaded (/usr/lib/systemd/user/pulseaudio.service; disabled; preset: enabled)
     Active: active (running) since Wed 2023-08-02 12:49:20 +08; 13min ago
TriggeredBy: ● pulseaudio.socket
   Main PID: 20732 (pulseaudio)
      Tasks: 9 (limit: 8577)
     Memory: 17.7M
        CPU: 193ms
     CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/pulseaudio.service
             ├─20732 /usr/bin/pulseaudio --daemonize=no --log-target=journal
             └─20742 /usr/lib/pulse/gsettings-helper

Aug 02 12:49:20 rc-acer-laptop pulseaudio[20732]: stat('/etc/pulse/default.pa.d'): No such file or directory
Aug 02 12:49:20 rc-acer-laptop systemd[760]: Started Sound Service.
Aug 02 12:49:20 rc-acer-laptop pulseaudio[20732]: Could not find org.bluez.BatteryProviderManager1.RegisterBatteryProvider(), is bluetoothd started with experimental features enabled (-E f>
Aug 02 12:49:20 rc-acer-laptop pulseaudio[20732]: org.bluez.ProfileManager1.RegisterProfile() failed: org.bluez.Error.NotPermitted: UUID already registered
Aug 02 13:01:27 rc-acer-laptop pulseaudio[20732]: Failed to create sink input: sink is suspended.
Aug 02 13:01:27 rc-acer-laptop pulseaudio[20732]: Failed to create sink input: sink is suspended.
Aug 02 13:01:27 rc-acer-laptop pulseaudio[20732]: Failed to create sink input: sink is suspended.
Aug 02 13:01:27 rc-acer-laptop pulseaudio[20732]: Failed to create sink input: sink is suspended.
Aug 02 13:01:27 rc-acer-laptop pulseaudio[20732]: Failed to create sink input: sink is suspended.
Aug 02 13:01:27 rc-acer-laptop pulseaudio[20732]: Failed to create sink input: sink is suspended.

The PC name is “rc-acer-laptop”. The username on that pc is: “rc”.

Any suggestions or ideas will be much appreciated. I am new here! Thank you!

I’m not sure, but I do see some stuff misbehaving in there. Hopefully with this output though. Someone more knowledgeable can help you. Like I mentioned before. I don’t use pulseaudio.

I found a temporary workaround, but this is not a solution. The temporary workaround is to comment the line:

load-module module-suspend-on-idle

in the file of: etc/pulse/default.pa

Commenting the line above means that the audio devices might use slightly more power and system resources because they won’t be suspended when idle. I hope the community here will provide me with a solution that can replace this temporary workaround. Thank you!

After restarting my PC, the problem returned back again. It seems my workaround above did not solve the issue.

I recommend isolating each sound server and test them out individually to see which one is causing the problem. Endeavour uses pipewire by default, so I’m not sure why you have pulseaudio installed?

If I were in your position, I would probably uninstall anything related to pulseaudio first and try to test out pipewire. Pipewire provides pipewire-pulse, which is a package that provides a daemon that is compatible with pulseaudio.

For more details on how to configure pipewire, there’s an excellent guide on Arch Wiki:

https://wiki.archlinux.org/title/PipeWire

If you have pipewire, pipewire-pulse, pipewire-alsa, pipewire-audio, pipewire-session-manager, pipewire-jack, and wireplumber installed, things should work.