Audio sometimes doesn't work on fresh install

Hi all,

I’ve just done a fresh install of EndeavourOS, and it often happens that my laptop speakers don’t produce any sound even though everything seems fine in the volume control settings (device is listed, sound appears to be playing when looking at the volume indicator, etc.). I don’t get this problem with external headphones plugged into the audio jack.

The strange thing to me is that this only happens sometimes. When I reboot my computer, there is a chance that the audio works perfectly, in which case it will continue to work for the rest of the session with no issues. However, if the audio doesn’t work on startup, nothing I’ve tried gets it to work without a reboot. This includes running systemctl --user restart wireplumber.service pipewire.service pipewire-pulse.service.

The issue doesn’t happen at all when running the EndeavourOS live USB. Audio works perfectly there. Other things I’ve tried:

  • Disabling node suspension as per section 5.1.13 of Arch wiki
  • alsactl init also as per Arch wiki
  • Using LTS kernel (which appears to be older than the kernel on the live USB where the audio works perfectly)

I’ve done many fresh installs while trying to fix this issue to no avail.

System logs (taken while the audio is not working):
Output of inxi -Aaz
Output of systemctl --user status pipewire.service
Output of systemctl --user status wireplumber.service
Output of pactl info

Thanks!