Audio output stopped working after system update

Hello, thank you for reading my post.

I’ve installed EndeavourOS with Gnome and KDE a few weeks ago, and was working fine until I ran a system update.
Now, I can not hear anything even though there seems to be no problems with the audio devices. Input is working fine.

This is actually the second time I’ve ran into this problem.
When I first installed Endeavour, I only installed with the Gnome Desktop, and at that time, no audio worked at all. So, I reinstalled with both GNOME and KDE, and audio was working fine.


I do not know much about how sound works, so I’d really appreciate it if someone could help me.
Please let me know which info I can provide.

Here’s what happens when I run dmesg |grep audio.

[onesc@endeavour ~]$ dmesg |grep audio
[    1.955024] snd_hda_intel 0000:01:00.1: Handle vga_switcheroo audio client
[    2.183989] snd_hda_intel 0000:01:00.1: bound 0000:01:00.0 (ops nv50_audio_component_bind_ops [nouveau])
[    2.663092] sof-audio-pci-intel-cnl 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if info 0x040100
[    2.663108] sof-audio-pci-intel-cnl 0000:00:1f.3: Digital mics found on Skylake+ platform, using SOF driver
[    2.663121] sof-audio-pci-intel-cnl 0000:00:1f.3: enabling device (0000 -> 0002)
[    2.663248] sof-audio-pci-intel-cnl 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if 0x040100
[    2.663309] sof-audio-pci-intel-cnl 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[    2.670188] sof-audio-pci-intel-cnl 0000:00:1f.3: use msi interrupt mode
[    2.753392] sof-audio-pci-intel-cnl 0000:00:1f.3: hda codecs found, mask 5
[    2.753395] sof-audio-pci-intel-cnl 0000:00:1f.3: using HDA machine driver skl_hda_dsp_generic now
[    2.753398] sof-audio-pci-intel-cnl 0000:00:1f.3: DMICs detected in NHLT tables: 2
[    2.754578] sof-audio-pci-intel-cnl 0000:00:1f.3: Firmware info: version 2:0:0-b678a
[    2.754579] sof-audio-pci-intel-cnl 0000:00:1f.3: Firmware: ABI 3:20:0 Kernel ABI 3:18:0
[    2.754581] sof-audio-pci-intel-cnl 0000:00:1f.3: warn: FW ABI is more recent than kernel
[    2.754583] sof-audio-pci-intel-cnl 0000:00:1f.3: unknown sof_ext_man header type 3 size 0x30
[    2.874536] sof-audio-pci-intel-cnl 0000:00:1f.3: Firmware info: version 2:0:0-b678a
[    2.874539] sof-audio-pci-intel-cnl 0000:00:1f.3: Firmware: ABI 3:20:0 Kernel ABI 3:18:0
[    2.874540] sof-audio-pci-intel-cnl 0000:00:1f.3: warn: FW ABI is more recent than kernel
[    2.908458] sof-audio-pci-intel-cnl 0000:00:1f.3: Topology: ABI 3:20:0 Kernel ABI 3:18:0
[    2.908461] sof-audio-pci-intel-cnl 0000:00:1f.3: warn: topology ABI is more recent than kernel
[    2.920571] snd_hda_codec_realtek ehdaudio0D0: autoconfig for ALC285: line_outs=2 (0x17/0x14/0x0/0x0/0x0) type:speaker
[    2.920574] snd_hda_codec_realtek ehdaudio0D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[    2.920575] snd_hda_codec_realtek ehdaudio0D0:    hp_outs=1 (0x21/0x0/0x0/0x0/0x0)
[    2.920576] snd_hda_codec_realtek ehdaudio0D0:    mono: mono_out=0x0
[    2.920577] snd_hda_codec_realtek ehdaudio0D0:    inputs:
[    2.920577] snd_hda_codec_realtek ehdaudio0D0:      Mic=0x19
[    4.313304] snd_hda_codec_realtek ehdaudio0D0: ASoC: sink widget AIF1TX overwritten
[    4.313313] snd_hda_codec_realtek ehdaudio0D0: ASoC: source widget AIF1RX overwritten
[    4.875882] snd_hda_codec_realtek ehdaudio0D0: didn't find PCM for DAI Digital Codec DAI
[    4.875887] snd_hda_codec_realtek ehdaudio0D0: ASoC: error at snd_soc_dai_startup on Digital Codec DAI: -22
[    4.875950] snd_hda_codec_realtek ehdaudio0D0: didn't find PCM for DAI Digital Codec DAI
[    4.875952] snd_hda_codec_realtek ehdaudio0D0: ASoC: error at snd_soc_dai_startup on Digital Codec DAI: -22
[   36.054168] snd_hda_codec_realtek ehdaudio0D0: didn't find PCM for DAI Digital Codec DAI
[   36.054171] snd_hda_codec_realtek ehdaudio0D0: ASoC: error at snd_soc_dai_startup on Digital Codec DAI: -22
[   36.054215] snd_hda_codec_realtek ehdaudio0D0: didn't find PCM for DAI Digital Codec DAI
[   36.054216] snd_hda_codec_realtek ehdaudio0D0: ASoC: error at snd_soc_dai_startup on Digital Codec DAI: -22

https://forums.gentoo.org/viewtopic-t-1116814-start-0.html

Are you using pipewire and pipewire-media-session or wireplumber or still pulseaudio without pipewire?

inxi -Aa
would show some info…
and
pacman -Qs pipewire
pacman -Qs pulse

Hi, thank you for the reply!

I’m using pipewire and pipewire-media-session.

Here is the result of inxi -Aa:

[onesc@endeavour ~]$ inxi -AaAudio:
  Device-1: Intel Cannon Lake PCH cAVS vendor: Hewlett-Packard
    driver: sof-audio-pci-intel-cnl
    alternate: snd_hda_intel,snd_soc_skl,snd_sof_pci_intel_cnl
    bus-ID: 00:1f.3 chip-ID: 8086:a348 class-ID: 0401
  Device-2: NVIDIA GP107GL High Definition Audio
    driver: snd_hda_intel v: kernel bus-ID: 01:00.1
    chip-ID: 10de:0fb9 class-ID: 0403
  Sound Server-1: ALSA v: k5.16.8-arch1-1 running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.45 running: yes

And the other two:

[onesc@endeavour ~]$ pacman -Qs pulse
local/libcanberra 0.30+2+gc0620e4-5
    A small and lightweight implementation of the XDG Sound Theme Specification
local/libpulse 15.0-1
    A featureful, general-purpose sound server (client library)
local/pavucontrol 1:5.0-1
    PulseAudio Volume Control
local/pipewire-alsa 1:0.3.44-1
    Low-latency audio/video router and processor - ALSA configuration
local/pipewire-pulse 1:0.3.45-1
    Low-latency audio/video router and processor - PulseAudio replacement
local/plasma-pa 5.24.0-1 (plasma)
    Plasma applet for audio volume management using PulseAudio
local/pulseaudio-qt 1.3-1
    Qt bindings for libpulse
[onesc@endeavour ~]$ pacman -Qs pipewire
local/gst-plugin-pipewire 1:0.3.44-1
    Multimedia graph framework - pipewire plugin
local/pipewire 1:0.3.45-1
    Low-latency audio/video router and processor
local/pipewire-alsa 1:0.3.44-1
    Low-latency audio/video router and processor - ALSA configuration
local/pipewire-jack 1:0.3.44-1
    Low-latency audio/video router and processor - JACK support
local/pipewire-media-session 1:0.4.1-1
    Example session manager for PipeWire
local/pipewire-pulse 1:0.3.45-1
    Low-latency audio/video router and processor - PulseAudio replacement

what if you simply try to disable HDMI audio devices here? (putting them to “off”)
As this one is the one you want to use?
2022-02-10_14-16
screwed that…

you have internal sof-audio-pci-intel-cnl and one audio from Nvidia card snd_hda_intel
and the nvidia one does not show up at all in your settings…

could you show configuration tab?
2022-02-10_14-23

Oh, it really was the configuration tab.

I set the profile and it was fixed. Thank you so much!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.