Audio output defaults to dummy output upon reboot/logout

I had a similar issue on Manjaro that caused me to need to reformat, and it seems to be an issue with audio config everytime pipewire and wireplumber are upgraded. I can still select the correct output by right clicking Kmix in the tray and clicking “Select Master Channel” and selecting Built-in Audio Digital Stereo (HDMI 2), and upping the volume again. But the problem is that on rebooting or logging off, I loose this output as being selected and it’s back to dummy output, which is annoying cause that means manually selecting the correct output several times a day. This issue happened over the past few days when I upgraded a ton of wireplumber and pipewire related packages. What can I do to force EndeavourOS to select the output HDMI 2 as default on startup? I’ve read the Arch Wiki and searched this forum to no avail. Thanks for any input.

Hello @MikeRL, take this in the terminal:

pactl list sinks

Then you see the output “Cards”.
I have the same problem, reboot is the first sinks :expressionless: the first card…

At next jump in BIOS and i deactivate the mainboard soundcard this fix my problem :smiley:

Thanks but unfortunately the UEFI firmware under Onboard devices only lets me disable the Intel sound card, which is the only sound card that works. I cannot disable the other one (I think it’s NVIDIA or Realtek, I have to check later) and I can confirm that the Intel card was disabled because disabling the only audio card I could disable in the BIOS still had dummy output listed under the master channels, but only dummy output. So no fix can be done from the BIOS, unfortunately.

try moving the configs for both wireplumber and pulse out of the way and start new:
mv ~/.config/pulse ~/.config/pulse.old
mv ~/.local/state/wireplumber ~/.local/state/wireplumber.old

instead of mv (move) you can also erase the folders… they will get recreated on next usage/login

1 Like

Output of pactl list sinks:
https://paste.ubuntu.com/p/BJvvRSbMFC/

I deleted the following with:
rm -rf ~/.config/pulse ~/.config/pulse.old
rm -rf ~/.local/state/wireplumber ~/.local/state/wireplumber.old
And upon reboot, the default is still dummy output.

should be :purple_square:
rm -rf ~/.config/pulse
rm -rf ~/.local/state/wireplumber

and in pavucontrol itb does not show any device to set?
2022-07-14_23-58

The first box shows “off” as the default option. The lower box shows “Digital Stereo (HDMI 2) Output”. See screenshot. The only option that doesn’t have “unavailable” next to it is “Pro Audio”, and when I select that it still is on dummy output.
2022-07-18_15-42

and you have something plugged into internal soundcard jacks or onto the HDMI output jack on your display?

I remember that in some cases it defaults to HDMI … but could be also the jack-plug-detection causing it… you can see it on the “output devices tab” where it will show plugged and unplugged…

and what shows:

 cat /proc/asound/modules

I think the issue may have been simpler than I thought. I removed kmix and configured the system tray to show plamsa-pa volume mixer. And now the sound is back. Thank you all for helping me. All it took was a few days away from the issue for me to realize what it actually was.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.