Audio only outputs from laptop speakers and not USB DAC/amp device, unless it's set as fallback

Hey everyone, just started using EndeavourOS a day or two ago, and very much loving it (and given this is my entryway into Linux, I’m glad it’s going well). That’s not related to my issue, I just wanted to say that because I never did after I got help from someone else on this forum before during installation. Anyway:

My audio is being a little weird. I use a small DAC/amp with my headphones (a FiiO E10K), and it plugs into a USB port rather than the headphone jack. The thing is, even though in the Volume Control it plays the test sounds fine, when I use Firefox, the sounds still come out of the laptop speakers unless I set the FiiO device as the fallback first. This happens every time I plug it in.

This really isn’t that big a deal, but I was wondering if anyone else would know how to deal with this? If not, and if I still can’t find a way to fix it, I can just live with it.

I’m not sure where you are doing this setting?

First, you go to the settings manager. Then, you start PulseAudio Volume Control, and select the Output Devices tab.
When I have the device plugged in, there’s an option next its name to check a box that says “Set as fallback” when I hover my mouse over it. I took a screenshot of my window, although the label got cut off a little bit.
Screenshot_2021-10-19_21-20-49

Okay… i have just not seen the “set as fallback” before as not all of us do these things or have the same devices. What is in the top part where it say’s Port when you have the Fiio device plugged in? Does it show it also in the drop down menu? I’m just not sure how the fallback setting works if the port is set to speakers? Maybe it has to be changed when you select fallback?

I’m sorry, it wasn’t my intention to sound snippy or anything. I was only trying to show you where the setting I’m having trouble with is located.
The top part is just my built in laptop speakers. It does have an option for fallback device. If this is set (which it is by default), then my laptop speakers play sounds instead of the USB device plugged in (in Firefox on YouTube, anyway). It seems like you can only have one fallback. Here’s a screenshot of my whole screen this time, with the window made bigger.

I wasn’t thinking you were sounding snippy or anything. I’m just pointing out that i don’t really know how the audio control settings work. I was just wondering myself because as i say i don’t have any usb audio device and i don’t usually pay much attention to it. I have had Bluetooth audio devices plugged in and working but i usually always manually change the output setting?

I guess for now, I’ll just manually change it whenever I plug it in, then. I’m just not used to it, since it works automatically when I plug it in on Windows (although Windows has its fair share of issues otherwise). Thanks anyway, though!

You can’t compare what happens in Windows to what happens on Linux. Don’t assume it’s just going to work the same way. :wink: What i’m saying is i don’t really know how it supposed to work either. :man_shrugging:

Yeah, I definitely get that. For example, I’m finding that using the terminal to do things instead of looking for ways to avoid it makes things easier. I also definitely like the centralized package management system, with apps sharing the same library dependency files, way nicer than Windows’ way, which is to force everyone to find a way to distribute their software on their own. I also really like how easy it is to build things from source compared to Windows. On Windows there are little things like this audio issue that I just have to deal with too, but with less of a chance of getting fixed.
Anyway, I’m kind of getting off topic. I’m not assuming things are always the same though, don’t worry.

1 Like