Audio Not Working on Nitro 50 Desktop

Hi. New to the community here. I’ve just installed EndeavourOS on my new Nitro 50 N50-640-EB13, and the sound isn’t working.

I’ve installed the nividia drivers for the Nvidia Geforce RTX 3060 card, no errors.

Output of inxi -Aaz

[rlee@Mycroft-V ~]$ inxi -Aaz
Audio:
Device-1: Intel Alder Lake-S HD Audio vendor: Acer Incorporated ALI
driver: snd_hda_intel v: kernel alternate: snd_sof_pci_intel_tgl
bus-ID: 00:1f.3 chip-ID: 8086:7ad0 class-ID: 0403
Device-2: NVIDIA GA106 High Definition Audio vendor: PC Partner / Sapphire
driver: snd_hda_intel v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 16
link-max: gen: 4 speed: 16 GT/s bus-ID: 01:00.1 chip-ID: 10de:228e
class-ID: 0403
Sound API: ALSA v: k5.15.81-1-lts running: yes
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.61 running: yes

I have checked in alsamixer to see if it’s muted, which it does not seem to be.

I have no sound with Opera (my browser) or Elisa.

Herewith a screenshot of pavucontrol, showing devices. The output goes to my Samsung monitor, HDMI 2.

Sorry to bother, but I’ve come to my wits end here. All help gratefully accepted.

Hi, May I see the Output Devices tab?

Here it is. It seems I can only upload one image at a time.

Appreciate the fast turnaround.

Sorry I’m not qualified for Pipewire config. Here is a workaround for me.

 sudo pacman -R pipewire-pulse
 sudo pacman -S pulseaudio
 sudo pacman -R pipewire-alsa
 sudo pacman -S pulseaudio-alsa

yay -Ss pulse | grep Installed
extra/pulseaudio-alsa 1:1.2.7.1-1 (3.2 KiB 0.0 B) (Installed)
extra/pulseaudio 16.1-3 (1.2 MiB 5.9 MiB) (Installed)
extra/pavucontrol 1:5.0+r61+gee77d86-2 (186.4 KiB 1.0 MiB) (Installed)
extra/libpulse 16.1-3 (411.6 KiB 1.5 MiB) (Installed)
extra/libcanberra 1:0.30+r2+gc0620e4-2 (91.5 KiB 438.8 KiB) (Installed)
The downside of leaving pipewire is bluetooth handling.
https://www.roxlu.com/2019/058/setting-up-a-bluetooth-headset-on-arch-linux

(I checked Mint Mate. Sound by HDMI works by default.)

Thanks. I’ll get into this as soon as I have time and post the result.

This may or may not be related, but I compiled the zen kernel using AKM and got some firmware related errors. I grabbed a screenshot.

I checked with a live USB of another distro, and encountered the same problem, so it’s not unique.

I tested in a newly installed Garuda (with zen-kernel). In Assistant/Sytem component there are 3 options for Audio: Alsa (HDMI sound OK), PulseAudio (…OK), Pipewire(No sound on HDMI). Three checkboxes (later warns that they are mutually exclusive). Reboot. Fast way of testing.

you will need to put off Built-In Audio when you want to pipe output to HDMI output of the Graphics card over your display.

I would check this before going to remove pipewire.

On configuration tab put built-in to off and only enable HDMI audio port.

Per default pipewire will only enable one pipe output.
Possible to enable output to all devices MultiSync:

1 Like

Just for fun reinstalled a test system (Arco)

[a@a-81w8 ~]$ yay -Ss pipewire | grep Installed
extra/pipewire 1:0.3.61-1 (998.3 KiB 4.9 MiB) (Installed)
[a@a-81w8 ~]$ yay -Ss pulse | grep Installed
extra/pulseaudio-bluetooth 16.1-3 (91.2 KiB 297.3 KiB) (Installed)
extra/pulseaudio-alsa 1:1.2.7.1-1 (3.2 KiB 0.0 B) (Installed)
extra/pulseaudio 16.1-3 (1.2 MiB 5.9 MiB) (Installed)
extra/pavucontrol 1:5.0+r61+gee77d86-2 (186.4 KiB 1.0 MiB) (Installed)
extra/libpulse 16.1-3 (411.6 KiB 1.5 MiB) (Installed)
extra/libcanberra 1:0.30+r2+gc0620e4-2 (91.5 KiB 438.8 KiB) (Installed)

Unplugged the HDMI cable of the Philips4109 monitor from the Notepad while playing a YT video then reconnected and it WORKS
Screenshot at 2022-12-10 21-28-10

Humble apologies to all on this thread, and thanks for your trouble. As one of my old teachers told me a long time ago in his Glasgow accent, “Always check the obvious, lad. It’ll save you a world of trouble.”

He was right. I have been driving myself crazy, when the answer to the problem was very simple. My nice new 4K monitor has no speakers.

I’m going out to buy some speakers. Thanks again, all.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.