Audio not working on my EndeavourOS

Hello everyone, I am using EndeavourOS on i3WM and my audio was working fine, today I updated my system, after the update was done, I rebooted the system and since the reboot, my audio is not working.

(More system details)

Output of inxi -Aaz

Output of systemctl --user status pulseaudio.{socket,service}

Output of alsa-info.sh --upload
https://alsa-project.org/db/?f=56a08a1f066860433a925d7ba1ea93295f5d7f34

When I reboot, I get audio for the first application I open, and as soon as I open any other application which plays any audio, the audio stops playing on every application. It feels like a very weird behavior. I even tried to switch to pipewire, but pipewire also gave the exact same problem, then I revert to pulseaudio again.

Please, someone help me to fix it :frowning:

https://bbs.archlinux.org/viewtopic.php?id=279149

looks like the same device?

I see you run on pulseaudio only? do you set this up ?
If not you will may try to check packages installed to solve pipewire setup…

pacman -Qs pipe
pacman -Qs pulse

1 Like

Yes, it is a similar device. but not the same. I have the same codec.

Codec: Realtek ALC256
Codec: Intel Kabylake HDMI

Yes, I setup pulseaudio because pipewire was giving some problems, pulseaudio was working fine for months, and yesterday when I updated the system, pulseaudio broke. :frowning:

I again tried to switch back to pipewire, it still gave the same problem.

I asked in reddit as well, these are the things which I already tried

package list shows a lot pipewire packages installed like pipewire-jack and pipewire-audio …
They could interfere with proper pulseaudio usage…
Currently a little messy to get packages installed and removed on switching…
best is to not uninstall and install needed to remove conflicting packages…
sudo pacman -S jack2 pulseaudio-jack could work

And when switching between pulse and pipe you should remove pulse settings from user dir:
rm -R ~/.config/pulse

I tried this, it gave the same problem. I rebooted and tried as well, I don’t know why I am facing this much issue suddenly after the update.

I also tried to switch back to pipewire, I removed the pulse file and deleted pulseaudio completely and installed pipewire, after rebooting… I was getting audio for some time and then the audio broke.

Now I am back to pulseaudio, which is giving the same problem.

tried lts kernel already?

are sof-firmware and alsa-ucm-conf installed?
journal could show info if firmware is failing:
journalctl -b -0 | grep firmware
(check output for uuids and private data before posting!!)

$ cat /proc/version

Linux version 5.15.81-1-lts (linux-lts@archlinux) (gcc (GCC) 12.2.0, GNU ld (GNU Binutils) 2.39.0) #1 SMP Fri, 02 Dec 2022 21:05:15 +0000

Yep its installed.

$ journalctl -b -0 | grep firmware

Dec 07 15:10:10 bharath-endy systemd[1]: Store a System Token in an EFI Variable was skipped because of an unmet condition check (ConditionPathExists=/sys/firmware/efi/efivars/LoaderFeatures-4a67b082-0a4c-41cf-b6c7-440b29bb8c4f).
Dec 07 15:10:10 bharath-endy systemd[1]: TPM2 PCR Barrier (Initialization) was skipped because of an unmet condition check (ConditionPathExists=/sys/firmware/efi/efivars/StubPcrKernelImage-4a67b082-0a4c-41cf-b6c7-440b29bb8c4f).
Dec 07 15:10:10 bharath-endy systemd[1]: TPM2 PCR Barrier (User) was skipped because of an unmet condition check (ConditionPathExists=/sys/firmware/efi/efivars/StubPcrKernelImage-4a67b082-0a4c-41cf-b6c7-440b29bb8c4f).
Dec 07 15:10:10 bharath-endy kernel: i915 0000:00:02.0: [drm] Finished loading DMC firmware i915/kbl_dmc_ver1_04.bin (v1.4)
Dec 07 15:10:10 bharath-endy kernel: Bluetooth: hci0: Found device firmware: intel/ibt-19-0-0.sfi
Dec 07 15:10:10 bharath-endy kernel: iwlwifi 0000:00:14.3: loaded firmware version 66.f1c864e0.0 QuZ-a0-jf-b0-66.ucode op_mode iwlmvm
Dec 07 15:10:11 bharath-endy NetworkManager[341]: <info>  [1670406011.1472] manager[0x562afd526010]: monitoring kernel firmware directory '/lib/firmware'.
Dec 07 15:10:20 bharath-endy systemd[1]: Startup finished in 5.450s (firmware) + 574ms (loader) + 957ms (kernel) + 798ms (initrd) + 11.726s (userspace) = 19.507s.
Dec 07 15:14:13 bharath-endy sudo[4041]:  bharath : TTY=pts/0 ; PWD=/home/bharath ; USER=root ; COMMAND=/usr/bin/pacman -S --config /etc/pacman.conf -- sof-firmware

status for pipe or pulse do not show any error warnings e.t.c?

systemctl --user status pulseaudio

no errors…

â—Ź pulseaudio.service - Sound Service
     Loaded: loaded (/usr/lib/systemd/user/pulseaudio.service; enabled; preset: enabled)
     Active: active (running) since Wed 2022-12-07 17:55:17 IST; 1h 11min ago
TriggeredBy: â—Ź pulseaudio.socket
   Main PID: 560 (pulseaudio)
      Tasks: 11 (limit: 9311)
     Memory: 5.9M
        CPU: 223ms
     CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/pulseaudio.service
             ├─560 /usr/bin/pulseaudio --daemonize=no --log-target=journal
             └─646 /usr/lib/pulse/gsettings-helper

Dec 07 17:55:16 bharath-endy systemd[551]: Starting Sound Service...
Dec 07 17:55:17 bharath-endy systemd[551]: Started Sound Service.

pacmd list-sources or pacmd list-sources | eos-sendlog to create pastebin
could show suspended device…

and you can try blacklist HDMI audio on boot kernel line:
module_blacklist=snd_hda_codec_hdmi

no errors…

https://0x0.st/odcx.txt

or

sure, I will give it a try

https://0x0.st/odcx.txt

or

sure, I will give it a try
EDIT: I tried adding the parameter by following this thread

but it made everything extremely slow, it took polybar 2 minutes to show up. and my laptop was not shutting down properly at all, after that… I removed the parameter from the grub config… and now the slowing down is fixed, but the audio is still broken :frowning:

I managed to fix it by reverting the kernel back one version.

check this thread on Manjaro Forums for more info.

@joekamprad Thank you so much for spending your time and helping me :slight_smile:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.