Audio not working/no audio devices detected

Ever since I updated my computer I have had immense trouble getting my audio to work, as in when I restart my computer it simply does not work. I have tried multiple solutions and the one which worked for a little was reinstalling ‘alsa-utils’ but this seems to be working less and less, and only under certain conditions which I can’t make sense of. Anyways, I wasn’t about to be doing that every time I opened my computer for more than a month. In the devices section of the volume control it says that no devices are detected. This is what it shows in the sound section of the settings application:

I am able to change the ‘volume’ using the respective buttons on my keyboard but of course it does nothing. When plugging my headphones in and out of the audio jack, in both cases, Plasma names the device in the middle of the screen like it would any other as ‘Built-in Audio Digital Stereo (HDMI)’ although sometimes for about a split second it shows ‘Built-in Audio Analog Stereo’ instead.

Here is my system information, couldn’t possibly leave that out.

I often work with audio/music and watch videos on my computer so a solution would be greatly appreciated. I am open to answering further questions.

Start here with logs.

Hello and welcome to :enos: forums.

Are you using the LTS kernel or the normal kernel?

Ah, thanks for the help with getting the logs.

inxi -Fxxc0z while audio was not working:

inxi -Fxxc0z while audio had been working for a while after reinstalling alsa-utils:

journalctl after having restarted the computer to test it without the audio working:

Don’t see any difference in the audio outputs for both. Not sure whats happening other than maybe it’s not selecting the correct card because usually there are two listed.

card0 and card1 as an example

I’m no expert at audio issue btw. :wink:

Check your playback output.

aplay -l

Edit: Maybe this helps?

While I had my laptop plugged into my TV through HDMI I managed to use the audio settings to change it to Audio Stereo Duplex and it works now for some reason? Probably has something to do with what Rick mentioned.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.