Audio: no output or input devices found

Hi guys,

I’m a happy user of EOS KDE Wayland for a couple of years. I love it but one thing I couldn’t solve.
In the last couple of months I don’t have sound when starting: “no output or input devices found” at the sound icon in the tray. Usually it solved with restarting.
But the sound problem is more pressing for me because I have to record a video with the desktop and the record has very high noise. Same with Skype calls, I get very high level of background noise.
What i did was to set up in System’s Sound the default recording device to headphone microphone, but then in the Skype audio I don’t see it as option. I only see “Default Device” (which supposedly is the headset) and build-in microphone. When setting this to Default Device I suspect skype also uses the built in microphone.
Same thing with OBS Studio, which records my screen, I suspect is using the built in microphone, despite me setting the headset microphone as recording device.

I installed pulse audio, pulseeffects, pavucontrol, nothing helped.
Any idea what I should do?
Thank you!

Welcome to the community! :vulcan_salute: :enos_flag:

For background noise, I’d recommend installing NoiseTorch.

It’s in the AUR:
Or you can build it from source if you prefer:

You said you are using Wayland — have you already tried x11(Xorg)?

Also, please post the output of the command below from a terminal.

pacman -Q | grep -i linux

You may need to try the LTS kernel if you don’t already have it installed.

Thank you so much!
Noisetorch indeed solved the Skype background noise.
In X11 it didn’t worked before, and with LTS kernel I didn’t try yet (because now it’s working).

Here’s the output:

[ltr01@eos ~]$ pacman -Q | grep -i linux
archlinux-keyring 20240520-1
lib32-util-linux 2.40.1-1
linux 6.9.1.arch1-1
linux-api-headers 6.8-1
linux-firmware 20240510.b9d2bf23-1
linux-firmware-whence 20240510.b9d2bf23-1
linux-headers 6.9.1.arch1-1
linux-lts 6.6.31-1
linux-lts-headers 6.6.31-1
util-linux 2.40.1-1
util-linux-libs 2.40.1-1
whatsapp-for-linux-git 1.6.5.r0.g2717ff6-1

Another thing that’s annoying is this:
I use an external monitor and I setup the image to be displayed only on the external monitor and disable the laptop’s screen.
However, after a restart, even though sometimes it works like this, most of the time I have to unplug the thunderbolt port and plug it back into the laptop for the image to move from laptop to the external monitor.
There’s some program that can “help” EOS to see the external monitor all the time?
Thank you!

Great that it’s working now. Glad I could help.

You can switch to the LTS kernel, if necessary, by selecting “Advanced Options” or some similar wording on the boot options screen.

This is another issue entirely that I have no experience with. I’ve only ever used a laptop with no external displays. So, please mark this thread as solved by clicking the “Solution” button, then open a new thread with the additional issue you mentioned.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.