Audio devices not detected today but they were all detected yesterday

I installed eos yesterday and at first all my audio devices where not detected (onboard soundcard, usb devices and hdmi / display sound on monitors). Then I installed Nvidia drivers for my graphic card and then all my sound devices begins to work !
I didn’t tried to understand why ^^ and I spend the evening playing on the pc and everything works fine. Today all the audio devices are not dectected and I don’t now what to do. I tried to install pulse audio but I was already installed. Can someone help me ?

My setup is a desktop PC with a realtek audio on board and un usb microphone (elgato wave) which I basically use as my main soundcard.

Hello and welcome !
What D.E. are you using?
Maybe to start with you can send some log.

And did you check the wiki?
Getting information while having sound issues

Would you be able to provide the link to the following.

inxi -Faz --no-host | eos-sendlog

Edit: Just copy the link that is shown after running the command and paste into the post.

Thank you for your help.
D.E. ? I don’t know the meaning of this
The link is here
Since my post I tried to switch from pulse audio to pipewire and it fixes the problem, and then after a reboot the audio devices are missing again.
So I reswitch from pipewire to pulse audio and my audio devices are listed but I don’t have sound.

Try installing pipewire like this

sudo pacman -S pipewire pipewire-pulse --needed

I had to reinstall endeavour because I switched hard drive. The problem remain the same. Sometimes It works and sometimes not. With pipewire or pulseaudio.

Can you check if sof-firmware is installed?

sudo pacman -S sof-firmware

Edit: Also would like to know if the elgato is not connected does that make any difference?

Your topic say’s audio devices not detected. Are the devices actually listed in the hardware? And or is it just not sending the audio to the proper output? Because it’s working sometimes.

Figuring out audio issues is pain staking and because you have another sound device (elgato) thrown in the mix you’ll have to first identify if the devices are actually listed and start going through a process to figure out if it’s set on the proper outputs and inputs. What is it set for the default etc.

I would probably stick with pulse audio since there is more documentation on it in the Arch wiki. Probably start here and then you’ll need to go to the Arch wiki for more info. Wish i had a snap answer but it’s a little more involved.

Thank you for your reply.

yes sof-firmware is installed
When it doesn’t work the devices are not listed in KDE-plasma interface and the sound icon is in muted state. If I launch alsamixer I can see them (maybe not everytime).

In fact the Elgato sound device is my main sound card, I practically never uses the realtek sound card.

I will reinstall pulse audio. I will comeback with an update about my problem later

Thank you again.

Did you reinstall Nvidia drivers too ?

What is

aplay -l
pacmd list-cards
pacmd list-sinks
sudo fuser -v /dev/snd/*