Audio devices not detected on EndeavourOS

I took apart and put my PC back together today for cleaning, and to tidy up the cable management. Onboard audio was perfectly functional before. After reassembly, neither onboard nor front panel audio is functional. Both sound cards are detected but any devices plugged into either port go undetected and there’s no way to enable either as anything but Pro Audio, which does nothing.


Better check your connections again? What do you have in the audio system settings on Kde?

I did check my HD audio connection, and I’ve tried plugging and unplugging multiple pairs of monitors into both the front panel audio and the motherboard line out, with no success in any instance. The above is a screenshot of what my audio settings look like. For profile, I have no options except Off and Pro Audio. Pro Audio does not give any audio output either, and before this issue arose I had Analog Stereo Duplex available, which worked perfectly.

1 Like

Wish you better luck than mine

Update: I unplugged my GPU from the PCIe x4 slot and plugged it into the x16 slot, which is significantly further from the Intel HD Audio header and has no risk of potentially stressing the connection or resulting in improper contact. After doing this, switching from HD Audio to AC’97 in UEFI results in the motherboard audio output being visible in settings. However, despite the sound card being listed, with an Analog Stereo Duplex profile option available, the Line Out is shown as unplugged even when something is plugged into it, and if the profile is set to Analog Audio Output it becomes impossible to attempt to play a test sound, as doing so presents an IO error.

Why did you have the Gpu in 4x slot? It should be in the 16x slot.

Edit: Have you checked the front audio header to make sure you have the wires connected properly?


Edit: Check UEFI Bios settings for audio.

I was having some unrelated issues with video output when the card was in the x16 slot (thanks Nvidia), which were resolved when using it in x4.

I have tried to confirm and it is impossible for me to plug in the front panel audio header incorrectly. The pinout is designed in such a way as to not allow this.

I am fairly certain that my case is using HDA and not AC’97, as the header is labeled AUDIO rather than AC’97 which while not definitive does point in the direction of it being HD Audio. The case is also fairly recent, so I can’t imagine why or really even how they would’ve gone with an audio codec from 1997. As well, the header being AC’97 would not explain why even the motherboard’s own onboard lineout has ceased functioning, even with the header unplugged.

In the UEFI BIOS, I have tried the following configurations:

Onboard HD Audio Auto, Front Panel HD

Onboard HD Audio Enabled, Front Panel HD

Onboard HD Audio Auto, Front Panel AC’97

Onboard HD Audio Enabled, Front Panel AC’97

(I greatly appreciate the extent and quality of your help by the way, it’s an extremely welcome change of pace from some other places within the open source community and reminds me once again why EOS will probably be the last distro I ever hop to.)

Are you using the onboard audio out connection to speakers?

I’ve tried both onboard audio out, and the front panel audio. While onboard used to work, it hasn’t ever since I rebuilt the system.

Well not sure what you have done. Does the audio work if you boot on the live ISO on either?

Do you know which HDA chip is on your board. Automatic detection/loading for some chips is a bit flaky. For example some Wolfson Audio chips require manual loading of kernel module.

[ricklinux@eos-kde ~]$ inxi -Aa
  Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
    vendor: Gigabyte driver: snd_hda_intel v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 16 link-max: gen: 3 speed: 8 GT/s bus-ID: 2d:00.1
    chip-ID: 1002:aaf0 class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 2f:00.4 chip-ID: 1022:1487 class-ID: 0403
  API: ALSA v: k6.4.10-arch1-1 status: kernel-api
    tools: alsactl,alsamixer,amixer
  Server-1: PipeWire v: 0.3.77 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl

It hasn’t worked across a variety of live boots, and now after a fresh Endeavour install, it continues to not work.