Audio and video do not sync with each other

As the title says.
I’ve looked at this link Audiophile and the arch wiki. And I don’t think I can find a solution.

I tried to followed the instructions on how to improve my sound quality.
The part where I have to:

To check out which output sample rate and sample format are the data sent to DAC (probably you need to change digits):

cat /proc/asound/card0/pcm0p/sub0/hw_params

The files it needs to cat are empty. I get an output called:


further down the page i can Get all supported sample rates and formats.
But the folders they refer to do not exist on my system.
I know that x has to be replaced to suit my system. But I don’t have any streamX files or anything that starts with stream.

I don’t know if the above has anything to do with audio and video do not sync with each other.
But as long as my audio syncs with video, I’m fine.

Sorry for all these posts, I’m new to EOS.

Disclaimer; not on Endeavour (Manjaro for now…) so can’t check directly.

/proc/asound/card<x>/pcm<y>p/sub<z>/hw_params only provide said hw_params if said ALSA-device is not closed. PulseAudio closes an its sink underlying ALSA-device after an only short time of the sink being idle – and assuming you use PipeWire, appears it also does. I.e., if you want to know e.g. sample-rate of the audio the hardware is being fed when playing, play something and then cat that file.

PulseAudio/PipeWire sort of exist as a Just Works layer (whahahahaha – but never mind…) over ALSA and yes, one of the things they do is potentially resample audio before handing it to the hardware so as to be able to mix audio from different sources: that needs a common sample-rate. Yes, that introduces latency and if bad, may introduce A/V sync issues. Same is sort of true for e.g. software volume and certainly is for normalization, equalization, … – so it sort of depends on what if any special things you are doing and, yes, may also depend on your hardware. Some hardware e.g. advertises to support sample-rates and/or formats which it in fact only internally resamples/refits, again with potential latency issues.

If you are not doing anything special as to e.g. equalization my first suggestion would be to switch to PulseAudio; Not that PA is great but it’s at least more tested. You’d confirm/deny the issue being specific to PipeWire and/or your PipeWire setup.

inxi -Fxz will be needed for any more direct potential assistance…

If you are not doing anything special as to e.g. equalization my first suggestion would be to switch to PulseAudio; Not that PA is great but it’s at least more tested. You’d confirm/deny the issue being specific to PipeWire and/or your PipeWire setup.

I have a dual boot with fedora and EOS. I use pipewire on both OS. I don’t experience the same audio problems on fedora.

I can of course try to change it to Pulsaudio a little later and see if it works.
Haven’t touched the audio or much else in the system at all. It is a fresh install of EOS.

inxi -Fxz

  Kernel: 6.0.11-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    Desktop: dwm v: 6.4 Distro: EndeavourOS base: Arch Linux
  Type: Laptop System: Dell product: XPS 13 9300 v: N/A serial: <filter>
  Mobo: Dell model: 077Y9N v: A00 serial: <filter> UEFI: Dell v: 1.15.0
    date: 09/13/2022
  ID-1: BAT0 charge: 38.6 Wh (100.0%) condition: 38.6/51.0 Wh (75.7%)
    volts: 8.5 min: 7.6 model: SMP DELL WN0N00B status: full
  Info: quad core model: Intel Core i7-1065G7 bits: 64 type: MT MCP
    arch: Ice Lake rev: 5 cache: L1: 320 KiB L2: 2 MiB L3: 8 MiB
  Speed (MHz): avg: 1400 high: 1500 min/max: 400/3900 cores: 1: 1100 2: 1100
    3: 1500 4: 1500 5: 1500 6: 1500 7: 1500 8: 1500 bogomips: 23961
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: Intel Iris Plus Graphics G7 vendor: Dell driver: i915 v: kernel
    arch: Gen-11 bus-ID: 00:02.0
  Device-2: Realtek Integrated_Webcam_HD type: USB driver: uvcvideo
    bus-ID: 3-9:2
  Display: server: X.Org v: 21.1.4 driver: X: loaded: modesetting
    unloaded: fbdev dri: iris gpu: i915 resolution: 3840x2400~60Hz
  API: OpenGL v: 4.6 Mesa 22.2.3 renderer: Mesa Intel Iris Plus Graphics
    (ICL GT2) direct render: Yes
  Device-1: Intel Ice Lake-LP Smart Sound Audio vendor: Dell
    driver: snd_hda_intel v: kernel bus-ID: 00:1f.3
  Sound API: ALSA v: k6.0.11-zen1-1-zen running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.61 running: yes
  Device-1: Intel Ice Lake-LP PCH CNVi WiFi vendor: Rivet Networks
    driver: iwlwifi v: kernel bus-ID: 00:14.3
  IF: wlan0 state: up mac: <filter>
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 3-10:3
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Local Storage: total: 953.87 GiB used: 7.3 GiB (0.8%)
  ID-1: /dev/nvme0n1 vendor: KIOXIA model: KXG60ZNV1T02 NVMe 1024GB
    size: 953.87 GiB temp: 43.9 C
  ID-1: / size: 205.47 GiB used: 7.18 GiB (3.5%) fs: btrfs dev: /dev/nvme0n1p9
  ID-2: /boot/efi size: 346.9 MiB used: 122.3 MiB (35.2%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-3: /home size: 205.47 GiB used: 7.18 GiB (3.5%) fs: btrfs
    dev: /dev/nvme0n1p9
  ID-4: /var/log size: 205.47 GiB used: 7.18 GiB (3.5%) fs: btrfs
    dev: /dev/nvme0n1p9
  ID-1: swap-1 type: partition size: 25 GiB used: 0 KiB (0.0%)
    dev: /dev/nvme0n1p8
  System Temperatures: cpu: 57.0 C mobo: 44.0 C
  Fan Speeds (RPM): cpu: 0 fan-2: 0
  Processes: 243 Uptime: 1h 30m Memory: 15.21 GiB used: 4.33 GiB (28.4%)
  Init: systemd Compilers: gcc: 12.2.0 Packages: 857 Shell: Zsh v: 5.9
  inxi: 3.3.23

Okay, given that Fedora + PipeWire works fine where Endeavour + PipeWire does not, really all I can do is plug your hardware into Google and that’s not finding me anything that would have me recommend a kernel up- or downgrade or alike (but still do compare kernel versions between Fedora and Endeavour I guess) and that’s then to say that it’s seemingly something Endeavour specific which I’ll furthermore butt out of.

The A/V player(s) is/are also the same between Fedora and Endeavour?

That’s when I watch youtube videos. I don’t know what kind of AV player the system uses to display youtube videos.

I have tried to debug with mpv player. But the mpv player is way too slow. It spends a lot of time on buffering.
I have also tried downloading some youtube videos to debug through mpv player.

But it took 12 hours and it had only downloaded 20% of the video, without sound :slight_smile:
google says it has nothing to do with mpv player or youtube-dl.
It’s youtube that makes it slow.

I can try to log into my fedora installation to see if I have any software installed there that I don’t have on EOS. But there should be less softwear and drivers on my fedora installation. Because, on fedora minimal you have to manually install hardware support and X drivers and utils.
On EOS base install/minimal, everything is installed unless you opt it out.

That would be “the browser” as such then. Again isn’t helping that I’m not using Endeavour but a quick search stumbled onto this:

Do you use Firefox? Does fedora have Jack installed/running? Does that about:config tweak do anything useful on Endeavour? (where you don’t have Jack running)

If not I’m afraid I’ve nothing more to offer…

I use firefox on both OS. And jack is installed on both OS.

But I have tried what was on that link. It did not work.

And I was wrong. Fedora does the same. Sorry.

Both are fresh installations. The problem was not there on fedora 36. It must have come with fedora 37, and the new kernel that was released 2-3 days before fedora 37 was released.

But on EOS, I have tried linux kernel, LTS and zen. It’s the same problem on all kernels.