ATI Radeon 5770 and possible video acceleration?

Still on the process to setup my MacPro 5.1 with eOS, today (and the days before) I was looking for indications in order to use my ATI Radeon HD 5770 at its best possibilities. The DisplayPort output was working fine after install, but I really want to know if it could be better when reading videos on the web, and if video acceleration is supported. I will not encode video on this machine :roll_eyes:

eOS Wiki mention ATI driver are already installed (TerraScale 2 for my GPU)

Arch wiki ATI page advices to install the mesa package, which provides the DRI driver for 3D acceleration.

So I’ve installed the mesa packages: mesa-vdpau, mesa-demos, libva-mesa-driver and libva-utils

vainfo is a bit short:

[philippe@macpro ~]$ vainfo
vainfo: VA-API version: 1.12 (libva 2.12.0)
vainfo: Driver version: Mesa Gallium driver 21.1.6 for AMD JUNIPER (DRM 2.50.0 / 5.10.56-1-lts, LLVM 12.0.1)
vainfo: Supported profile and entrypoints
      VAProfileMPEG2Simple            :	VAEntrypointVLD
      VAProfileMPEG2Main              :	VAEntrypointVLD
      VAProfileVC1Simple              :	VAEntrypointVLD
      VAProfileVC1Main                :	VAEntrypointVLD
      VAProfileVC1Advanced            :	VAEntrypointVLD
      VAProfileH264ConstrainedBaseline:	VAEntrypointVLD
      VAProfileH264Main               :	VAEntrypointVLD
      VAProfileH264High               :	VAEntrypointVLD
      VAProfileNone                   :	VAEntrypointVideoProc
[philippe@macpro ~]$ 

Then, the arch wiki page Hardware video acceleration, I read vdpau should be supported, but is giving me an error (about nvidia !!!):

[philippe@macpro ~]$ vdpauinfo
display: :0   screen: 0
Failed to open VDPAU backend cannot open shared object file: No such file or directory
Error creating VDPAU device: 1
[philippe@macpro ~]$ 

Here is a capture of the cli radeontop when playing a peertube vid. The two red lines are over 100% ???

I know ATI Radeon 5770 is quite old, and being on wayland complicate my understanding about how it’s work…
Do I get the right driver(s), or what do I miss ?
Note: I did not install any lib32 package yet

[philippe@macpro ~]$ inxi -Gxxx
Graphics:  Device-1: AMD Juniper XT [Radeon HD 5770] vendor: Apple MacPro5 1 driver: radeon v: kernel 
           bus-ID: 05:00.0 chip-ID: 1002:68b8 class-ID: 0300 
           Display: wayland server: 1.20.13 compositor: gnome-shell v: 40.3 driver: 
           loaded: ati,radeon unloaded: fbdev,modesetting,vesa resolution: <missing: xdpyinfo> 
           OpenGL: renderer: AMD JUNIPER (DRM 2.50.0 / 5.10.56-1-lts LLVM 12.0.1) v: 3.3 Mesa 21.1.6 
           compat-v: 3.1 direct render: Yes 
[philippe@macpro ~]$ 
[philippe@macpro ~]$ xrandr
Screen 0: minimum 16 x 16, current 1920 x 1080, maximum 32767 x 32767
XWAYLAND0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 530mm x 300mm
   1920x1080     59.96*+
   1440x1080     59.99  
   1400x1050     59.98  
   1280x1024     59.89  
   1280x960      59.94  
   1152x864      59.96  
   1024x768      59.92  
   800x600       59.86  
   640x480       59.38  
   320x240       59.52  
   1680x1050     59.95  
   1440x900      59.89  
   1280x800      59.81  
   720x480       59.71  
   640x400       59.95  
   320x200       58.96  
   1600x900      59.95  
   1368x768      59.88  
   1280x720      59.86  
   1024x576      59.90  
   864x486       59.92  
   720x400       59.55  
   640x350       59.77  
[philippe@macpro ~]$ 

Any advice are welcome

Maybe run through configuration helps.

Have you tried VA-API with the translation layer?

Translation layers

  • libva-vdpau-driver — A VDPAU-based backend for VA-API. || libva-vdpau-driver, libva-vdpau-driver-chromiumAUR, libva-vdpau-driver-vp9-gitAUR

Thanks. As I don’t know exactly what a Translation layers is… but I just installed it an reboot.

[philippe@macpro ~]$ vdpauinfo
display: :0   screen: 0
Failed to open VDPAU backend cannot open shared object file: No such file or directory
Error creating VDPAU device: 1
[philippe@macpro ~]$

vdpau seems to be for nvidia use HW video decode support for VDPAU platforms. e.g. NVIDIA
And it seems to be develop for intel according to their web site:

I did it, but with my knowledge…

When it comes to the Arch wiki I’m not any more enlightened. I just read that it say’s the driver it should be using is radeonsi


$ grep -iE 'vdpau | dri driver' /var/log/Xorg.0.log

(II) RADEON(0): [DRI2] DRI driver: radeonsi
(II) RADEON(0): [DRI2] VDPAU driver: radeonsi

It talks about configuring the driver … :man_shrugging:

Have you tried it on Xorg instead of wayland?

On this wiki page, it says:

For AMDGPU driver use radeonsi.

But my vid card (TerraScale 2 gen) needs the old ATI driver, not the new AMDGPU , and If I switch to Xorg, I would first have to learn how…

Yes i understand your card uses ati it’s already installed xf86-vdeo-ati The wiki say’s both va-api and vdpau are supported under ati and amdgpu.

It’s the configuration part that i pointed to and i don’t understand their instructions any better either. It tells information but lacks specifics. :man_shrugging:

Looks good. vainfo shows va-api working. With that there’s no need for anything vdpau related. You only need one and va-api is preferred.

The next step is to activate hardware acceleration in the browser:

1 Like

Oh…it’s under Firefox? I didn’t realize that? I thought it was specific to the graphics card.

Edit: Yet it still points back to the same wiki page. No wonder it’s so confusing.

Work in progress: set gfx.webrender.all to true already… but webgl test is in between 25 and 35 fps @500 fishes

I try to setup graphic drivers card first, next Firefox and also mpv…

I can do 10000 fish @ 26 fps

I understand. The problem i have is the Arch wiki. I just find it very challenging to say the least. It’s spews lots of information but there is no do A B C D to get to E! It annoys me!

my GPU do no support 10 000 fish, I got 4fps! and I quit the page :astonished:

mpv is a good start. Get a 1080 h.264 video and then toggle hardware acceleration with the ctrl+h shortcut. If everything is working you should see the CPU usage drop (or increase).

Well, I wonder what’s the GPU temp after 5 min on webgl test page (at same score). I’ve plan to change the GPU thermal paste soon, it is close to 10 years old, and this computer was used for graphical business all day long…

Ctrl+H when playing vid in mpv?
I found it in man mpv:

Ctrl h Toggle hardware video decoding on/off.

The wiki has great detail information on how, but not so much why. Understanding the whole stack (GPU-vendor, GPU-generations, driver-versions incl. open vs proprietary, OpenGL/Vulcan, video-acceleration, settings in particular apps, X vs Wayland) is a steep learning curve.