Atheros AR9285 WiFI very unstable

This happen on all linux distros. I google it, but I did not find a solution to the problem. windowsOs have stable connection. I would not want to come back. Please halp! -_- %D0%A1%D0%BD%D0%B8%D0%BC%D0%BE%D0%BA%20%D1%8D%D0%BA%D1%80%D0%B0%D0%BD%D0%B0_2019-10-26_17-05-11

Hello @happyexcellence The Atheros AR9285 runs at 2.4 Ghz. It is a single band 2.4 Ghz chip as far as i know. So it is likely an 802.11n standard. Do you know the manufacturer of the card? How old is this hardware? I’m trying to confirm this possibly.
When it’s connected could you post the output of:
iwconfig

Do you know the manufacturer of the card?

%D0%A1%D0%BD%D0%B8%D0%BC%D0%BE%D0%BA%20%D1%8D%D0%BA%D1%80%D0%B0%D0%BD%D0%B0_2019-10-26_17-03-43
iwconfig
enp5s0 no wireless extensions.

lo no wireless extensions.

wlp3s0 IEEE 802.11 ESSID:“happyWifi”
Mode:Managed Frequency:2.462 GHz Access Point: 94:CE:2C:A7:54:AC
Bit Rate=65 Mb/s Tx-Power=15 dBm
Retry short limit:7 RTS thr:off Fragment thr:off
Power Management:off
Link Quality=44/70 Signal level=-66 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:23 Missed beacon:0

Yes it is definitely a single band 2.4 Ghz . What are you connecting to? What is it you are connecting to? Wireless modem router? What is the hardware and have you tried looking at the router settings. Sometimes the channel makes a difference.

It is using the correct driver. ath9k

Welcome @happyexcellence

Via a Google search I found one user having problems similar to yours.
The fix for them was to:
Create a new file /etc/modprobe.d/ath9k.conf If it does not already exist.

sudo nano /etc/modprobe.d/ath9k.conf
Add the following line to it:
options ath9k nohwcrypt=1
Save, exit, and reboot.

1 Like

@CMarch I was going to get to this but you got here first. Good one. :slightly_smiling_face:
The nohwcrpt=1 turns off encryption. It may or may not work.

nohwcrypt=1 Use CPU crypto instead for better performance,
more reliable connections
but…“do not disable unless chip is known buggy”

I’m using mobile phone Sony Xperia ZL, my phone does not suport 5Ghz.

I did: not work
Could this be a problem on linux? I want to clarify, the signal deteriorates with outgoing traffic (Internet surfing, updates and etc), in the idle state I have a full wifi signal scale.
p.s: I will try test another phone
Screenshot_Settings_20191027-024327

You could try other channels. Also what kernel are you running? The current 5.3.7? You could try the lts kernel and see if there is any difference.

So are you using tethering to connect to the internet? Via your cell phone?

What channels, how I can change this?? Yes, 5.3.7 ( after update) and the default kernel (current last distro from site) have same problem. I tested openSuse tumbleweed (same) and manjaro (all current kernels, same) I’m using tethering because I don’t have alternative) On windowsOs I have stable signal (default drivers and proprietary)

Okay i see. I was talking about wireless channels on your router settings. You could also try the lts kernel i suppose. My only other suggestion is to replace the wifi card with something better such as a TP-link that uses Broadcom or some other brand. They are not expensive and that is what i would do. Endeavour has broadcom-wl-dms included.

1 Like

Perhaps I will postpone linux until better times, thanks for your support)

support is on linux always more bad on linux, is just the manufacturer they should support given driver… i had a atheros my self one chip did it ok other less, sometimes it droppes , its also possible to do on powersaving on a guess … but i would try to endeavour a bit im sure there will something going up

One more thing to try: usb tethering. Does that work?

1 Like