ASUS Vivobook S 14X OLED S5402 Keyboard isn't working

$ uname -r
⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
⎜   ↳ ASUE140D:00 04F3:31BC Mouse             	id=10	[slave  pointer  (2)]
⎜   ↳ ASUE140D:00 04F3:31BC Touchpad          	id=11	[slave  pointer  (2)]
⎣ Virtual core keyboard                   	id=3	[master keyboard (2)]
    ↳ Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
    ↳ Power Button                            	id=7	[slave  keyboard (3)]
    ↳ Lid Switch                              	id=8	[slave  keyboard (3)]
    ↳ USB2.0 HD UVC WebCam: USB2.0 HD         	id=9	[slave  keyboard (3)]
    ↳ Video Bus                               	id=6	[slave  keyboard (3)]
    ↳ Asus WMI hotkeys                        	id=13	[slave  keyboard (3)]
    ↳ ASUE140D:00 04F3:31BC Keyboard          	id=12	[slave  keyboard (3)]

The Keyboard appears to be recognized but it doesn’t work. The only thing I can do on the keyboard is using the FN Keys to control the display brightness.
I’ve also tried Linux Mint and it has the same problems. External keyboards are working flawlessly.

Looks like a kernel issue.

found that topic too. They said they applied the patch for the S5402ZA Model aswell, i don’t quite understand if I have to configure something?

It was only merged recently. I don’t follow kernel development closely enough to know when that patch will actually be in production kernels.

If it isn’t there currently, you would need to apply the patch and build the kernel yourself.

Probably this is the patch?
Do you might have a reference on how to apply a patch? I’m a total newb to kernel stuff.

You can easily use the patch command to apply the patch.

The harder part is building the kernel.

Here are the instructions for that.

Okay thanks,
then this should be solved. If you have this laptop model or any other mentioned in the bug thread, you can either wait for kernel version 6.1+ or patch it yourself.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.