Assistance needed: Getting my NVIDIA Optiomus card working


I’ve just installed Endeavour OS, and I am attempting to get my Nvidia RTX 3060 / Intel CometLake Optimus GPU system to work, and I’m running into some issues.

I should mention that doing an install with the systemd bootloader bricked my system, preventing me from installing ANY distro, and I had to use the GRUB 2 bootloader.

II used the nvidia-inst program to install my drivers, and n’m trying to use EnvyControl to set my system into hybrid mode. It appears to work but using the nvidia-smi command it returns:

NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

I also get the error that the NVIDIA Persistence service fails to load upon boot. Running EnvyControl in nvidia mode causes a black screen on boot, until I TTYY to the terminal and switch it back to internal or hybrid mode and reboot. I attempted adding the nvidia-drm.modeset=1 into the GRUB Kernel line, and rebuilt the grub.cfg line successfully. However, when booting into the system the nvidia-smi command still returns the same error. I cannot try the other two options because they require the systemd bootloader and the reinstall-kernels module is missing.

I am at a loss as to where to go now. I know that the systemd bootloader would probably help the situation, but as i said, it bricks my system by refusing to load any bootloader, even after installing another distro. The only way I have found to fix it is to install EndeavourOS as GRUB2 or installing Windows.

Here’s the output of my inxi -Fz command:

Kernel: 6.8.1-arch1-1 arch: x86_64 bits: 64
Desktop: KDE Plasma v: 6.0.2 Distro: EndeavourOS
Type: Laptop System: Micro-Star product: GF65 Thin 10UE v: REV:1.0
Mobo: Micro-Star model: MS-16W2 v: REV:1.0 serial:
UEFI: American Megatrends v: E16W2IMS.105 date: 05/14/2021
ID-1: BAT1 charge: 38.0 Wh (97.4%) condition: 39.0/51.3 Wh (75.9%)
Info: 6-core model: Intel Core i5-10500H bits: 64 type: MT MCP cache:
L2: 1.5 MiB
Speed (MHz): avg: 800 min/max: 800/4500 cores: 1: 800 2: 800 3: 800 4: 800
5: 800 6: 800 7: 800 8: 800 9: 800 10: 800 11: 800 12: 800
Device-1: Intel CometLake-H GT2 [UHD Graphics] driver: i915 v: kernel
Device-2: NVIDIA GA106M [GeForce RTX 3060 Mobile / Max-Q] driver: N/A
Device-3: Bison HD Webcam driver: uvcvideo type: USB
Display: wayland server: v: with: Xwayland v: 23.2.4
compositor: kwin_wayland driver: X: loaded: modesetting dri: iris gpu: i915
resolution: 1280x720
API: EGL v: 1.5 drivers: iris,swrast
platforms: gbm,wayland,x11,surfaceless,device
API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 24.0.3-arch1.1
renderer: Mesa Intel UHD Graphics (CML GT2)
API: Vulkan Message: No Vulkan data available.
Device-1: Intel Comet Lake PCH cAVS driver: snd_hda_intel
Device-2: NVIDIA GA106 High Definition Audio driver: snd_hda_intel
API: ALSA v: k6.8.1-arch1-1 status: kernel-api
Server-1: PipeWire v: 1.0.4 status: active
Device-1: Intel Comet Lake PCH CNVi WiFi driver: iwlwifi
IF: wlan0 state: up mac:
Device-2: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
driver: r8169
IF: enp5s0 state: down mac:
Device-1: Intel AX201 Bluetooth driver: btusb type: USB
Report: btmgmt ID: hci0 rfk-id: 0 state: down bt-service: disabled
rfk-block: hardware: no software: no address: N/A
Local Storage: total: 1.38 TiB used: 11.99 GiB (0.9%)
ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO Plus 1TB
size: 931.51 GiB
ID-2: /dev/nvme1n1 vendor: Micron model: 2210 MTFDHBA512QFD
size: 476.94 GiB
ID-1: / size: 896.25 GiB used: 11.99 GiB (1.3%) fs: btrfs
dev: /dev/nvme0n1p2
ID-2: /boot/efi size: 998 MiB used: 584 KiB (0.1%) fs: vfat
dev: /dev/nvme0n1p1
ID-3: /home size: 896.25 GiB used: 11.99 GiB (1.3%) fs: btrfs
dev: /dev/nvme0n1p2
ID-4: /var/log size: 896.25 GiB used: 11.99 GiB (1.3%) fs: btrfs
dev: /dev/nvme0n1p2
ID-1: swap-1 type: partition size: 34.28 GiB used: 0 KiB (0.0%)
dev: /dev/nvme0n1p3
System Temperatures: cpu: 39.3 C pch: 50.0 C mobo: N/A
Fan Speeds (rpm): N/A
Memory: total: 32 GiB available: 31.17 GiB used: 3.09 GiB (9.9%)
Processes: 299 Uptime: 10m Shell: Bash inxi: 3.3.33

Thanks in advance for your help.


Have you tried these kernel parameters?

nvidia_drm.fbdev=1 initcall_blacklist=simpledrm_platform_driver_init nvidia_drm.modeset=1

I added those parameters to the GRUB Kernel line and no change. I am not familliar with how to edit the kernel directly using the dracut system. If there is a way I would be grateful for your help.

If you are using grub you add them to the grub command line in /etc/default/grub and save. Then you have to run the grub update command sudo grub-mkconfig -o /boot/grub/grub.cfg It doesn’t have anything to do with touching dracut. Then reboot and see if any difference.

That’s what I did, there was no change.

Okay … it was just something to try that another user posted that worked for them on a hybrid laptop with nvidia. Are there settings in the bios for setting integrated, dedicated or hybrid gpu?

Actually… I have checked the standard BIOS settings and found nothing, but I forgot about the fact that there’s a key combination that I can do that opens up a TON of settings. It’s how I got my USB-C ports working at full speed. Let me try that and I’ll report back what I find.

UPDATE: Even in the advanced settings, there’s no integrated/hybrid/nvidia controls. I KNOW it’s possible, but MSI makes it so freaking hard to get one of their laptops to work with Linux, they are an extremely anti-Linux company… If I didn’t get this amazing laptop at a pawn shop for a STEAL i wouldn’t use MSI. LOL

Well i like their desktop motherboards. That’s what i use and any laptops i have are Ryzen non hybrid with AMD gpu. I don’t own any hybrid laptops and i would not buy any that have that type of hardware of with Nvidia gpu. :wink:

To be fair, it was a $1700 computer for $300. :smiley: I couldn’t pass it up. I guess it’s time for a deep dive into the Nvidia Optimus documentation. Uggh. LOL

Ya I’m just going by what i read about the HP Omen that has the Advanced Nvidia Optimus.

Edit: This might be the answer as i said it should work with just prime render.