Assigning a specific Icon to a file type

I just installed and changed to a new theme, download the appropriate application style, and changed the icon set from what came with the global theme to NoManSky. The issue is that it looks like I have a icon set for everything excep[t for .m3u. I honestly have no idea where to look to change the icon associated with particular file types. Help with this would be greatly appreciated. Thanks

Right click the file, select properties, click file type options. Click the icon:

Select a new icon.

3 Likes

Thanks for that. I actually remembered to go to file associations in settings, but now I know of two ways to get to it. Thanks again.

1 Like

Looks like with the updates yesterday KDE fix certain icons not appearing. After a reboot today and after noticing I’m missing a ton a app shortcut icons I did notice that the .m3u icon was finally the one that comes with the current icon theme I’m running. Looks like in the process of fix that they broke something else.