Assigned system hotkeys are not working

Talking about options located here:
Control panel > Keyboard > Application Shortcuts.

I’m trying to launch sh script. Here is my command for launching application.

/home/sp808/Projects/Website-pug-testing/ file holds plain:

npm run dev

Any ideas?

ps weird thing, when pressing ctrl+shift+1 system detects it as ctrl+shift+!.
I’m using Keychron Q6 keyboard. System layout is Geenric 105-key PC.

Dumb question, but the script executes properly when you run it manually in a terminal emulator, right?

Not dumb at all, every bit helps.
Yeah, script executes without any problems.

Tried to put this


Session and Startup > Application Autostart

Restarted a machine and of course nothing happened.
Maybe i’m doing’ something wrong, due to lack of Linux knowledge.

I have no memory of how npm works. Does “dev” refer to a project folder or something? Does it need absolute paths put into the script? You could do a test by replacing the contents of the script with something more familiar that you know should launch (xfce-terminal, for example). Then we can break the issue down from there.

Another two obvious things you could check. What keyboard shortcut are you trying to use to launch the script? And are you referring to the script with an absolute path when entering it into the Application Shortcuts menu?

Shortcut properties:

Working directory:


Session and startup settings:



Assigned shortcut:


No, it is not folder, it is mode of webpack application.

I don’t have access to an XFCE4 install, but I’m curious if our understanding of what “working directory” means is correct. Are you able to launch other programs with your keyboard shortcut, such as thunar or xfce4-terminal?

Thunar and terminal are launching. But my sh file is not.
It looks like i don’t understand something.

Do thunar and xfce-terminal launch even with the working directory being listed as /home/sp808/Desktop/Projects/Website-pug-testing/?

I would try getting rid of the “working directory” field and putting the full path of the script into the “command” field. I don’t think the “working directory” refers to the location of the script.

  1. build a .foxtrader file in /home/username
  2. make the property of ~/.foxtrader executable and also readable and writable by username
  3. give command in session and stage as the following
  4. .foxtrader has the following content:
    xfce4-terminal -e “env WINEARCH=“win64” WINEPREFIX=”/home/username/.wine804048" wine64 explorer /desktop=name,3775x2050 /home/username/.wine804048/drive_c/Fox20161226T/FoxTrader-Big5.exe " --hold

3a) build a launcher in panel which has the following executing configuration:

a) name = foxtrader
b) command = /home/username/.foxtrader
c) working directory = /home/username
d) icon = your own choice

ps. Replace username with your own username

My original .foxtrader content is the following:
xfce4-terminal -e “env WINEARCH=“win64” WINEPREFIX=”/home/username/.wine804048" wine64 explorer /desktop=name,3775x2050 /run/media/username/ext4gge/.wine804048/drive_c/Fox20161226T/FoxTrader-Big5.exe " --hold

I tried it in a session and stage launcher, but during the booting i cann’t open external SSD drive ext4gge at a new thunar window, so i have to use key ‘alt + tab’ to change window to terminal to kill this process.
I usually run this proc in a panel launcher.
It is my own habit to assign a hot-key to a program in wine by using ‘xbindkey’, but never to linux system itself.