Artemis ARM install works on Rpi CM4

Just setup my Compute Module 4 (32gb emmc, 4gb ram, wifi+bt) using the new installer. Setup was super easy, was able to install rpiusbboot (needed to flash the internal storage of the cm4) through AUR in the live usb environment.

Everything worked out of the box for a xfce install, Only small issue was bluetooth didnt work post install, was enabled in config.txt, ended up having to run “bluetoothctl power on” before it worked, but bt audio seems fine.

Tested dual hdmi outputs and it actually worked better than rpiOS, Allowed me to use refresh rates over 60hz witch RpiOS doesnt show any refresh rates over 60hz, not that a rpi can really keep up to 120 or 144hz once you do much more than spinning the mouse in a circle

For some reason the default mouse speed is crazy low by default, same dpi is fine on x64 endeavour and windows, but seems 1/5 or lower than “normal” had to change on mouse dpi settings to make it usable. Unsure how to actually fix, most search results talk about acceleration which isnt the problem.

Small suggestion for installs: Maybe just allow downloads of the image so it can just be flashed from rpiimager like most rpi images, would be a bit more straightforward for users more used to the standard rpi way

1 Like

Add this at the end of your /boot/cmdline.txt


We have already recognized this issue and will release a new image with this.

I don’t think we want to go that way. I have tried out other distributions that offer that path and I have few issues with that:

  1. Images are compressed with xz method that take a long time to uncompress.
  2. Its a two step process to burn the image, first uncompress and then flash using Rpi imager
  3. During the install these installers have scripts that expand the image to the entire sd card. This restricts us in a way I’ll explain below

The way we do things

  1. We compress the image using zstd so uncompression speed is very fast for users. Some users have reported less than 1 min speeds
  2. Its a single step process. We use bsdtar to uncompress and burn the image in a single step
  3. We partition the sd card before burning the image. This allows us the flexibility to offer multiple file systems in the install options ext4 and btrfs.
  4. The way we do things is closer the arch way than using RPi imager.
  5. We are planning to integrate the entire process in calamares in the future.

Hope this helps.
:enos: :enos_flag:

1 Like

So from a clean install my cmdline.txt had usbhid.mousepoll=8 changing to 6 seemed to have no noticeable change.

I can totally see the advantages of using the installer vs img files now, i know its still early beta for Eos arm but maybe push the installer to the x64 endeavour repo so desktop endeavour users can have a armEos installer without the need for live usb, i had to put the new iso on a flashdrive just to try the new arm install.

what sort of mouse are using, it is a wireless USB mouse?

can you try usbhid.mousepoll=1??

You can use the instructions here if you want to skip the iso. The iso actually runs the instructions in this repo as a script.

Let us know if you are facing an issues or have questions about the instructions.

My mouse is a Glorious Model D, so wired, mousepoll=1 seems no different than 6 or 8.

Thats great its flashable from desktop Eos ill keep that im mind if i need to reflash

That’s how we do it for testing and development.
Doing it from an ISO would be hard :wink:

Also regarding the CM4 @Pudge says you are a pioneer, so maybe there is new issue for us to tackle. Is there a way to change settings in xfce to solve this?
We haven’t faced this issue at all in Rpi 4/400

Supposedly, the lower the number, the smoother the mouse works, at the expense of more CPU usage. So if 8 works well, I would go to that for less CPU load.

Since it is a wired mouse, and since the mousepoll is at the end of the /boot/cmdline.txt you can try commenting out the usbhid.mousepoll=8 part at the end.

If this is still satisfactory, you can consider leaving that part commented out.


No xfce has no mouse speed setting only mouse acceleration, my desktop kde install does, Could just be something weird with this mouse. I tried a bluetooth mouse and that was normal but idk if that translates.

Well if you need anything tested let me know, but so far all is well and the cm4 is pretty much pi4 -usb3 +pcie

1 Like