ARM devices + Plasma 6 = disaster so far

Plasma 6 hit the Archlinux ARM repos today, and I started to play around with it.

I tried to update the Odroid N2 to plasma 6.
Pacman would not run because of kuserfeedback5 dependencies
Removed kuserfeedback5 with pacman -Rdd kuserfeedback5

Pacman completed the update after the removal of kuserfeedback5

Upon reboot, both x11 and Wayland gave a black screen with only the Welcome window.
No task bar, or anything else.

Then I tried to create new ddimg and rootfs images for Plasma 6.
pacstrap yielded nothing but dependency hell.

I am going to wait a couple of days to ensure all mirrors will be up to date, and then try again.

For now, if you are running KDE plasma on an ARM device, I would recommend not updating for a while.




sounds scary :nerd_face:
I will go update now :crazy_face:

I bet the main issue is the packagelist… also most of them will get removed replaced there are leftovers i see on every update i do from 5 to 6.


I found at least one of the problems, at least where creating images is concerned.

In the Archlinux ARM repos, plasma-meta is


which calls for plasma 5 packages.

plasma-meta should be ver 6.0-2 which calls for the plasma 6 packages.

I posted on the Archlinux ARM forum that plasma-meta needs updating.


there we use plasma-desktop and plasma-workspace


Plasma 6 still have problem open X11 items

it boot on rpi 5 on wayland

1 Like

sadly i have no installed plasma on my sd cards i go with cinnamon on my odroid at the moment.

But i can try install one i do have fast brandnew sd card hanging around.