Are all the eos mirrors down or something?

I been trying to update my eos mirrors and every single one shows me failed to connect.
When i try to use the old mirrors for system update it also says error: failed retrieving file ‘endeavouros.db’ while the rest of the programs and linux related updates work fine.

I havent messed with my system it worked all fine yesterday, my internet works too.

Whats going on?

Can you share the full output from sudo pacman -Sy

I been at it for past 20 min or so, this is just forever hanging here

sudo: /var/db/sudo/lectured is world writable
:: Synchronizing package databases…
core 132.5 KiB 2.54 KiB/s 00:52 [-----------------------------------------] 100%
extra 8.2 MiB 124 KiB/s 01:08 [-----------------------------------------] 100%
multilib 141.3 KiB 17.2 KiB/s 00:08 [-----------------------------------------] 100%

Just for completeness, what does going to:
show you? That’s an EnOS mirror, btw (mine), and I know it’s up :grin:

looks like this

Shows correctly, then - so that’s not the problem! Try putting it first in the list found in the file /etc/pacman.d/endeavouros-mirrorlist, and retry your update.

just checked the folder and i have a ton of eos mirror lists. maybe thats the problem?

Only the one without ‘elaboration’ is in use - the others are updates that weren’t necessarily integrated in to the ‘working’ version. Make sure the first entry in the actual in use file is mine - for testing purposes - then we can see how to ‘fix’ the problem (depending to some degree on where you are (my mirror is in Toronto, Ontario, Canada).

so i can safely delete the other files?
im not sure if its the one in use how do i check that?
creation date wise both endevouros-mirrorlist, mirrorlist and mirrorlist.bak are from today

this is what it looks like for me, should be good?

Well - it would be if the first reference to my mirror did NOT have a ‘#’ character in front of it! The other do not need to be removed, they are harmless - and MAY contain information you can use later. Only the named one with extras gets used. sudo nano /etc/pacman.d/endeavouros-mirrorlist and remove the # - then save and exit and retry your update…

is it good like this? i have never used this before

The previous list was already OK, better keep that. Mirror of @freebird54 was the first uncommented.

Now, can you share the full output of command @dalto asked? And please don’t use screenshots, there are better ways.

not sure what he means then by removing the # in nano. so i should just leave it as it was?


sadly none of this solved my initial thread problem. that i cant update my system anymore.

another issue maybe related i noticed is that my internet got extremly sluggish no matter the browser, even tho speed tests online show 2gpbs download and normal ping, yet sites take forever to load.

i hope anyone can help me fix this
im not sure what to do, i never messed with my system much, except for biweekly mirror list updates (which usually worked in 5 seconds) and full system updates that had no issue so far.

here is a screen from how it looked when i last time tried to system update with yay

nevermind it all seemed to have fix itself, i guess i had very specific internet provider issue


1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.