[Archlinux]pacman 6.0 and pamac-aur compatibility

Did you rebuild it from source or are you using the binary?

1 Like

First I just used the binary and it didn’t work. Then I built yay-git, and it is OK.

4 Likes

It’s already starting. I went to update and cancelled. I’m more than likely going to wait a few days to update and I’m assuming it gets sorted out rather quickly. But the help threads are already starting to come in.

For those that are using pamac they will have to uninstall it first. Then uninstall yay. Then you can update and install pacman 6.0 The option after that is to wait for a new build for yay or use another AUR helper such as Trizen. Or hold off on updating pacman 6.0 until all of these packages are rebuilt? Not sure whats the best solution. I tried building yay again after updating pacman and i had errors and it messed up my KDE install. :cry:

My understanding is that if you build yay-git it will build and work OK - but waiting a day or so is SO much easier :grin:

2 Likes
2 Likes

Pacman 6.0 landed on core. So all pamac-aur / pamac-all version are broken until pamac code is fixed.

The good news is that you can easily rebuild yay from AUR.

1 Like

Hmm, I updated using Pamac and it seemed to run fine, other that it wanted to delete itself.
Pamac is gone but the updated yay gives an error.

:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community                         5,6 MiB  1067 KiB/s 00:05 [--------------------------------] 100%
 multilib is up to date
 endeavouros is up to date
 m-m is up to date
 m-aur is up to date
 m-more2 is up to date
error: could not open file /var/lib/pacman/sync/5a3d4b80-befa-11eb-91d3-184fe5c81c6e?X-Amz-Algorithm=AWS4-HMAC-SHA256&X-Amz-Credential=AKIAIWNJYAX4CSVEH53A%2F20210601%2Fus-east-1%2Fs3%2Faws4_request&X-Amz-Date=20210601T083701Z&X-Amz-Expires=300&X-Amz-Signature=6ed1fd3183463f1c2ac5df1a1a9ed856f818b1ac3c6fa42213c2fb6ee50d985d&X-Amz-SignedHeaders=host&actor_id=0&key_id=0&repo_id=200632352&response-content-disposition=attachment%3B%20filename%3Dm-m.db&response-content-type=application%2Foctet-stream.sig.part: File name too long
error: could not open file /var/lib/pacman/sync/e72cca00-be52-11eb-9bb2-4889f242ae9c?X-Amz-Algorithm=AWS4-HMAC-SHA256&X-Amz-Credential=AKIAIWNJYAX4CSVEH53A%2F20210601%2Fus-east-1%2Fs3%2Faws4_request&X-Amz-Date=20210601T083702Z&X-Amz-Expires=300&X-Amz-Signature=5d6c7db05796e10ff986bb7397abef231d6615fbbfa75a46ed24918ba14ceb50&X-Amz-SignedHeaders=host&actor_id=0&key_id=0&repo_id=257294958&response-content-disposition=attachment%3B%20filename%3Dm-aur.db&response-content-type=application%2Foctet-stream.sig.part: File name too long
error: could not open file /var/lib/pacman/sync/c3f8c600-9b03-11eb-990b-3f7f18a77a32?X-Amz-Algorithm=AWS4-HMAC-SHA256&X-Amz-Credential=AKIAIWNJYAX4CSVEH53A%2F20210601%2Fus-east-1%2Fs3%2Faws4_request&X-Amz-Date=20210601T083703Z&X-Amz-Expires=300&X-Amz-Signature=7c74505df9ba432562afc3a8a18c88f8b1af4e7f3de4b18ca03941beabe5c142&X-Amz-SignedHeaders=host&actor_id=0&key_id=0&repo_id=255379748&response-content-disposition=attachment%3B%20filename%3Dm-more2.db&response-content-type=application%2Foctet-stream.sig.part: File name too long
:: Starting full system upgrade...
 there is nothing to do
:: Searching databases for updates...
:: Searching AUR for updates...
 there is nothing to do

Try:

sudo rm -f /var/lib/pacman/sync/*
sudo pacman -Syu

Didn´t you skip a step, cause now I have even more errors…

fout:kan bestand /var/lib/pacman/sync/5a3d4b80-befa-11eb-91d3-184fe5c81c6e?X-Amz-Algorithm=AWS4-HMAC-SHA256&X-Amz-Credential=AKIAIWNJYAX4CSVEH53A%2F20210601%2Fus-east-1%2Fs3%2Faws4_request&X-Amz-Date=20210601T085858Z&X-Amz-Expires=300&X-Amz-Signature=56ca4cb640932f0e5f4b9e02c5f7f816c4c9b429e6feb4668ce176e4248d4fb0&X-Amz-SignedHeaders=host&actor_id=0&key_id=0&repo_id=200632352&response-content-disposition=attachment%3B%20filename%3Dm-m.db&response-content-type=application%2Foctet-stream.sig.part: Bestandsnaam is te lang niet openen
fout:kan bestand /var/lib/pacman/sync/e72cca00-be52-11eb-9bb2-4889f242ae9c?X-Amz-Algorithm=AWS4-HMAC-SHA256&X-Amz-Credential=AKIAIWNJYAX4CSVEH53A%2F20210601%2Fus-east-1%2Fs3%2Faws4_request&X-Amz-Date=20210601T085858Z&X-Amz-Expires=300&X-Amz-Signature=97ded6822571ddcf9651af2aea1e1e2dad7dd2e887f2abf01f555081ae62b25b&X-Amz-SignedHeaders=host&actor_id=0&key_id=0&repo_id=257294958&response-content-disposition=attachment%3B%20filename%3Dm-aur.db&response-content-type=application%2Foctet-stream.sig.part: Bestandsnaam is te lang niet openen
fout:kan bestand /var/lib/pacman/sync/c3f8c600-9b03-11eb-990b-3f7f18a77a32?X-Amz-Algorithm=AWS4-HMAC-SHA256&X-Amz-Credential=AKIAIWNJYAX4CSVEH53A%2F20210601%2Fus-east-1%2Fs3%2Faws4_request&X-Amz-Date=20210601T085859Z&X-Amz-Expires=300&X-Amz-Signature=4724bd35dd6cbcaff33ea75f54235310e8c759633d0bcec6c6ae9402f3449d20&X-Amz-SignedHeaders=host&actor_id=0&key_id=0&repo_id=255379748&response-content-disposition=attachment%3B%20filename%3Dm-more2.db&response-content-type=application%2Foctet-stream.sig.part: Bestandsnaam is te lang niet openen
fout:m-m: ontbrekende PGP handtekening
fout:m-aur: ontbrekende PGP handtekening
fout:m-more2: ontbrekende PGP handtekening
fout:failed to synchronize all databases (ongeldige of corrupte database (PGP handtekening))

All the dbases have gone obviously.

The first command should have cleared the sync folder and nothing else. The sync folder should be rebuild by the second one. Perhaps it has revealed that the problem is somewhere else?

fout:m-m: ontbrekende PGP handtekening
fout:m-aur: ontbrekende PGP handtekening
fout:m-more2: ontbrekende PGP handtekening

Are these other repositories you have added? There seems to be something wrong with the PGP verification.

Yes, repos from @manuel to get the Pamac binary.

See if you can import the PGP keys again. Or disable those repos for the time being. Pamac’s code seems to need a makeover upstreams anyways after the latest update to pacman.

Ok, I’ll disable those repos and see what happens, the first error is still there though.

You mean these:

fout:kan bestand /var/lib/pacman/sync/5a3d4b80-befa-11eb-91d3-184fe5c81c6e?X-Amz-Algorithm=AWS4-HMAC-SHA256&X-Amz-Credential=AKIAIWNJYAX4CSVEH53A%2F20210601%2Fus-east-1%2Fs3%2Faws4_request&X-Amz-Date=20210601T085858Z&X-Amz-Expires=300&X-Amz-Signature=56ca4cb640932f0e5f4b9e02c5f7f816c4c9b429e6feb4668ce176e4248d4fb0&X-Amz-SignedHeaders=host&actor_id=0&key_id=0&repo_id=200632352&response-content-disposition=attachment%3B%20filename%3Dm-m.db&response-content-type=application%2Foctet-stream.sig.part: Bestandsnaam is te lang niet openen
fout:kan bestand /var/lib/pacman/sync/e72cca00-be52-11eb-9bb2-4889f242ae9c?X-Amz-Algorithm=AWS4-HMAC-SHA256&X-Amz-Credential=AKIAIWNJYAX4CSVEH53A%2F20210601%2Fus-east-1%2Fs3%2Faws4_request&X-Amz-Date=20210601T085858Z&X-Amz-Expires=300&X-Amz-Signature=97ded6822571ddcf9651af2aea1e1e2dad7dd2e887f2abf01f555081ae62b25b&X-Amz-SignedHeaders=host&actor_id=0&key_id=0&repo_id=257294958&response-content-disposition=attachment%3B%20filename%3Dm-aur.db&response-content-type=application%2Foctet-stream.sig.part: Bestandsnaam is te lang niet openen
fout:kan bestand /var/lib/pacman/sync/c3f8c600-9b03-11eb-990b-3f7f18a77a32?X-Amz-Algorithm=AWS4-HMAC-SHA256&X-Amz-Credential=AKIAIWNJYAX4CSVEH53A%2F20210601%2Fus-east-1%2Fs3%2Faws4_request&X-Amz-Date=20210601T085859Z&X-Amz-Expires=300&X-Amz-Signature=4724bd35dd6cbcaff33ea75f54235310e8c759633d0bcec6c6ae9402f3449d20&X-Amz-SignedHeaders=host&actor_id=0&key_id=0&repo_id=255379748&response-content-disposition=attachment%3B%20filename%3Dm-more2.db&response-content-type=application%2Foctet-stream.sig.part: Bestandsnaam is te lang niet openen

?

Disable those extra repos first and then repeat the commands I posted before.

1 Like

Yes, this worked out.

$ sudo rm -f /var/lib/pacman/sync/*
$ sudo pacman -Syu
:: Pakket-databases synchroniseren...
 core                            133,3 KiB   385 KiB/s 00:00 [--------------------------------] 100%
 extra                          1549,8 KiB  1045 KiB/s 00:01 [--------------------------------] 100%
 community                         5,6 MiB  1201 KiB/s 00:05 [--------------------------------] 100%
 multilib                        150,4 KiB   976 KiB/s 00:00 [--------------------------------] 100%
 endeavouros                      17,3 KiB  56,5 KiB/s 00:00 [--------------------------------] 100%
:: Volledige systeemsupgrade starten...
 er valt niets te doen

1 Like

Everything works fine for me except Pamac-all so I guess will have to wait for it to get upgraded…

Good to know that your pacman is working now.
Perhaps you could check with @manuel later on regarding the extra repos when pamac’s issue has been resolved.

Yes, I’ll do that and thanks.

1 Like