Arch user for 1+ years, EndeavourOS ignored my options during install?

When I would install arch, I would run the following line and have a minimal plasma desktop:

sudo pacman -S xorg-server plasma-desktop plasma-nm plasma-wayland-session sddm dolphin konsole nvidia-dkms

I tried doing something similar in the EndeavourOS GUI installer, picking only what I need, but after rebooting I noticed it installed a TON of stuff that I had unchecked, I know that dependencies will auto install but this is stuff that was not required on my Arch install with plasma-desktop:




One of the motivations for trying EndeavourOS was that it uses Dracut by default and also has the lts and zen kernels, all things I would like in Arch, and sure I could have done in it in Arch, but figured if EndeavourOS simplifies the install then why not use it.

Basically I am going for barebones minimal with a couple added things that I find useful.

I am going to try reinstalling and picking No desktop, and installing plasma-desktop manually afterwards like I would in Arch and see if it works.

I also noticed that there was no option for zsh, I had hoped that EndeavourOS would have an option for it, I loved the zsh config that came with manjaro for the short time that I was using manjaro before jumping over to Arch.

Here is the Log:

I actually took screenshots during the install so that I would be able to reference them later (to make installing on additional systems quicker.)

1 Like

My best guess would be that somehow the entire plasma group was rechecked accidentally before the install started. That is sort of what it looks like from the extra package listing.

yad is a dependency for many of the eos apps such as welcome and reflector-simple.

I do minimal installs all the time during my testing and have never seen extra packages brought in like that.


Welcome to the EndeavourOS forum. I hope you enjoy your time here.

Another alternative is to not install any DE or WM in Calamares. Then after the install use the pacman command listed in your OP to install exactly what you want for plasma.



Click on No Desktop and read the paragraph at the bottom of the window.


I will give it another go right now

By selecting “No Desktop”, I was able to still check the boxes for the desktop related packages that I wanted on the next page. This gave me the minimal install I was looking for.

Now there are only a couple of packages that I would like to remove, will tackle them 1 by 1:

Qt V4L2 test Utility
Qt V4L2 video capture utility

Thanks very much for the help guys!

1 Like
~ » yay -Qo /usr/bin/qv4l2 
/usr/bin/qv4l2 is owned by v4l-utils 1.24.1-2


these are mainly support dependencies… in cas eyou want to use a webcam or capture devices…
avahi is dependency for gvfs
This is a “far” support dependency for firefox p.e. may can get removed on pure non gtk setup…

:: edit::
just see … avahi is dependency for a lot of kde stuff in addition… better not remove it :wink:

1 Like

yad is needed by some EndeavourOS tools like Welcome, reflector-simple and akm, to mention a few. (yad-icon-browser is included in yad).
If you don’t want to have them, you could try unselecting all EndeavourOS packages. Note that I haven’t tried that, so it might not work as expected.

Another way is to write your own code in file /home/liveuser/user_commands.bash before starting the install process. More info about this is here:

1 Like

It does work. I do this pretty regularly in my testing.

1 Like

Geez, I just learned something about still being able to check the boxes. Good to know.

I’m glad it worked out for you. I hope to see you around the forum.


1 Like

Thanks everyone, I got everything sorted out and so far I am loving it!

I removed xterm, as well as yad and the things that require it.

I left avahi and v4l-utils installed because they are dependencies for things I don’t want to remove.

I then disabled the avahi daemon and a couple others:

sudo systemctl disable ModemManager
sudo systemctl mask ModemManager
sudo systemctl disable avahi-daemon
sudo systemctl mask avahi-daemon
sudo systemctl disable bluetooth
sudo systemctl mask bluetooth

So far very happy with EndeavourOS! Planning to install this on a couple other machines as well.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.