Arch linux + Plasma in the arch way

I’m trying to learn more about Arch, so I’ve installed it in the arch way, and noticed that there’s still a lot to learn, like not skipping network configuration and chroot to complete this step. :rofl:

imagen

I’ve installed the group plasma that it’s pretty bloated and next time I’ll try plasma-desktop instead.

Any other suggestion to get an Arch linux + plasma “vanilla” installation like the one on EOS would be really appreciated as well as any other advices to get a secure system.

Thanks in advance.

2 Likes

After you have installed the base system, you could download EnOS’ package list for KDE, cp/mv it to the root of the installed system and run the following in chroot:

# pacman -S - < plasma.pkg.list

Replace plasma.pkg.list with the name you give to the downloaded package list.

https://wiki.archlinux.org/title/Security

3 Likes

You can also use the symbol ^ (i.e. ^discover) during installation to exclude packages from a group.

3 Likes

Cool, I’ll try it instead of plasma-desktop and I guess I should not install kde-applications.

Too much to read and learn, I’ve only installed microcode and firewalld.

Thanks for your great advices.

Thanks, it’s a very useful tip.

2 Likes

@Triby

eos-plasma-sddm-config

Just noticed that this one is enos’ specific package that you would want to remove from that list.
Otherwise you would need to add EnOS’ repo to /etc/pacman.conf and its mirrorlist to /etc/pacman.d.
You could also always add these postinstall and install any packages you want from EnOS’ repo.

1 Like

I didn’t do this yet, instead I’ve chrooted to remove plasma and kde-applications, replace them with plasma-desktop and kde-utilities, the result is much better.

imagen
It kept my previous configuration… really cool!

I’ll take a look at EOS’ KDE package and compare it to kde-utilities to see if there any app what I want or need in order to keep this installation free of bloat.

BTW, I use arch! :rofl: No, wait! what I really want to say is that this test is only to learn a little bit more about Arch and its derivatives, but I’m not planning to leave EOS. :purple_heart:

Tried sudo pacman -S kde-utilities ^yakuake, but it gave an error message about package not found, but sudo pacman -S kde-utilities --ignore yakuake worked fine. Did I do something wrong?

4 Likes

Interesting…not that I’m aware of. Perhaps someone more knowledgeable can chime in?

1 Like