Arch linux full system freezes (mainly when playing some games)

I have installed secureboot, using sbctl then I though it might be causing the Arch linux to freeze for some reason so I tried turning it down but that didn’t work. Using NVIDIA BETA 555 drivers othervise games are flickering and wayland it self as well, but it ran without issues even with the beta driver before. I tried adding SWAP as well. I have tried looking into some journalctl logs, but i dont really understand those logs. The system is up to date ofc. When the pc freezes there is lagging sound in the background and the pc needs to be restarted using power button.

journalctl -b -1 -p err

output - https://pastebin.com/CSAWZhvm
EndeavourOS
Kde Plasma, Wayland
AMD Ryzen 3 3100
NVIDIA RTX 2060
16 GB DDR4 RAM

Maybe post the hardware output first. Post the url

inxi -Faz | eos-sendlog

https://0x0.st/XNPI.txt

I see that you your Bios version is P4.31 which was beta. There are newer Bios updates that have newer AMD AGESA. You may want to look that over and update. I personally wouldn’t be using secure boot. Nvidia drivers are installed and loaded but they are beta and Nvidia is buggy at best.

secureboot is there just because dualbooting windows for valorant. As I said without nvidia driver 555 basically whole linux was flickering or visually bugging.

could the issue be cause by not having SWAP? Those system freezes were happening mainly when playing modded minecraft with 8GB RAM allocated to it, so mby?

Try LTS kernel. Install it by running sudo pacman -S linux-lts linux-lts-headers nvidia-dkms

That would mean downgrading nvidia driver right?

Yup. Perhaps it will not give you flickering ?

I only know that secure boot isn’t necessary for Windows either.

It is necessary for valorant it self.

It did, I tried even older drivers. It just did flicker. But maybe I found a fix for the EndeavourOS freezes - EOS didn’t include SWAP when I installed it as I discovered yeasterday. So I added swap partitions and the minecraft seems to be running ok. I think it could be beacause of allocating 8GB of RAM to the MC with 16GB RAM could cause the system to just shut down some processes or something because there was not just enough RAM.

You’ve probably already invested time and even money into this game, but in the future, I’d suggested not playing, or worse, paying for any games that have such requirements.

A general rule even for software. Unless of course you need it for work. :person_shrugging:

it has such requirement because its modded with modpack All The mods 9 so yeah mods are a bit ram hungry sometimes.

And indeed I tried receating the EndeavourOS freeze by turning off swap and playing minecraft for a bit with btop on the second screen and yeah when the ram available went around 1% the system froze. Maybe EndeavourOS should have SWAP turned on by default. Or at least option for turning it on and off during installation. Or maybe telling users that there is not swap by default.

That’s odd. Not a gamer and not familiar with Valorant. Looks interesting though.

Depending on how you installed you have the option to create a swap file automatically on the install which can be resized afterwards. Or you can create a swap file after the install. One doesn’t necessarily need a swap partition.

Edit: A swap partition is also possible if installing using manual partitioning.

Edit2: You can also select no swap! So I’m not sure if that’s what you did?

Oh I’m sorry if that’s the case and I missed it. I did just a normal install without manual partitioning so I’m no sure. If the swap is there by default during not manual install that’s good. But I don’t think I was messing with the swap partition if it was there. So I just created swap file because its easily managed.

2 Likes