Arch gvfs packaging problem?

i have been using linux for over 2 months now and came across a gnome extension which connects to android phone but it fails to work on manjaro,i raised the issue with developer and he said that this issue is with manjaro gvfs packaging, i also tried it on endevouros, but no result, the mount will just not work, everything else works.

i cannot find out if its a manjaro/endeavouros problem or arch packaging problem because this worked totally on fedora gnome and solus gnome, one more thing confusing me was kdeconnect works.

Any help please. Below is the question i asked on manjaro forum:-


Hello @sunny
Do you have sshfs installed? You have to install that package separately and then in Gnome under devices browse files turn on. Or on your device?

Edit: This should work.

The gvfs package on Arch does contain /usr/lib/gvfsd-sftp. What is the packaging issue you are referring to?

I tried all the options available in the user interface, both on the device and on gnome gsconnect, nothing worked, so i asked the developer if he could help me with it, but there were other people with same issue on arch systems like manjaro,

Yes i see sshfs installed in pamac.
and it seem to work on every linux distro other than arch based.

I just tried solus gnome in live mode and it worked, it worked on fedora too without any settings i had to do.

Do you have gnome-keyring installed?

Oh, by the way, Welcome to the EndeavourOS forum. Thanks for giving EndeavourOS a try.
I hope you enjoy your time here.


So you have tried it then?

sunny  sunny-pc  ~  $  sudo systemctl status sshd.server
[sudo] password for sunny:
Unit sshd.server.service could not be found.

This is what i get, i guess thats why its not working??
Yes, gnome-keyring is installed, but i dont think it ever popped up anywhere in last 2 months of usage

EndeavourOS has open ssh installed.

Edit: Did you take a look at this?

Yes, its installed, i just enabled it by doing:-
sunny  sunny-pc  ~  $  sudo systemctl start sshd.service

I’m not sure how gsconnect works but it is same as kde connect. I am on EndeavourOS Cinnamon and i just plug my Android phone in and it connects no problem i just enable usb file transfer. I’m sure it’s the same if i go on my other computer which has Plama and KDE connect. What is the deal with GS connect and or KDE connect? Just easier organization? I don’t use these so i’m not familiar with them much.

I would go out and or reboot then and try repairing the phone? I’m assuming you are doing this wireless?

yes on a wireless connection, on plasma it worked flawlessly, no issues, but somehow i just couldnt make myself to like plasma, gnome was super easy to set up to my liking within 10 mins of install. i am gonna try to reboot and repairing the phone

Welcome! :smile:

On Xfce the android connection is working as expected.
Do you have the following packages installed: android-udev, gvfs-mtp, and optionally android-tools?

If if doesn’t help instantly, try reboot.

installed but not enabled, would be a security issue and also not everyone need it running at all.

I installed and reboot but didnt help…i think now the problem is the app(only it works in every other diatro not based on arch, i tried fedora and budgie)…anyway i am pretty happy with the current set up except vmware horizon client scaling problem for which i just switch to 1920x1080 and use it…i will just use wire for file transfer.

I came across below link for the problem, thanks for the help…

Yes that is on the link i sent you under issues. Glad you found it.

Thanks Rick

Well i don’t need any thanks i just found that info and actually didn’t go through it or anything. I just perused it and thought it may help you. Afterwards when i saw you were able to figure it out i had another look at it and saw that info was there. I just thought at the time well this is the developers stuff so it’s most relevant.

1 Like