Arc menu and application menu extensions are not working

Just now I installed a fresh endeavouros with gnome ,

But when I installed arc menu and application menu, error occurred saying that gmenu can’t be found.

So while installing gmenu from yay, the compilation stopped in midway. Compilation got struck.

Please help me to install arc menu and application menu extension.

It would be a good idea to post the whole terminal output. That might give some clue to some forum member who is able to help you.

Btw, doesn’t Applications Menu come preinstalled? Look into the Extensions app. You would need to enable it in there.

Please don’t post text output as image or photo. Instead copy/paste the output into a code block.

Solved by installing gnome-menus

1 Like

Just in case anyone may see this in the future, I’d like to throw in a little bit of extra information that I think is helpful.

Arc Menu is a Gnome extension that adds a Windows/KDE style launcher and icon to the Gnome desktop, typically it is used in tandem with the Dash to Panel extension as well for the best experience. One thing to note, there are two versions of Arc Menu within the Gnome extensions website; one is actively developed and one is no longer maintained. The actively maintained one is available here: https://extensions.gnome.org/extension/3628/arcmenu/

As it states on that extension page, you must also install gir1.2-gmenu-3.0 or gnome-menus for Arc Menu to function properly. I’ve always installed the gir1.2-gmenu-3.0 package and got Arc Menu working just fine; for OP the gnome-menus package worked for them, either one is fine, you don’t need both, FYI. Enjoy using Gnome :slight_smile:

3 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.