Apps not updating; Truncated zstd input

Earlier today I had an issue after updating where “Reboot Into Firmware” was the only boot option. Not sure if this is related or not, but after repairing that and running updates, I get errors on 3 packages that won’t update and the launchers are missing while the directories are still present. These are brave-bin, librewolf-bin, ungoogled-chromium-bin and the errors are:

error: could not extract /opt/brave-bin/brave (Truncated zstd input)

error: could not extract /usr/lib/librewolf/browser/features/formautofill@mozilla.org.xpi (Truncated zstd input)

error: could not extract /usr/bin/chromedriver (Truncated zstd input)

I’ve been searching both EOS and Arch forums but the issues I’m finding aren’t similar.

1 Like

Uninstall and reinstall each package.

I hoped this would be a remarkably simple solution, I used yay -Rn librewolf-bin and then tried re-installing but it’s giving the same error.

How about clearing the yay cache first and trying to build again?

3 Likes

In fact, it was an easy solution. Even if it’s something simple, there is something to be learned every day. Thanks guys!!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.