Applications have missing toolbars

After originally asking on reddit ( ) thinking it was only Kdenlive with this issue, i have used my computer a bit more and discovered a lot of applications have the same issue (krita, obs, even libreoffice’s toggle menubar function changes nothing)

Applications seem to be missing their menu bars, so the usual file , edit , view … menus are missing. Don’t recall changing anything in that area recently, other than changing themes around a bit (to dark breeze with some options such as borders on)
I’m willing to assume this is a system wide issue, any idea what i can do to solve it, or even investigate it at this point?

Do you have multiple monitors attached to your computer?

Please, show us the output of your

inxi -Fxxc0z

You can post it here using this command and posting the resulting URL:

inxi -Fxxc0z | eos-sendlog


yep, i have two monitors in use. is the output of the sendlog command

Do the windows look differently on different monitors?

I added a link to KDE bug report in my previous post, see above. :wink:

just been looking at that bug report now, seems the solution is either remove the appmenu part or to remove the forced setting.

it looks exactly the same on both monitors. Tried the fix of editing the arc file in the config, but whenever i load up kdenlive it reverts the changes (kate informs me the file was created on disk and that there are differences of it re-adding the hide menu tag back)

Testing on kdenlive through the distribution on yay

Noticed briefly that at one stage the menu bars actually appeared but they were on hidden panel (containing only an icons only task manager) on one of my monitors rather than directly on the application, which are the time disappeared when i closed konsole. Haven’t noticed it since.

1 Like

Good luck in your further research! :v:

1 Like

looked around a bit more in settings. Can’t get the application menu to show naturally yet, but i have gone into Appearance → windows decorations → titlebar buttons → and then added the application menu button to the top, so i can at least access the settings somehow.

Later edition: fixed it partially, seems a panel i had on the left kept going to a global menu, which i removed and it seems to of fixed the issue partially.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.