Application Variety doesn't display in system tray (Plasma 6)

I have been using the application Variety for a number of years. However, since I’ve upgraded to Plasma 6, the icon for Variety no longer displays in the system tray. Is this an issue with Variety or potentially a bug in KDE Plasma 6?

Does it show under the System Tray Settings under Entries at all? If it is what is it set to? Also does the same but occur under and X11 session? (Probably don’t have a solution for you but these are some things to try, I’m off to bed)

Working here:
image

(wayland)

It doesn’t show under entries. I’ll try in X11.

Is this in a system tray widget in Plasma 6?

Well it displays in the system tray in X11, but not in Wayland.

What happens if you login under Wayland under a new user?

Plasma 6 wayland, yes. Launch variety from a terminal, see if you get any errors.

Launching from terminal will launch fine with no errors and will show in the application tray, it just won’t show in the minimized state in the system tray.

I’ll try with a new user to see if I see the same behavior.

Have you tried delaying it starting? Something like:

#!/bin/bash
sleep 10
variety&

Then run the script in startup.

So no errors launching from terminal. However tonight I was looking at my autostart settings to disable Plasma discover (different issue now).

Now I see this in the auto start details;

2024.06.22 21:16: Failed to load module "appmenu-gtk-module"
    gtk_widget_get_scale_factor: assertion 'GTK_IS_WIDGET (widget)' failed
    gtk_widget_get_scale_factor: assertion 'GTK_IS_WIDGET (widget)' failed
    WARNING: 2024-06-22 21:16:10,004: create_menu() 'Variety-slideshow not installed.'

is it installed?

I installed it but still get an error:
create_menu() 'Variety Slideshow is not installed. This is an optional extension adding pan and zoom slideshows to Variety"

I can’t find a package for Variety Slideshow.

I get this too, just a warning.