AppImage can't run; Others work fine

When i try to run jetbrains-toolbox it stops and this error comes up:

This doesn't look like a squashfs image.

Cannot mount AppImage, please check your FUSE setup.
You might still be able to extract the contents of this AppImage 
if you run it with the --appimage-extract option. 
See https://github.com/AppImage/AppImageKit/wiki/FUSE 
for more information
open dir error: No such file or directory

I saw other people having the same issue but none of the solutions worked.

I have fuse2, fuse3, squashfs-tools and squashfuse installed.
The fuse module is also loaded in the kernel:

lsmod | grep fuse
fuse                  212992  5

I had it a good while back with Zoho Mail and all I ever did was relaunch Zoho til the message went away.

Hi new user! Kidding. Welcome to the community! :enos:

Now, regarding Appimages: on rare occasions, they just don’t work no matter what you do. And it is difficult to tell if it’s a user error or if it was just packaged incorrectly.

So, rather than using your time trying to figure out what’s wrong, it would be better to get another version of the app - whether that’s from the AUR, a flatpak, a .sh file (program file), or a snap.

1 Like

Number one reason I’ve seen for this in the past, is users haven’t made it executable.

I actually think this is the most common reason. Admittedly, I don’t have any empirical evidence of this, but from helping many users and my own experience. I know other users love appimages, but experience has rarely been positive and I generally avoid them.

:point_down: This is good advice :point_down:

Note: The number one reason and the most common reason can’t be different.

Regarding users not making it executable: I’ve noticed that lately, the packagers often do this for end users to avoid such user errors. In fact, I just downloaded the package from their website. It comes with execute permissions.

I use Appimages and this is literally the only issue I have with them - on that rare occasion, they just don’t work.


image


All of the above work just fine.



Loads just fine as well. So, yes, in this case it is probably user error.

@meo209 : Please post the outputs of

pacman -Qi appimagelauncher
and
pacman -Qi glib2

Appimagelauncher is your friend. :man_facepalming:

1 Like

@ddnn Google is your friend to do the research.

So i got it working. The AUR one was broken for me but just downloading the raw appimage from the jetbrains website worked fine. Thanks for your help :smile:

And my response before this (images included) is your friend to do your research on why your comment makes no sense. But let’s leave it at that.

Okay, great! Please mark this post as solved. Cheers!

Well, we may just have to agree to disagree on this. Experience says otherwise, for me. Besides, the number one user error can be completely different than the most common reason for an app not running.

You may well be right. As I noted, I don’t use them, so I wouldn’t know this.

Brilliant. Then that eliminates one possible error.

As you say, this instance appears to be user error.

1 Like