Apperance is not changing

The apperance of tweaks got changed but the system appearance was not changed

Can you describe your issue in more detail?

What did you change in gnome teaks? What is the result?

I have changed the legacy application means changed the theme
After changing the application it worked for tweaks but the others applications on the system were not able to changed

They may not be legacy applications then. They would be changed with dark mode in the normal settings.

Then what should i doo

I’m afraid you have to describe more closely what you expect your desktop to look like. If this is the first time you installed anything GNOME you’re going to be frustrated because it’s the total intention to look like any other GNOME desktop, even on a different distro. What I mean is, the top line with the date and time, and with the icons for Wifi, volume etc. cannot be changed. The bottom panel cannot be changed. Cannot have desktop icons – this is the most frustrating thing for me because sometimes that D.E. rejects “dot-desktop” files. There’s more which is mind-boggling but I don’t want to bring out the defenders of GNOME thinking I’m bashing it. I do have Gecko “Static” GNOME (v41.8) and only saying things out of experience with it.

Erm, noticed one of the screenshots which changed the position of the date and time but, still that could only be at the top. That whole line cannot be moved to the bottom like could do so with KDE or XFCE, for example.


Too bad program icons still can’t be on right-hand side but this is amazing. This is a far cry from what I knew about Fedora 35 which looked dorky, especially the huge title bar for the Terminal that it insisted on. I have to take better notes about GNOME. Still, it could go much further with allowing its “black jacket” appearance changed.

Yes bro that’s how i did it but after selecting the theme from legacy application the UI of tweaks got changed
But it wasn’t applied in other systems or applications

I really don’t know how GTK and Qt operate but most programs use either of those GUI toolkits. Otherwise if the app came from KDE or some other source not GNOME, then it’s less likely to respond to indications about appearance called upon by GNOME. A few programs were created “to get it done” and “needs to work most of all” which means hardcoding settings. This is expected from simple programs that aren’t updated much.

I mentioned KDE but if an app from that camp is installed into GNOME D.E. or some other then it hauls in a lot of dependencies eating a lot of disk space, and it might be to make sure it keeps appearance as expected from Plasma. It’s the other way around in non-GNOME environment and this is most noticeable with most Flatpaks. Even with the latest GNOME, a Flatpak could decide to install an earlier version of the framework from the same corporation which is irritating. Those could also resist being “tweaked”.

1 Like

Yes, it’s a thing with GNOME, GTK4 and libadwaita. Some system apps use the default theme and they cannot be easily modified. I believe there are workarounds to theme system apps like Settings, GNOME Console, Text Editor etc., and I also believe there are certain themes that fully support GTK4, but I personally have not tried yet.

Here’s a “demonstration” screenshot of my desktop. GNOME system apps like Console, Text Editor, and Settings remain with the default theme, but Terminator, GNOME Tweaks, and Disks are properly themed with Nordic-Polar-v40, along with Flatpaks that do not use GTK4/libadwaita. I don’t really mind because I don’t use system apps enough to be bothered by the different theme, but if it does bother you, you will have to do a bit more work to change them.



No problem here. You should check your settings.

I understand that Settings > Appearance > Default/Dark changes the color scheme from light to dark, but it doesn’t enable Shell or Legacy Applications theme for system apps. Default/Dark switch does work for me, but it doesn’t apply title bar, window action keys, etc, as shown here:

1 Like