Apparently deleted my boot partition (and/or more)

Hi to everyone! (Posting from Live ISO :sweat_smile:)

This week when I forcefully restarted after a freeze I got something like the next block - if I remember correctly on /dev/sda2 -.


fsck from util-linux 2.26.2
/dev/sda6 contains a file system with errors, check forced.
/dev/sda6: Inodes that were part of a corrupted orphan linked list found.

        (i.e., without -a or -p options)
fsck exited with status code 4
The root filesystem on /dev/sda6 requires a manual fsck
# [...]
(initramfs) _

So I followed what is suggested in the source linked before which is yes to all without knowing much what I was doing (Hoping to always learn from mistakes and decisions like that haha). Something like the next fsck /dev/sda2 and got prompted several times for errors, I answered yes to every prompt.

After that I rebooted and I got a message from the computer that it couldn’t recognize any boot media. Right after that I enter the UEFI to see the same, I have no Boot media, only this:

# (Boot menu)
EFI Hard Drive (ST1000LM035-1RK172)
EFI PXE Network

I tried to Chroot with a live ISO - from the Grub incident of august more or less as I learned -.

Tried to mount (please check):

[liveuser@eos-2022.09.10 ~]$ sudo lsblk -f
NAME   FSTYPE   FSVER            LABEL       UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
loop0  squashfs 4.0                                                                     0   100% /run/archiso/airootfs
├─sda1 vfat     FAT32            NO_LABEL    B303-E0D5                                           
├─sda2 ext4     1.0                          296fc2f2-67e8-468b-b86b-8231bf911b58                
└─sda3 swap     1                swap        c52dec28-c60f-429f-a5d3-53bda411f9c2                
sdb    iso9660  Joliet Extension EOS_202209  2022-09-10-10-51-40-00                              
├─sdb1 iso9660  Joliet Extension EOS_202209  2022-09-10-10-51-40-00                     0   100% /run/archiso/bootmnt

[liveuser@eos-2022.09.10 ~]$ sudo mount /dev/sda2 /mnt
mount: /mnt: can't read superblock on /dev/sda2.
       dmesg(1) may have more information after failed mount system call.

And got this log from journalctl -k:

From this I would like to ask to any that can help me:

  1. I am doing the chroot process correctly? (Actually I fell I don’t understand it so well like the last time from here)
  2. Is there a way I could recover my previous data or installation, I actually deleted it or its just corrupted (or both)?
  3. What are my next steps

More info


For more context, I was finishing a Job for college - with a lot of things opened - and usually what happens is my system can’t hold it no more and freezes (happened a few times before). That is usually a small problem because when I restart I recover the session through something like a journal, I don’t really know whats that about but is very nice.


From INXI (inxi -FAZ --no-host):


Relatively new Linux user here, I started with EndeavourOS less than a year ago and I wanted to take this opportunity to say that it has been a very good experience and very educational Im very thankful of this community.

#arch-based-related-questions #arch-based-related-questions:kernel-hardware

you have error on ata1 ( search for ata1 in log )
==> first recheck cables
after with USB live iso
check for smartctl

1 Like

Hi @Stephane thanks for your time.
Rechecked cables :white_check_mark:
And this is smartctl log (on every /dev/sda):
smartctl /dev/sda2

[liveuser@eos-2022.09.10 ~]$ sudo smartctl /dev/sda2
smartctl 7.3 2022-02-28 r5338 [x86_64-linux-5.19.7-arch1-1] (local build)
Copyright (C) 2002-22, Bruce Allen, Christian Franke,

ATA device successfully opened

Use 'smartctl -a' (or '-x') to print SMART (and more) information

$ smartctl -a /dev/sda2 (log here)
$ smartctl -a /dev/sda2 after trying to mount /dev/sda2 log:

[liveuser@eos-2022.09.10 ~]$ sudo smartctl /dev/sda2
smartctl 7.3 2022-02-28 r5338 [x86_64-linux-5.19.7-arch1-1] (local build)
Copyright (C) 2002-22, Bruce Allen, Christian Franke,

Short INQUIRY response, skip product id
A mandatory SMART command failed: exiting. To continue, add one or more '-T permissive' options.

and with -T permissive (I don’t really know what it is for)

[liveuser@eos-2022.09.10 ~]$ sudo smartctl -T permissive /dev/sda2
smartctl 7.3 2022-02-28 r5338 [x86_64-linux-5.19.7-arch1-1] (local build)
Copyright (C) 2002-22, Bruce Allen, Christian Franke,

Short INQUIRY response, skip product id

For whatever it’s worth I tested all the above with:

  • /dev/sda
  • /dev/sda1
  • /dev/sda2
  • /dev/sda3

what would be the next step?

then retry fsck /dev/sda2

Got this:

[liveuser@eos-2022.09.10 ~]$ sudo fsck /dev/sda2
fsck from util-linux 2.38.1
e2fsck 1.46.5 (30-Dec-2021)
/dev/sda2: recovering journal
Error reading block 120818564 (Input/output error).  Ignore error<y>? 

Sorry, I’m not very confident since the last time. I ignore errors?

if there data on sda2 —> make a save
then try

e2fsck -f -y -v /dev/sda2

How should I make a save from /dev/sda2?

Something that has me worried and ignored in the first post is that I remember not so clearly, that besides ignoring errors fsck prompted me to rewrite on the blocks. Also from my INXI and other programs it looks like /dev/sda2 is empty from the available space.

So looks it is possible to backup a disk via dd ill manage to backup the data and return later to update with what you pointed out @Stephane. Thanks!

1 Like

Hello again. Hope you having a nice day.

After doing what you pointed out I can mount sda2 and sda1 on /mnt and /mnt/boot/efi respectively and chroot into my system and see all my files in /home.

From that I present the following:

  1. At booting still no boot partition e.g As my first post
  2. When doing fsck /dev/sda2 (I cancel it):
e2fsck 1.46.5 (30-Dec-2021)
/dev/sda2 contains a file system with errors, check forced.
Pass 1: Checking inodes, blocks, and sizes
Inode 6164727 extent tree (at level 2) could be narrower.  Optimize<y>? /dev/sda2: e2fsck canceled.

/dev/sda2: ********** WARNING: Filesystem still has errors **********

What should I do?
At this point could I run grub-install?

you can go for that

sudo e2fsck -f -y -v /dev/sda2
1 Like

Hi again. So has been approximately 5 hours since I ran this command and its still checking “Inode” by Inode apparently.

A lot of blocks like this:

Unattached inode 14294363
Connect to /lost+found? yes

Inode  14294363 ref count is 2, should be 1. Fix? yes

From looking at the last log of first running e2fsck Im thinking that is still a long way to go. Probably millions from this log of the last lines of first running e2fsck (previous reply)

Error reading block 214990848 (Input/output error).  Ignore error? yes

Force rewrite? yes

Error writing file system info: Input/output error

/dev/sda2: ***** FILE SYSTEM WAS MODIFIED *****

Sadly since I am in final exams and have no time to wait my decision at this point is to try a fresh installation from the bootable usb (RIP last system :frowning: ).

If you still there and have any advice @Stephane I would be really grateful, I would be trying to reinstall in the next hour or so.

Edit: my guess is that blocks have nothing to do with inodes, sorry for that. Even in that situation the time it is taking is soo much for me, and don’t know what to expect or how much.

Just finished trying to run EndeavourOS installation and it failed with the same.

Calamares log:

Job: Check file system on partition ‘/dev/sda2’

Command: e2fsck -f -y -v /dev/sda2

2022-12-11 - 23:14:17 [6]: void Calamares::ViewManager::onInstallationFailed(const QString&, const QString&)
    Calamares will quit when the dialog closes. 
2022-12-11 - 23:14:17 [6]: QML Component (default slideshow) deactivated
2022-12-11 - 23:14:17 [6]: void Config::doNotify(bool, bool)
    Notification not sent; completion: failed 

full log :
from journalctl -k:

Now I’m looking forward to have back my computer as soon as possible because is urgency, either via a fresh installation or my old system.

Could anyone guide me?

your disk is dead , they were report errors in journallog
==> change disk


One disk is on the way. Thanks a lot for your time @Stephane. Have a nice week! :grinning:

really looks like drive failing hardware side…
Only as a recommendation on rescue drives it is best to clone it to another drive or create an image of the drive and do the rescue on cloned or image not an the drive that is failing.

1 Like

Thank you! I will apply this next time

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.